]> git.sven.stormbind.net Git - sven/exfat-utils.git/blobdiff - debian/rules
Added "-Wall -std=c99" to the CFLAGS from the list of default flags given in the...
[sven/exfat-utils.git] / debian / rules
index ceff3f1348c629df4d3d9a143c43b3835a34d38e..0c77679525b304ca9580369b3cb581214b516c57 100755 (executable)
@@ -1,30 +1,18 @@
 #!/usr/bin/make -f
 # -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export CCFLAGS = $(CFLAGS) -Wall -std=c99
+
 %:
-       dh $@ 
+       dh $@
 
 override_dh_auto_build:
        scons
 
 override_dh_auto_clean:
        scons -c
-
-override_dh_auto_install:
-       mkdir -p debian/exfat-utils/sbin
-       cd debian/exfat-utils/sbin && \
-               ln -s exfatfsck fsck.exfat; \
-               ln -s mkexfatfs mkfs.exfat
-
-       mkdir -p debian/exfat-utils/usr/share/man/man8
-       cd debian/exfat-utils/usr/share/man/man8 && \
-               ln -s exfatfsck.8.gz fsck.exfat.8.gz; \
-               ln -s mkexfatfs.8.gz mkfs.exfat.8.gz
+       rm -f config.log