128c4db2c4d5820be078991abc1eef60961a2596
[sven/java-package.git] / debian / changelog
1 java-package (0.53) UNRELEASED; urgency=low
2
3   * Team upload.
4   * Added support for early access releases (Closes: #721136)
5   * Added support for GA and FCS releases
6   * Updated the package description:
7     - no longer recommend openjdk-6
8     - mention the compatibility with Java 8
9
10  -- Emmanuel Bourg <ebourg@apache.org>  Wed, 28 Aug 2013 19:34:41 +0200
11
12 java-package (0.52) unstable; urgency=low
13
14   [ Sylvestre Ledru ]
15   * Team upload
16   * Upload to unstable
17   * Ack the NMU of David Prévot (thanks!)
18   * Standards-Version updated to version 3.9.4
19   * Remove obsolete variable from the changelog
20   * Add support of ARM upstream binary by James Page and Matthias Vill.
21     Thanks guys! (Closes: #687375)
22   * Change the installation path from
23     /usr/lib/jvm/jdk-6.38-oracle-x64 or /usr/lib/jvm/jdk-7.10-oracle-x64
24     to
25     /usr/lib/jvm/jdk-6-oracle-x64 and /usr/lib/jvm/jdk-7-oracle-x64
26     Thanks to Constantin Makshin for the patch (Closes: #696227)
27
28   [ Cédric Pineau ]
29   * Fix lintian errors and warnings
30
31   [ Gabriele Giacone ]
32   * Add {mozilla,firefox}-javaplugin.so for update-java-alternatives.
33   * Fix plugin directories. Closes: #686216
34
35   [ Emmanuel Bourg ]
36   * Switched to the 3.0 (native) package format
37   * debian/control: Use canonical URLs for the Vcs-* fields
38   * debian/copyright: Switched to the Machine-readable format 1.0
39   * Updated the manpages to reflect the latest naming changes
40   * Removed the unused provided dependencies (j2sdk<version>, j2re<version>)
41   * Provide the java<version-1>-runtime and java<version-2>-runtime dependencies
42     (Closes: #691063)
43   * Provide the java<version>-sdk dependencies to match the openjdk package
44   * Use the upstream versioning scheme (i.e 7u13 instead of 7.13)
45     to match the convention used by the new openjdk packages
46   * Renamed the script files (j2sdk->jdk, j2re->jre, j2se->javase)
47
48  -- Sylvestre Ledru <sylvestre@debian.org>  Wed, 05 Jun 2013 13:43:55 +0200
49
50 java-package (0.51~exp1) experimental; urgency=low
51
52   * Add firefox-javaplugin.so alternative Closes: #673670 and LP: #1024368
53   * Add java5 and 6-{runtime|sdk|...} to the provides line in generated packages Closes: #684993 and LP: #995655
54   * Drop installation debconf note Closes: #685082
55   * Correct handling of amd64 in oracle-jdk6.1->4 and improve error message when used with unknown archives
56   * Add support for earlier oracle-jdk6 version
57
58   [Emmanuel Bourg]
59   * Improved detection of the JRE/JDK version (supports 2 digits Java 7 updates) Closes: #597294
60   * Brand and naming cleanup
61   * Documentation directory changed to be /usr/share/doc/oracle-javaV-doc (for oracle)
62
63   [Joerg Schirottke]
64   * Add mozilla-javaplugin.so alternative
65
66  -- Cédric Pineau <cedric.pineau@gmail.com>  Sat, 18 Aug 2012 11:00:34 +0200
67
68 java-package (0.50+nmu2) unstable; urgency=high
69
70   * Non-maintainer upload.
71   * Allow two digits in Java 7 updates. Closes: #597294, #698108
72
73  -- David Prévot <taffit@debian.org>  Tue, 15 Jan 2013 15:06:26 -0400
74
75 java-package (0.50+nmu1) unstable; urgency=low
76
77   * Non-maintainer upload.
78   * Drop installation debconf note. Closes: #685082
79
80  -- David Prévot <taffit@debian.org>  Thu, 06 Sep 2012 18:38:03 -0400
81
82 java-package (0.50) unstable; urgency=low
83
84   * Java-package reset for reintroduction in debian (removal of all
85     previously supported jvm, global refactoring).
86   * Add support for Oracle Java 6 (update >= 10)
87   * Add support for Oracle Java 7
88   * Add support for .jinfo file (update-java-alternatives tool)
89   * Use jdk included jre binaries (jdk/jre/bin/*)
90   * Print usage information on install
91
92   [ Sylvestre Ledru ]
93   * Long description removed
94   * debian-rules-missing-recommended-target removed
95   * maintainer-script-lacks-debhelper-token removed
96   * Declare the debian/compat to 7 to avoid warnings
97   
98   [ Michael Kock ]
99   * Remove Java plugins for all browsers (Closes: #367887).
100   * Add support for Sun Java 6 Update XX (Closes: #514364).
101
102  -- Cédric Pineau <cedric.pineau@gmail.com>  Thu, 22 Dec 2011 11:42:13 +0100
103
104 java-package (0.42) unstable; urgency=low
105
106   * Provide java*-runtime-headless and java*-sdk names for generated
107     packages.
108   * Recommend dpkg-dev and gcc. Closes: #281766, #405814.
109
110  -- Matthias Klose <doko@debian.org>  Sat, 02 Aug 2008 12:10:52 +0200
111
112 java-package (0.41) unstable; urgency=low
113
114   * Added support for new SUN JDK/JRE for amd64 downloads. Thanks to
115     Artyom Gavrichenkov for the initial patch.
116
117  -- Michael Koch <konqueror@gmx.de>  Fri, 21 Mar 2008 17:20:35 +0100
118
119 java-package (0.40) unstable; urgency=low
120
121   * Add support for ibm-java2-sdk-5.0-6.0-linux-$arch.tgz. Closes: #462399
122     Thanks to Evgeni Dobrev for the patch.
123   * Fixed spelling error in long description: debian -> Debian.
124
125  -- Michael Koch <konqueror@gmx.de>  Thu, 24 Jan 2008 22:48:46 +0100
126
127 java-package (0.39) unstable; urgency=low
128
129   * Added support for IBM JDK 6.0 final release.
130   * Updated Standard-Version to 3.7.3.
131   * Updated debhelper level to 5.
132
133  -- Michael Koch <konqueror@gmx.de>  Tue, 18 Dec 2007 07:38:34 +0100
134
135 java-package (0.38) unstable; urgency=low
136
137   * Mention SUN JDK 6 in REAME.Debian. Closes: #448258.
138   * Fixed typo when creating version number for SUN JDK 6. Closes: #451935.
139   * Fix handling of symlinks for ControlPanel, HtmlConverter and java-rmi.cgi
140     from SUN JDK 6. Closes: #448351.
141
142  -- Michael Koch <konqueror@gmx.de>  Fri, 30 Nov 2007 00:03:50 +0100
143
144 java-package (0.37) unstable; urgency=low
145
146   * Added libstdc++5 to Recommends of generated package. Closes: #446334.
147
148  -- Michael Koch <konqueror@gmx.de>  Thu, 25 Oct 2007 22:45:42 +0200
149
150 java-package (0.36) unstable; urgency=low
151
152   * Fixed package description to include more supported JDKs.
153     Closes: #447615, #447617.
154
155  -- Michael Koch <konqueror@gmx.de>  Wed, 24 Oct 2007 09:56:52 +0200
156
157 java-package (0.35) unstable; urgency=low
158
159   * Use 'date -R' instead of the deprecated '822-date'. Closes: #441229.
160   * Fix generation of .changes file. Closes: #332643.
161     Thanks to Christoph Goehre for the patch.
162   * Add possibility to add a configured revision to the version.
163     Closes: #442246. Thanks to Christoph Goehre again for the patch.
164
165  -- Michael Koch <konqueror@gmx.de>  Fri, 14 Sep 2007 17:28:13 +0200
166
167 java-package (0.34) unstable; urgency=low
168
169   * Fixed SUN JDK on amd64. Closes: #439221.
170
171  -- Michael Koch <konqueror@gmx.de>  Fri, 24 Aug 2007 00:41:54 +0200
172
173 java-package (0.33) unstable; urgency=low
174
175   * Fixed postinst scripts for SUN JDK 1.4, 5 and 6. Closes: #435632.
176
177  -- Michael Koch <konqueror@gmx.de>  Thu, 02 Aug 2007 18:43:40 +0200
178
179 java-package (0.32) unstable; urgency=low
180
181   * Added support for iceweasel. Closes: #433445.
182   * Fix dangling links for SUN Java 5. Closes: #305053.
183   * Depend on libx11-6 and libasound2. Closes: #289004.
184   * Fix building on ia64. Closes: #355465.
185
186  -- Michael Koch <konqueror@gmx.de>  Thu, 19 Jul 2007 22:51:31 +0200
187
188 java-package (0.31) unstable; urgency=low
189
190   * Reapplied changes from 0.28 to 0.29. Closes: 322843.
191
192  -- Michael Koch <konqueror@gmx.de>  Tue, 10 Jul 2007 08:16:14 +0200
193
194 java-package (0.30) unstable; urgency=low
195
196   * Added support for SUN JDK 6u2 (and following updates).
197   * Added support for ibm-java2-jre-5.0-5.0-linux-ppc.tgz.
198     Thanks to B. Zhang.
199
200  -- Michael Koch <konqueror@gmx.de>  Sun, 08 Jul 2007 09:33:29 +0200
201
202 java-package (0.29) unstable; urgency=low
203
204   * Added support for SUN Java 6 and IBM Java 6.
205     Closes: #322843, #402642, #418592, #425508, #430026.
206   * Added myself to Uploaders.
207
208  -- Michael Koch <konqueror@gmx.de>  Tue, 26 Jun 2007 17:40:04 -0100
209
210 java-package (0.28) unstable; urgency=low
211
212   * Modified to reflect migration to Subversion
213   * Bumped standards to version 3.7.2, no changes
214   * Corrected test for AMD64 architecture during plug-in detection
215   * Corrected detected version for IBM Java 5 JDK on AMD64 (Closes: #345775)
216   * Repaired alternatives handling for IBM Java 5 JREs and JDKs
217     (Closes: #338569)
218   * Corrected pathing for alternatives installation for Mozilla and
219     Firefox plugins (Closes: #341751)
220   * Relaxed architectural restrictions on plugin alternative 
221     installation for IBM Java 5 JREs and JDKs (Closes: #343837)
222   * Added plugin installation for the new packaging of Firefox 1.5 and
223     later (Closes: #341749)
224   * Modified warning suppression for dh_shlibdeps to accommodate 
225     changes in dpkg-dev (Closes: #354427)
226   * Added quotes to variable tests for maintainer name and email 
227     (Closes: #342623)
228   * Refactored architecture evaluation to eliminate repetition and
229     evaluate DEB_BUILD_GNU_TYPE correctly for i486-linux-gnu
230   * Removed dependency on 'coreutils | stat' from control file, as
231     the dependency is satisfied within essential (Closes: #370002)
232
233  -- Barry Hawkins <barry@alltc.com>  Mon, 26 Jun 2006 11:19:08 -0400
234
235 java-package (0.27) unstable; urgency=low
236
237   * Added support for IBM Java2 5.0 JREs and JDKs (Closes: #337129)
238   * Corrected missing alternatives links for all JREs and JDKs
239     (Closes: #317492)
240   * Added conditional wrapping around dh_compress to account for
241     JRE/JDKs that do not ship manpages (Closes: 301738)
242   * Removed java-common from Provides: for JRE and JDK packages.
243
244  -- Barry Hawkins <barry@bytemason.org>  Tue, 08 Nov 2005 12:16:24 -0500
245
246 java-package (0.26) unstable; urgency=low
247
248   * Update standards version to 3.6.2
249   * Resolve issues with powerpc-linux support detection (Closes: #317671)
250   * Added support for Blackdown 1.4.2+02 release (Closes: #316831)
251   * Added support for packaging Sun JDK documentation (Closes: #272971)
252   * Modified make-jpkg behavior to default the generated packages' 
253     name and email address for the maintainer to Debian Java Maintainers
254     (Closes: #325554)
255
256  -- Barry Hawkins <barry@bytemason.org>  Thu, 18 Aug 2005 00:43:17 -0400
257
258 java-package (0.25) unstable; urgency=low
259
260   * Cope with dpkg's new way of expressing architectures (Closes: #313555)
261   * Re-exec with fakeroot if needed (Closes: #310132)
262
263  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Sun, 10 Jul 2005 18:50:40 +0200
264
265 java-package (0.24) unstable; urgency=low
266
267   * Added plugin alternatives support for i386 IBM JREs and JDKs
268   * Corrected pathing for plugin alternatives to reflect difference in 
269     layout between JREs and JDKs for Sun and Blackdown (Closes: #305219,
270     #301806)
271
272  -- Barry Hawkins <barry@bytemason.org>  Wed, 21 Apr 2005 01:02:03 -0400
273
274 java-package (0.23.1) experimental; urgency=low
275
276   * Added architecture-specific pathing for plugin alternatives for 
277     Blackdown 1.3 and 1.4 JREs and JDKs
278
279  -- Barry Hawkins <barry@bytemason.org>  Wed, 06 Apr 2005 00:03:40 -0500
280
281 java-package (0.23) unstable; urgency=low
282
283   * Further expanded 1.3.1 Blackdown JRE/JDK support for i386
284   * Added architecture-specific pathing for plugin alternatives for 
285     Sun 1.4 and 1.5 JREs and JDKs (Closes: #301806)
286   * Added recommends for system elements required by applets and 
287     graphical user interface elements (Closes: #300817)
288   * Jeroen van Wolffelaar:
289     + Fixed packages description to not have too long lines, and make the 3
290       items an enumeration
291
292  -- Barry Hawkins <barry@bytemason.org>  Fri, 01 Apr 2005 00:36:40 -0500
293
294 java-package (0.22.1) experimental; urgency=low
295
296   * Corrected IBM and Blackdown JRE/JDK file size specifications
297   * Added support for additional 1.3.1 Blackdown JREs and JDKs for i386,
298     powerpc (Closes: #301092)
299   * Added installation of javaws alternative for Sun 1.5 JREs and JDKs 
300     (Closes: #300303)
301
302  -- Barry Hawkins <barry@bytemason.org>  Thu, 24 Mar 2005 13:20:18 -0500
303
304 java-package (0.22) unstable; urgency=low
305
306   * Corrected IBM JRE/JDK scripts to accurately reflect the supported 
307     IBM JDKs and JREs in the generated SUPPORTED file
308
309  -- Barry Hawkins <barry@alltc.com>  Fri, 18 Mar 2005 10:21:53 -0500
310
311 java-package (0.21) unstable; urgency=low
312
313   * Enable support for IBM JDKs and JREs for x86, amd64, powerpc, 
314     powerpc64, and s390 architectures, based upon a patch by Rico 
315     Schiekel (Closes: #264137)
316   * Enable suppport for Blackdown 1.3.1 JDK and JRE for PowerPC 
317     architecture. (Closes: #296205)
318   * Update documentation and to reflect current supported JDKs and JREs
319
320  -- Barry Hawkins <barry@alltc.com>  Mon, 14 Mar 2005 03:18:39 -0500
321
322 java-package (0.20) unstable; urgency=low
323
324   * Make the postinst & rm for generated packages #!/bin/bash, as we use
325     bash-specific features (Closes: #292179)
326   * Drop the df output parsing, use '/usr/bin/stat' instead (Closes: #293487,
327     #289006, #293350)
328   * Drop the now obsolete peer stuff from the source package
329   * Change priorities, 313 for 1.3, 314 for 1.4, etc (Closes: #292451)
330   * Don't dh_strip, fiddling with upstream's binaries apparantly breaks stuff
331     (Closes: #291238)
332
333  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Tue, 08 Feb 2005 15:04:51 +0100
334
335 java-package (0.19) unstable; urgency=low
336
337   The "Joshua Kwan <joshk@debian.org> rocks!" release.
338
339   Joshua Kwan:
340   * Unclutter Debian build system and rework package slightly so that
341     *debian packages are not needed anymore. The necessary files will be
342     included in the generated packages. (Closes: #291145, #289245, #284779)
343   * Add support for Blackdown 1.4.2+01 build. (Closes: #285405)
344   * Fix support for Sun 1.5.0 amd64 builds due to typo. (Closes: #290879)
345   * Mozilla browser plugin name changed in 1.4.2 versions. Detect and correct.
346     (Closes: #273730)
347   * Use --block-size=1M instead of -BM. (Closes: #289005, #291161)
348   * Disable support for Sun JDK 1.3 due to its dependencies on libraries
349     that are simply not available anymore. (Closes: #272972)
350   * Fix up short description a little bit.
351   * Bump Standards-Version to 3.6.1 (no changes)
352   * Be a bit more conservative with the real-root test.
353   * Remove last j2se-package references.
354   * Change Suggests on fakeroot to a Depends because it is worthless both
355     as real root and as a normal user without fakeroot.
356
357   Jeroen van Wolffelaar:
358   * Use DEBFULLNAME, DEBNAME and DEBEMAIL if available, and don't ask for
359     those values in that case. (Closes: #279653)
360   * Updated documentation regarding dropped Sun 1.3 support
361   * Work around multiline df output caused by long device names
362     (Closes: #289006)
363   * Add Replaces: for the generated packages on their *debian counterparts
364
365  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Tue, 25 Jan 2005 00:05:06 +0100
366
367 java-package (0.18) unstable; urgency=low
368
369   * Added myself to Uploaders
370   * Fix security hole (inscure temp file creation) plus lots of needless I/O
371     in free disk checking function
372   * Added support for Sun's JDK/JRE 1.5 patch levels, based on a patch by
373     Peter Marschall <peter@adpm.de> (Closes: #286718, #287857)
374   * Bail out if running as real root (works around the evil parts of Sun's
375     install script that unconditionally writes to /etc, see #266273, #280707)
376   * Fix typo in j2re.sh that apparantly with some versions of
377     bash/dpkg/whatever cause package build failure (Closes: #281780, #282902)
378   * Reduce minimum expected size a bit Sun's 1.5.0 amd64 package, it was set
379     too high (Closes: #284033)
380   * Substitute package version number at build time in the make-jpkg
381     executable (Closes: #282221)
382   * Added a README.Debian explaining the existance of make-jpkg and what
383     binary packages are supported and where to get them. Thanks Thijs
384     Kinkhorst for the draft (Closes: #283362)
385   * Added automatically-generated file SUPPORTED that lists all binary
386     filenames that are supported, thanks Alex Owen <owen@cus.org.uk> for the
387     idea (Closes: #275296)
388
389  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Mon,  3 Jan 2005 18:47:47 +0100
390
391 java-package (0.17) unstable; urgency=low
392
393   * added a patch for detecting the architecture (Closes: #274844,
394     #270949, #271846). This patch should also close this one (Closes:
395     #280685).
396
397  -- Arnaud Vandyck <avdyk@debian.org>  Fri, 12 Nov 2004 17:28:38 +0100
398
399 java-package (0.16) unstable; urgency=low
400
401   * added myself as an uploader.
402   * Carlos already closed the support for 1.5 request but it seems he did
403     not upload the package (Closes: #277088).
404
405  -- Arnaud Vandyck <avdyk@debian.org>  Wed, 10 Nov 2004 16:38:44 +0100
406
407 java-package (0.15) unstable; urgency=low
408
409   * lib/sun-j2re.sh: Added support for JRE 1.5.0 (aka "Java 5.0").
410   * lib/sun-j2sdk.sh: Added support for Java SDK 1.5.0.
411
412  -- Carlos Laviola <claviola@debian.org>  Mon, 11 Oct 2004 21:08:59 -0300
413
414 java-package (0.14) unstable; urgency=low
415
416   * debian/control: Commented out the lines that generate the Debian-specific
417     packages, thus making alternatives available.
418     - Also made all of the generated packages depend on their Debian-specific
419     counterparts by default.  (Closes: #266671)
420
421  -- Carlos Laviola <claviola@debian.org>  Mon, 13 Sep 2004 03:38:31 -0300
422
423 java-package (0.13) unstable; urgency=low
424
425   * References to j2se-package are gone.  (Closes: #267642)
426   * Added support for Blackdown Java 1.4.2 RC1 JRE/SDK.  (Closes: #267643)
427
428  -- Carlos Laviola <claviola@debian.org>  Mon, 13 Sep 2004 03:17:54 -0300
429
430 java-package (0.12) unstable; urgency=low
431
432   * remove to contrib because this package depend on non-free J2SE.
433
434  -- Takashi Okamoto <tora@debian.org>  Tue,  3 Aug 2004 00:37:13 +0900
435
436 java-package (0.11) unstable; urgency=low
437
438   * change package name java-package and the command build package is 
439     make-jpkg.
440
441  -- Takashi Okamoto <tora@debian.org>  Sat, 31 Jul 2004 15:07:36 +0900
442
443 java-package (0.10) unstable; urgency=low
444
445   * change package name mpkg-j2se.
446   * not use *-j2[re|sdk]debian package. Instead of this, add package 
447     dependency to generated package. This reduce the installation for 
448     such extra package. 
449   * SUN's jdk1.5 beta2 support.
450
451  -- Takashi Okamoto <tora@debian.org>  Sun, 18 Jul 2004 13:53:36 +0900
452
453 java-package (0.9) unstable; urgency=low
454
455   * more generic support for j2re1.3.1/j2sdk1.3.1 from SUN.
456
457   * add alternative for jarsigner (in j2sdk1.4 and j2sdk1.5 from SUN).
458
459  -- Hubert Schmid <ude2@z42.de>  Sun, 23 May 2004 23:35:14 +0200
460
461 java-package (0.8) unstable; urgency=low
462
463   * java plugin: support for mozilla-firefox.
464
465  -- Hubert Schmid <ude2@z42.de>  Tue,  4 May 2004 22:39:39 +0200
466
467 java-package (0.7) unstable; urgency=low
468
469   * Optionally create .changes file.
470
471   * Add command line options: --help, --version, --full-name,
472     --email, --changes.
473
474   * Add environment variables: J2SE_PACKAGE_FULL_NAME,
475     J2SE_PACKAGE_EMAIL.
476
477  -- Hubert Schmid <ude2@z42.de>  Sat, 27 Mar 2004 23:01:08 +0100
478
479 java-package (0.6) unstable; urgency=low
480
481   * More generic support for Java2 1.4.2 from SUN.
482
483  -- Hubert Schmid <ude2@z42.de>  Thu, 11 Mar 2004 20:39:51 +0100
484
485 java-package (0.5) unstable; urgency=low
486
487   * NEW: build Blackdown J2RE 1.4.1 (gcc-2.95) and J2SDK 1.4.1 (gcc-2.95).
488
489   * NEW: support for SUN J2RE 1.5.0 beta, SUN J2SDK 1.5.0 beta.
490
491  -- Hubert Schmid <ude2@z42.de>  Sat,  7 Feb 2004 21:57:09 +0100
492
493 java-package (0.4) unstable; urgency=low
494
495   * Added support for: SUN J2RE 1.4.2_03, SUN J2SDK 1.4.2_03
496
497  -- Hubert Schmid <ude2@z42.de>  Thu, 15 Jan 2004 22:27:52 +0100
498
499 java-package (0.3) unstable; urgency=low
500
501   * Added support for: Blackdown J2RE 1.3, 1.4, J2SDK 1.3, 1.4
502
503   * Removed usage of "du --apparent-size". This should fix a problem
504     with old fileutils.
505
506  -- Hubert Schmid <ude2@z42.de>  Sun,  9 Nov 2003 21:13:38 +0100
507
508 java-package (0.2) unstable; urgency=low
509
510   * Added support for: Sun J2RE 1.3, Sun J2SDK 1.3, Sun J2SDK 1.4
511
512   * Moved peer packages into this source package.
513
514  -- Hubert Schmid <ude2@z42.de>  Thu, 30 Oct 2003 00:10:01 +0100
515
516 java-package (0.1) unstable; urgency=low
517
518   * Initial Release.
519
520  -- Hubert Schmid <j2se-package@z42.de>  Sun, 26 Oct 2003 20:06:57 +0100