29ce8d8cdf63176f72d894ae786cb9186776c6a9
[sven/java-package.git] / debian / changelog
1 java-package (0.55) UNRELEASED; urgency=medium
2
3   [ tony mancill ]
4   * Team upload.
5   * Add lsb-release to Depends (used in make-jpkg).
6   * Apply patch to honor --revision argument.
7     Thanks to Alberto Caso Palomino. (Closes: #743919)
8
9   [ Emmanuel Bourg ]
10   * Bumped the Standards-Version of the generated package to 3.9.5
11   * Use debhelper level 9 in the generated package
12
13   [ Benjamin Drung ]
14   * Add a debian/rules file to the generated source package.
15   * Use dpkg-buildpackage to build the guest package.
16   * Add ${misc:Depends} to the guest dependency.
17   * Add --source option to build a source package instead of a binary deb
18     package. (Closes: #745762)
19
20  -- tony mancill <tmancill@debian.org>  Mon, 07 Apr 2014 21:26:36 -0700
21
22 java-package (0.54) unstable; urgency=medium
23
24   * Team upload.
25   * Added support for ARM VFP/hard-float JDK releases.
26     Thanks to Christopher Huhn <C.Huhn@gsi.de> (Closes: #724455)
27   * Added more command line tool alternatives: jcmd, jdeps, jhat, jrunscript,
28     schemagen, wsgen, wsimport and xjc
29   * Standards-Version updated to 3.9.5 (no changes)
30   * Removed the suggested dependency on openjdk-6-jre
31   * Switch to debhelper level 9
32
33  -- Emmanuel Bourg <ebourg@apache.org>  Mon, 24 Mar 2014 18:44:58 +0100
34
35 java-package (0.53) unstable; urgency=low
36
37   * Team upload.
38   * Added support for early access releases (Closes: #721136)
39   * Added support for GA and FCS releases
40   * Excluded the fxavcodecplugin libraries used by JavaFX from the dependency
41     calculation performed by dh_shlibdeps to avoid errors (Closes: #687075)
42   * Updated the package description and debian/README.Debian:
43     - no longer recommend openjdk-6
44     - mention the compatibility with Java 8
45   * Removed 'Replaces: ${j2se_package}debian' from the generated control file
46   * Adjusted the disk space required to unpack the Java 8 documentation
47   * Updated the manpages for Java 8
48   * Updated debhelper level to 7
49   * debian/rules: Use dh_prep instead of dh_clean -k
50   * Removed the recommended dependency on libstdc++5 from the generated
51     control file (used by the now unsupported IBM JDK 5)
52   * Removed the recommended dependency on libgtk1.2 from the generated
53     control file (removed from Squeeze)
54   * Removed the recommended dependency on libx11-6 and libasound2 from
55     the generated control file (these dependencies are already injected
56     by dh_shlibdeps)
57   * Removed the references to "Java 2" from the description of the generated
58     JRE package
59   * Changed the short description of the generate packages to match
60     the official name
61
62  -- Emmanuel Bourg <ebourg@apache.org>  Tue, 10 Sep 2013 14:42:43 +0200
63
64 java-package (0.52) unstable; urgency=low
65
66   [ Sylvestre Ledru ]
67   * Team upload
68   * Upload to unstable
69   * Ack the NMU of David Prévot (thanks!)
70   * Standards-Version updated to version 3.9.4
71   * Remove obsolete variable from the changelog
72   * Add support of ARM upstream binary by James Page and Matthias Vill.
73     Thanks guys! (Closes: #687375)
74   * Change the installation path from
75     /usr/lib/jvm/jdk-6.38-oracle-x64 or /usr/lib/jvm/jdk-7.10-oracle-x64
76     to
77     /usr/lib/jvm/jdk-6-oracle-x64 and /usr/lib/jvm/jdk-7-oracle-x64
78     Thanks to Constantin Makshin for the patch (Closes: #696227)
79
80   [ Cédric Pineau ]
81   * Fix lintian errors and warnings
82
83   [ Gabriele Giacone ]
84   * Add {mozilla,firefox}-javaplugin.so for update-java-alternatives.
85   * Fix plugin directories. Closes: #686216
86
87   [ Emmanuel Bourg ]
88   * Switched to the 3.0 (native) package format
89   * debian/control: Use canonical URLs for the Vcs-* fields
90   * debian/copyright: Switched to the Machine-readable format 1.0
91   * Updated the manpages to reflect the latest naming changes
92   * Removed the unused provided dependencies (j2sdk<version>, j2re<version>)
93   * Provide the java<version-1>-runtime and java<version-2>-runtime dependencies
94     (Closes: #691063)
95   * Provide the java<version>-sdk dependencies to match the openjdk package
96   * Use the upstream versioning scheme (i.e 7u13 instead of 7.13)
97     to match the convention used by the new openjdk packages
98   * Renamed the script files (j2sdk->jdk, j2re->jre, j2se->javase)
99
100  -- Sylvestre Ledru <sylvestre@debian.org>  Wed, 05 Jun 2013 13:43:55 +0200
101
102 java-package (0.51~exp1) experimental; urgency=low
103
104   * Add firefox-javaplugin.so alternative Closes: #673670 and LP: #1024368
105   * Add java5 and 6-{runtime|sdk|...} to the provides line in generated packages Closes: #684993 and LP: #995655
106   * Drop installation debconf note Closes: #685082
107   * Correct handling of amd64 in oracle-jdk6.1->4 and improve error message when used with unknown archives
108   * Add support for earlier oracle-jdk6 version
109
110   [Emmanuel Bourg]
111   * Improved detection of the JRE/JDK version (supports 2 digits Java 7 updates) Closes: #597294
112   * Brand and naming cleanup
113   * Documentation directory changed to be /usr/share/doc/oracle-javaV-doc (for oracle)
114
115   [Joerg Schirottke]
116   * Add mozilla-javaplugin.so alternative
117
118  -- Cédric Pineau <cedric.pineau@gmail.com>  Sat, 18 Aug 2012 11:00:34 +0200
119
120 java-package (0.50+nmu2) unstable; urgency=high
121
122   * Non-maintainer upload.
123   * Allow two digits in Java 7 updates. Closes: #597294, #698108
124
125  -- David Prévot <taffit@debian.org>  Tue, 15 Jan 2013 15:06:26 -0400
126
127 java-package (0.50+nmu1) unstable; urgency=low
128
129   * Non-maintainer upload.
130   * Drop installation debconf note. Closes: #685082
131
132  -- David Prévot <taffit@debian.org>  Thu, 06 Sep 2012 18:38:03 -0400
133
134 java-package (0.50) unstable; urgency=low
135
136   * Java-package reset for reintroduction in debian (removal of all
137     previously supported jvm, global refactoring).
138   * Add support for Oracle Java 6 (update >= 10)
139   * Add support for Oracle Java 7
140   * Add support for .jinfo file (update-java-alternatives tool)
141   * Use jdk included jre binaries (jdk/jre/bin/*)
142   * Print usage information on install
143
144   [ Sylvestre Ledru ]
145   * Long description removed
146   * debian-rules-missing-recommended-target removed
147   * maintainer-script-lacks-debhelper-token removed
148   * Declare the debian/compat to 7 to avoid warnings
149
150   [ Michael Koch ]
151   * Remove Java plugins for all browsers (Closes: #367887).
152   * Add support for Sun Java 6 Update XX (Closes: #514364).
153
154  -- Cédric Pineau <cedric.pineau@gmail.com>  Thu, 22 Dec 2011 11:42:13 +0100
155
156 java-package (0.42) unstable; urgency=low
157
158   * Provide java*-runtime-headless and java*-sdk names for generated
159     packages.
160   * Recommend dpkg-dev and gcc. Closes: #281766, #405814.
161
162  -- Matthias Klose <doko@debian.org>  Sat, 02 Aug 2008 12:10:52 +0200
163
164 java-package (0.41) unstable; urgency=low
165
166   * Added support for new SUN JDK/JRE for amd64 downloads. Thanks to
167     Artyom Gavrichenkov for the initial patch.
168
169  -- Michael Koch <konqueror@gmx.de>  Fri, 21 Mar 2008 17:20:35 +0100
170
171 java-package (0.40) unstable; urgency=low
172
173   * Add support for ibm-java2-sdk-5.0-6.0-linux-$arch.tgz. Closes: #462399
174     Thanks to Evgeni Dobrev for the patch.
175   * Fixed spelling error in long description: debian -> Debian.
176
177  -- Michael Koch <konqueror@gmx.de>  Thu, 24 Jan 2008 22:48:46 +0100
178
179 java-package (0.39) unstable; urgency=low
180
181   * Added support for IBM JDK 6.0 final release.
182   * Updated Standard-Version to 3.7.3.
183   * Updated debhelper level to 5.
184
185  -- Michael Koch <konqueror@gmx.de>  Tue, 18 Dec 2007 07:38:34 +0100
186
187 java-package (0.38) unstable; urgency=low
188
189   * Mention SUN JDK 6 in REAME.Debian. Closes: #448258.
190   * Fixed typo when creating version number for SUN JDK 6. Closes: #451935.
191   * Fix handling of symlinks for ControlPanel, HtmlConverter and java-rmi.cgi
192     from SUN JDK 6. Closes: #448351.
193
194  -- Michael Koch <konqueror@gmx.de>  Fri, 30 Nov 2007 00:03:50 +0100
195
196 java-package (0.37) unstable; urgency=low
197
198   * Added libstdc++5 to Recommends of generated package. Closes: #446334.
199
200  -- Michael Koch <konqueror@gmx.de>  Thu, 25 Oct 2007 22:45:42 +0200
201
202 java-package (0.36) unstable; urgency=low
203
204   * Fixed package description to include more supported JDKs.
205     Closes: #447615, #447617.
206
207  -- Michael Koch <konqueror@gmx.de>  Wed, 24 Oct 2007 09:56:52 +0200
208
209 java-package (0.35) unstable; urgency=low
210
211   * Use 'date -R' instead of the deprecated '822-date'. Closes: #441229.
212   * Fix generation of .changes file. Closes: #332643.
213     Thanks to Christoph Goehre for the patch.
214   * Add possibility to add a configured revision to the version.
215     Closes: #442246. Thanks to Christoph Goehre again for the patch.
216
217  -- Michael Koch <konqueror@gmx.de>  Fri, 14 Sep 2007 17:28:13 +0200
218
219 java-package (0.34) unstable; urgency=low
220
221   * Fixed SUN JDK on amd64. Closes: #439221.
222
223  -- Michael Koch <konqueror@gmx.de>  Fri, 24 Aug 2007 00:41:54 +0200
224
225 java-package (0.33) unstable; urgency=low
226
227   * Fixed postinst scripts for SUN JDK 1.4, 5 and 6. Closes: #435632.
228
229  -- Michael Koch <konqueror@gmx.de>  Thu, 02 Aug 2007 18:43:40 +0200
230
231 java-package (0.32) unstable; urgency=low
232
233   * Added support for iceweasel. Closes: #433445.
234   * Fix dangling links for SUN Java 5. Closes: #305053.
235   * Depend on libx11-6 and libasound2. Closes: #289004.
236   * Fix building on ia64. Closes: #355465.
237
238  -- Michael Koch <konqueror@gmx.de>  Thu, 19 Jul 2007 22:51:31 +0200
239
240 java-package (0.31) unstable; urgency=low
241
242   * Reapplied changes from 0.28 to 0.29. Closes: 322843.
243
244  -- Michael Koch <konqueror@gmx.de>  Tue, 10 Jul 2007 08:16:14 +0200
245
246 java-package (0.30) unstable; urgency=low
247
248   * Added support for SUN JDK 6u2 (and following updates).
249   * Added support for ibm-java2-jre-5.0-5.0-linux-ppc.tgz.
250     Thanks to B. Zhang.
251
252  -- Michael Koch <konqueror@gmx.de>  Sun, 08 Jul 2007 09:33:29 +0200
253
254 java-package (0.29) unstable; urgency=low
255
256   * Added support for SUN Java 6 and IBM Java 6.
257     Closes: #322843, #402642, #418592, #425508, #430026.
258   * Added myself to Uploaders.
259
260  -- Michael Koch <konqueror@gmx.de>  Tue, 26 Jun 2007 17:40:04 -0100
261
262 java-package (0.28) unstable; urgency=low
263
264   * Modified to reflect migration to Subversion
265   * Bumped standards to version 3.7.2, no changes
266   * Corrected test for AMD64 architecture during plug-in detection
267   * Corrected detected version for IBM Java 5 JDK on AMD64 (Closes: #345775)
268   * Repaired alternatives handling for IBM Java 5 JREs and JDKs
269     (Closes: #338569)
270   * Corrected pathing for alternatives installation for Mozilla and
271     Firefox plugins (Closes: #341751)
272   * Relaxed architectural restrictions on plugin alternative
273     installation for IBM Java 5 JREs and JDKs (Closes: #343837)
274   * Added plugin installation for the new packaging of Firefox 1.5 and
275     later (Closes: #341749)
276   * Modified warning suppression for dh_shlibdeps to accommodate
277     changes in dpkg-dev (Closes: #354427)
278   * Added quotes to variable tests for maintainer name and email
279     (Closes: #342623)
280   * Refactored architecture evaluation to eliminate repetition and
281     evaluate DEB_BUILD_GNU_TYPE correctly for i486-linux-gnu
282   * Removed dependency on 'coreutils | stat' from control file, as
283     the dependency is satisfied within essential (Closes: #370002)
284
285  -- Barry Hawkins <barry@alltc.com>  Mon, 26 Jun 2006 11:19:08 -0400
286
287 java-package (0.27) unstable; urgency=low
288
289   * Added support for IBM Java2 5.0 JREs and JDKs (Closes: #337129)
290   * Corrected missing alternatives links for all JREs and JDKs
291     (Closes: #317492)
292   * Added conditional wrapping around dh_compress to account for
293     JRE/JDKs that do not ship manpages (Closes: 301738)
294   * Removed java-common from Provides: for JRE and JDK packages.
295
296  -- Barry Hawkins <barry@bytemason.org>  Tue, 08 Nov 2005 12:16:24 -0500
297
298 java-package (0.26) unstable; urgency=low
299
300   * Update standards version to 3.6.2
301   * Resolve issues with powerpc-linux support detection (Closes: #317671)
302   * Added support for Blackdown 1.4.2+02 release (Closes: #316831)
303   * Added support for packaging Sun JDK documentation (Closes: #272971)
304   * Modified make-jpkg behavior to default the generated packages'
305     name and email address for the maintainer to Debian Java Maintainers
306     (Closes: #325554)
307
308  -- Barry Hawkins <barry@bytemason.org>  Thu, 18 Aug 2005 00:43:17 -0400
309
310 java-package (0.25) unstable; urgency=low
311
312   * Cope with dpkg's new way of expressing architectures (Closes: #313555)
313   * Re-exec with fakeroot if needed (Closes: #310132)
314
315  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Sun, 10 Jul 2005 18:50:40 +0200
316
317 java-package (0.24) unstable; urgency=low
318
319   * Added plugin alternatives support for i386 IBM JREs and JDKs
320   * Corrected pathing for plugin alternatives to reflect difference in
321     layout between JREs and JDKs for Sun and Blackdown (Closes: #305219,
322     #301806)
323
324  -- Barry Hawkins <barry@bytemason.org>  Wed, 21 Apr 2005 01:02:03 -0400
325
326 java-package (0.23.1) experimental; urgency=low
327
328   * Added architecture-specific pathing for plugin alternatives for
329     Blackdown 1.3 and 1.4 JREs and JDKs
330
331  -- Barry Hawkins <barry@bytemason.org>  Wed, 06 Apr 2005 00:03:40 -0500
332
333 java-package (0.23) unstable; urgency=low
334
335   * Further expanded 1.3.1 Blackdown JRE/JDK support for i386
336   * Added architecture-specific pathing for plugin alternatives for
337     Sun 1.4 and 1.5 JREs and JDKs (Closes: #301806)
338   * Added recommends for system elements required by applets and
339     graphical user interface elements (Closes: #300817)
340   * Jeroen van Wolffelaar:
341     + Fixed packages description to not have too long lines, and make the 3
342       items an enumeration
343
344  -- Barry Hawkins <barry@bytemason.org>  Fri, 01 Apr 2005 00:36:40 -0500
345
346 java-package (0.22.1) experimental; urgency=low
347
348   * Corrected IBM and Blackdown JRE/JDK file size specifications
349   * Added support for additional 1.3.1 Blackdown JREs and JDKs for i386,
350     powerpc (Closes: #301092)
351   * Added installation of javaws alternative for Sun 1.5 JREs and JDKs
352     (Closes: #300303)
353
354  -- Barry Hawkins <barry@bytemason.org>  Thu, 24 Mar 2005 13:20:18 -0500
355
356 java-package (0.22) unstable; urgency=low
357
358   * Corrected IBM JRE/JDK scripts to accurately reflect the supported
359     IBM JDKs and JREs in the generated SUPPORTED file
360
361  -- Barry Hawkins <barry@alltc.com>  Fri, 18 Mar 2005 10:21:53 -0500
362
363 java-package (0.21) unstable; urgency=low
364
365   * Enable support for IBM JDKs and JREs for x86, amd64, powerpc,
366     powerpc64, and s390 architectures, based upon a patch by Rico
367     Schiekel (Closes: #264137)
368   * Enable suppport for Blackdown 1.3.1 JDK and JRE for PowerPC
369     architecture. (Closes: #296205)
370   * Update documentation and to reflect current supported JDKs and JREs
371
372  -- Barry Hawkins <barry@alltc.com>  Mon, 14 Mar 2005 03:18:39 -0500
373
374 java-package (0.20) unstable; urgency=low
375
376   * Make the postinst & rm for generated packages #!/bin/bash, as we use
377     bash-specific features (Closes: #292179)
378   * Drop the df output parsing, use '/usr/bin/stat' instead (Closes: #293487,
379     #289006, #293350)
380   * Drop the now obsolete peer stuff from the source package
381   * Change priorities, 313 for 1.3, 314 for 1.4, etc (Closes: #292451)
382   * Don't dh_strip, fiddling with upstream's binaries apparantly breaks stuff
383     (Closes: #291238)
384
385  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Tue, 08 Feb 2005 15:04:51 +0100
386
387 java-package (0.19) unstable; urgency=low
388
389   The "Joshua Kwan <joshk@debian.org> rocks!" release.
390
391   Joshua Kwan:
392   * Unclutter Debian build system and rework package slightly so that
393     *debian packages are not needed anymore. The necessary files will be
394     included in the generated packages. (Closes: #291145, #289245, #284779)
395   * Add support for Blackdown 1.4.2+01 build. (Closes: #285405)
396   * Fix support for Sun 1.5.0 amd64 builds due to typo. (Closes: #290879)
397   * Mozilla browser plugin name changed in 1.4.2 versions. Detect and correct.
398     (Closes: #273730)
399   * Use --block-size=1M instead of -BM. (Closes: #289005, #291161)
400   * Disable support for Sun JDK 1.3 due to its dependencies on libraries
401     that are simply not available anymore. (Closes: #272972)
402   * Fix up short description a little bit.
403   * Bump Standards-Version to 3.6.1 (no changes)
404   * Be a bit more conservative with the real-root test.
405   * Remove last j2se-package references.
406   * Change Suggests on fakeroot to a Depends because it is worthless both
407     as real root and as a normal user without fakeroot.
408
409   Jeroen van Wolffelaar:
410   * Use DEBFULLNAME, DEBNAME and DEBEMAIL if available, and don't ask for
411     those values in that case. (Closes: #279653)
412   * Updated documentation regarding dropped Sun 1.3 support
413   * Work around multiline df output caused by long device names
414     (Closes: #289006)
415   * Add Replaces: for the generated packages on their *debian counterparts
416
417  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Tue, 25 Jan 2005 00:05:06 +0100
418
419 java-package (0.18) unstable; urgency=low
420
421   * Added myself to Uploaders
422   * Fix security hole (inscure temp file creation) plus lots of needless I/O
423     in free disk checking function
424   * Added support for Sun's JDK/JRE 1.5 patch levels, based on a patch by
425     Peter Marschall <peter@adpm.de> (Closes: #286718, #287857)
426   * Bail out if running as real root (works around the evil parts of Sun's
427     install script that unconditionally writes to /etc, see #266273, #280707)
428   * Fix typo in j2re.sh that apparantly with some versions of
429     bash/dpkg/whatever cause package build failure (Closes: #281780, #282902)
430   * Reduce minimum expected size a bit Sun's 1.5.0 amd64 package, it was set
431     too high (Closes: #284033)
432   * Substitute package version number at build time in the make-jpkg
433     executable (Closes: #282221)
434   * Added a README.Debian explaining the existance of make-jpkg and what
435     binary packages are supported and where to get them. Thanks Thijs
436     Kinkhorst for the draft (Closes: #283362)
437   * Added automatically-generated file SUPPORTED that lists all binary
438     filenames that are supported, thanks Alex Owen <owen@cus.org.uk> for the
439     idea (Closes: #275296)
440
441  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Mon,  3 Jan 2005 18:47:47 +0100
442
443 java-package (0.17) unstable; urgency=low
444
445   * added a patch for detecting the architecture (Closes: #274844,
446     #270949, #271846). This patch should also close this one (Closes:
447     #280685).
448
449  -- Arnaud Vandyck <avdyk@debian.org>  Fri, 12 Nov 2004 17:28:38 +0100
450
451 java-package (0.16) unstable; urgency=low
452
453   * added myself as an uploader.
454   * Carlos already closed the support for 1.5 request but it seems he did
455     not upload the package (Closes: #277088).
456
457  -- Arnaud Vandyck <avdyk@debian.org>  Wed, 10 Nov 2004 16:38:44 +0100
458
459 java-package (0.15) unstable; urgency=low
460
461   * lib/sun-j2re.sh: Added support for JRE 1.5.0 (aka "Java 5.0").
462   * lib/sun-j2sdk.sh: Added support for Java SDK 1.5.0.
463
464  -- Carlos Laviola <claviola@debian.org>  Mon, 11 Oct 2004 21:08:59 -0300
465
466 java-package (0.14) unstable; urgency=low
467
468   * debian/control: Commented out the lines that generate the Debian-specific
469     packages, thus making alternatives available.
470     - Also made all of the generated packages depend on their Debian-specific
471     counterparts by default.  (Closes: #266671)
472
473  -- Carlos Laviola <claviola@debian.org>  Mon, 13 Sep 2004 03:38:31 -0300
474
475 java-package (0.13) unstable; urgency=low
476
477   * References to j2se-package are gone.  (Closes: #267642)
478   * Added support for Blackdown Java 1.4.2 RC1 JRE/SDK.  (Closes: #267643)
479
480  -- Carlos Laviola <claviola@debian.org>  Mon, 13 Sep 2004 03:17:54 -0300
481
482 java-package (0.12) unstable; urgency=low
483
484   * remove to contrib because this package depend on non-free J2SE.
485
486  -- Takashi Okamoto <tora@debian.org>  Tue,  3 Aug 2004 00:37:13 +0900
487
488 java-package (0.11) unstable; urgency=low
489
490   * change package name java-package and the command build package is
491     make-jpkg.
492
493  -- Takashi Okamoto <tora@debian.org>  Sat, 31 Jul 2004 15:07:36 +0900
494
495 java-package (0.10) unstable; urgency=low
496
497   * change package name mpkg-j2se.
498   * not use *-j2[re|sdk]debian package. Instead of this, add package
499     dependency to generated package. This reduce the installation for
500     such extra package.
501   * SUN's jdk1.5 beta2 support.
502
503  -- Takashi Okamoto <tora@debian.org>  Sun, 18 Jul 2004 13:53:36 +0900
504
505 java-package (0.9) unstable; urgency=low
506
507   * more generic support for j2re1.3.1/j2sdk1.3.1 from SUN.
508
509   * add alternative for jarsigner (in j2sdk1.4 and j2sdk1.5 from SUN).
510
511  -- Hubert Schmid <ude2@z42.de>  Sun, 23 May 2004 23:35:14 +0200
512
513 java-package (0.8) unstable; urgency=low
514
515   * java plugin: support for mozilla-firefox.
516
517  -- Hubert Schmid <ude2@z42.de>  Tue,  4 May 2004 22:39:39 +0200
518
519 java-package (0.7) unstable; urgency=low
520
521   * Optionally create .changes file.
522
523   * Add command line options: --help, --version, --full-name,
524     --email, --changes.
525
526   * Add environment variables: J2SE_PACKAGE_FULL_NAME,
527     J2SE_PACKAGE_EMAIL.
528
529  -- Hubert Schmid <ude2@z42.de>  Sat, 27 Mar 2004 23:01:08 +0100
530
531 java-package (0.6) unstable; urgency=low
532
533   * More generic support for Java2 1.4.2 from SUN.
534
535  -- Hubert Schmid <ude2@z42.de>  Thu, 11 Mar 2004 20:39:51 +0100
536
537 java-package (0.5) unstable; urgency=low
538
539   * NEW: build Blackdown J2RE 1.4.1 (gcc-2.95) and J2SDK 1.4.1 (gcc-2.95).
540
541   * NEW: support for SUN J2RE 1.5.0 beta, SUN J2SDK 1.5.0 beta.
542
543  -- Hubert Schmid <ude2@z42.de>  Sat,  7 Feb 2004 21:57:09 +0100
544
545 java-package (0.4) unstable; urgency=low
546
547   * Added support for: SUN J2RE 1.4.2_03, SUN J2SDK 1.4.2_03
548
549  -- Hubert Schmid <ude2@z42.de>  Thu, 15 Jan 2004 22:27:52 +0100
550
551 java-package (0.3) unstable; urgency=low
552
553   * Added support for: Blackdown J2RE 1.3, 1.4, J2SDK 1.3, 1.4
554
555   * Removed usage of "du --apparent-size". This should fix a problem
556     with old fileutils.
557
558  -- Hubert Schmid <ude2@z42.de>  Sun,  9 Nov 2003 21:13:38 +0100
559
560 java-package (0.2) unstable; urgency=low
561
562   * Added support for: Sun J2RE 1.3, Sun J2SDK 1.3, Sun J2SDK 1.4
563
564   * Moved peer packages into this source package.
565
566  -- Hubert Schmid <ude2@z42.de>  Thu, 30 Oct 2003 00:10:01 +0100
567
568 java-package (0.1) unstable; urgency=low
569
570   * Initial Release.
571
572  -- Hubert Schmid <j2se-package@z42.de>  Sun, 26 Oct 2003 20:06:57 +0100