Updated the manpages for Java 8
[sven/java-package.git] / debian / changelog
1 java-package (0.53) UNRELEASED; urgency=low
2
3   * Team upload.
4   * Added support for early access releases (Closes: #721136)
5   * Added support for GA and FCS releases
6   * Updated the package description:
7     - no longer recommend openjdk-6
8     - mention the compatibility with Java 8
9   * Removed 'Replaces: ${j2se_package}debian' from the generated control file
10   * Adjusted the disk space required to unpack the Java 8 documentation
11   * Updated the manpages for Java 8
12
13  -- Emmanuel Bourg <ebourg@apache.org>  Wed, 28 Aug 2013 19:34:41 +0200
14
15 java-package (0.52) unstable; urgency=low
16
17   [ Sylvestre Ledru ]
18   * Team upload
19   * Upload to unstable
20   * Ack the NMU of David Prévot (thanks!)
21   * Standards-Version updated to version 3.9.4
22   * Remove obsolete variable from the changelog
23   * Add support of ARM upstream binary by James Page and Matthias Vill.
24     Thanks guys! (Closes: #687375)
25   * Change the installation path from
26     /usr/lib/jvm/jdk-6.38-oracle-x64 or /usr/lib/jvm/jdk-7.10-oracle-x64
27     to
28     /usr/lib/jvm/jdk-6-oracle-x64 and /usr/lib/jvm/jdk-7-oracle-x64
29     Thanks to Constantin Makshin for the patch (Closes: #696227)
30
31   [ Cédric Pineau ]
32   * Fix lintian errors and warnings
33
34   [ Gabriele Giacone ]
35   * Add {mozilla,firefox}-javaplugin.so for update-java-alternatives.
36   * Fix plugin directories. Closes: #686216
37
38   [ Emmanuel Bourg ]
39   * Switched to the 3.0 (native) package format
40   * debian/control: Use canonical URLs for the Vcs-* fields
41   * debian/copyright: Switched to the Machine-readable format 1.0
42   * Updated the manpages to reflect the latest naming changes
43   * Removed the unused provided dependencies (j2sdk<version>, j2re<version>)
44   * Provide the java<version-1>-runtime and java<version-2>-runtime dependencies
45     (Closes: #691063)
46   * Provide the java<version>-sdk dependencies to match the openjdk package
47   * Use the upstream versioning scheme (i.e 7u13 instead of 7.13)
48     to match the convention used by the new openjdk packages
49   * Renamed the script files (j2sdk->jdk, j2re->jre, j2se->javase)
50
51  -- Sylvestre Ledru <sylvestre@debian.org>  Wed, 05 Jun 2013 13:43:55 +0200
52
53 java-package (0.51~exp1) experimental; urgency=low
54
55   * Add firefox-javaplugin.so alternative Closes: #673670 and LP: #1024368
56   * Add java5 and 6-{runtime|sdk|...} to the provides line in generated packages Closes: #684993 and LP: #995655
57   * Drop installation debconf note Closes: #685082
58   * Correct handling of amd64 in oracle-jdk6.1->4 and improve error message when used with unknown archives
59   * Add support for earlier oracle-jdk6 version
60
61   [Emmanuel Bourg]
62   * Improved detection of the JRE/JDK version (supports 2 digits Java 7 updates) Closes: #597294
63   * Brand and naming cleanup
64   * Documentation directory changed to be /usr/share/doc/oracle-javaV-doc (for oracle)
65
66   [Joerg Schirottke]
67   * Add mozilla-javaplugin.so alternative
68
69  -- Cédric Pineau <cedric.pineau@gmail.com>  Sat, 18 Aug 2012 11:00:34 +0200
70
71 java-package (0.50+nmu2) unstable; urgency=high
72
73   * Non-maintainer upload.
74   * Allow two digits in Java 7 updates. Closes: #597294, #698108
75
76  -- David Prévot <taffit@debian.org>  Tue, 15 Jan 2013 15:06:26 -0400
77
78 java-package (0.50+nmu1) unstable; urgency=low
79
80   * Non-maintainer upload.
81   * Drop installation debconf note. Closes: #685082
82
83  -- David Prévot <taffit@debian.org>  Thu, 06 Sep 2012 18:38:03 -0400
84
85 java-package (0.50) unstable; urgency=low
86
87   * Java-package reset for reintroduction in debian (removal of all
88     previously supported jvm, global refactoring).
89   * Add support for Oracle Java 6 (update >= 10)
90   * Add support for Oracle Java 7
91   * Add support for .jinfo file (update-java-alternatives tool)
92   * Use jdk included jre binaries (jdk/jre/bin/*)
93   * Print usage information on install
94
95   [ Sylvestre Ledru ]
96   * Long description removed
97   * debian-rules-missing-recommended-target removed
98   * maintainer-script-lacks-debhelper-token removed
99   * Declare the debian/compat to 7 to avoid warnings
100   
101   [ Michael Kock ]
102   * Remove Java plugins for all browsers (Closes: #367887).
103   * Add support for Sun Java 6 Update XX (Closes: #514364).
104
105  -- Cédric Pineau <cedric.pineau@gmail.com>  Thu, 22 Dec 2011 11:42:13 +0100
106
107 java-package (0.42) unstable; urgency=low
108
109   * Provide java*-runtime-headless and java*-sdk names for generated
110     packages.
111   * Recommend dpkg-dev and gcc. Closes: #281766, #405814.
112
113  -- Matthias Klose <doko@debian.org>  Sat, 02 Aug 2008 12:10:52 +0200
114
115 java-package (0.41) unstable; urgency=low
116
117   * Added support for new SUN JDK/JRE for amd64 downloads. Thanks to
118     Artyom Gavrichenkov for the initial patch.
119
120  -- Michael Koch <konqueror@gmx.de>  Fri, 21 Mar 2008 17:20:35 +0100
121
122 java-package (0.40) unstable; urgency=low
123
124   * Add support for ibm-java2-sdk-5.0-6.0-linux-$arch.tgz. Closes: #462399
125     Thanks to Evgeni Dobrev for the patch.
126   * Fixed spelling error in long description: debian -> Debian.
127
128  -- Michael Koch <konqueror@gmx.de>  Thu, 24 Jan 2008 22:48:46 +0100
129
130 java-package (0.39) unstable; urgency=low
131
132   * Added support for IBM JDK 6.0 final release.
133   * Updated Standard-Version to 3.7.3.
134   * Updated debhelper level to 5.
135
136  -- Michael Koch <konqueror@gmx.de>  Tue, 18 Dec 2007 07:38:34 +0100
137
138 java-package (0.38) unstable; urgency=low
139
140   * Mention SUN JDK 6 in REAME.Debian. Closes: #448258.
141   * Fixed typo when creating version number for SUN JDK 6. Closes: #451935.
142   * Fix handling of symlinks for ControlPanel, HtmlConverter and java-rmi.cgi
143     from SUN JDK 6. Closes: #448351.
144
145  -- Michael Koch <konqueror@gmx.de>  Fri, 30 Nov 2007 00:03:50 +0100
146
147 java-package (0.37) unstable; urgency=low
148
149   * Added libstdc++5 to Recommends of generated package. Closes: #446334.
150
151  -- Michael Koch <konqueror@gmx.de>  Thu, 25 Oct 2007 22:45:42 +0200
152
153 java-package (0.36) unstable; urgency=low
154
155   * Fixed package description to include more supported JDKs.
156     Closes: #447615, #447617.
157
158  -- Michael Koch <konqueror@gmx.de>  Wed, 24 Oct 2007 09:56:52 +0200
159
160 java-package (0.35) unstable; urgency=low
161
162   * Use 'date -R' instead of the deprecated '822-date'. Closes: #441229.
163   * Fix generation of .changes file. Closes: #332643.
164     Thanks to Christoph Goehre for the patch.
165   * Add possibility to add a configured revision to the version.
166     Closes: #442246. Thanks to Christoph Goehre again for the patch.
167
168  -- Michael Koch <konqueror@gmx.de>  Fri, 14 Sep 2007 17:28:13 +0200
169
170 java-package (0.34) unstable; urgency=low
171
172   * Fixed SUN JDK on amd64. Closes: #439221.
173
174  -- Michael Koch <konqueror@gmx.de>  Fri, 24 Aug 2007 00:41:54 +0200
175
176 java-package (0.33) unstable; urgency=low
177
178   * Fixed postinst scripts for SUN JDK 1.4, 5 and 6. Closes: #435632.
179
180  -- Michael Koch <konqueror@gmx.de>  Thu, 02 Aug 2007 18:43:40 +0200
181
182 java-package (0.32) unstable; urgency=low
183
184   * Added support for iceweasel. Closes: #433445.
185   * Fix dangling links for SUN Java 5. Closes: #305053.
186   * Depend on libx11-6 and libasound2. Closes: #289004.
187   * Fix building on ia64. Closes: #355465.
188
189  -- Michael Koch <konqueror@gmx.de>  Thu, 19 Jul 2007 22:51:31 +0200
190
191 java-package (0.31) unstable; urgency=low
192
193   * Reapplied changes from 0.28 to 0.29. Closes: 322843.
194
195  -- Michael Koch <konqueror@gmx.de>  Tue, 10 Jul 2007 08:16:14 +0200
196
197 java-package (0.30) unstable; urgency=low
198
199   * Added support for SUN JDK 6u2 (and following updates).
200   * Added support for ibm-java2-jre-5.0-5.0-linux-ppc.tgz.
201     Thanks to B. Zhang.
202
203  -- Michael Koch <konqueror@gmx.de>  Sun, 08 Jul 2007 09:33:29 +0200
204
205 java-package (0.29) unstable; urgency=low
206
207   * Added support for SUN Java 6 and IBM Java 6.
208     Closes: #322843, #402642, #418592, #425508, #430026.
209   * Added myself to Uploaders.
210
211  -- Michael Koch <konqueror@gmx.de>  Tue, 26 Jun 2007 17:40:04 -0100
212
213 java-package (0.28) unstable; urgency=low
214
215   * Modified to reflect migration to Subversion
216   * Bumped standards to version 3.7.2, no changes
217   * Corrected test for AMD64 architecture during plug-in detection
218   * Corrected detected version for IBM Java 5 JDK on AMD64 (Closes: #345775)
219   * Repaired alternatives handling for IBM Java 5 JREs and JDKs
220     (Closes: #338569)
221   * Corrected pathing for alternatives installation for Mozilla and
222     Firefox plugins (Closes: #341751)
223   * Relaxed architectural restrictions on plugin alternative 
224     installation for IBM Java 5 JREs and JDKs (Closes: #343837)
225   * Added plugin installation for the new packaging of Firefox 1.5 and
226     later (Closes: #341749)
227   * Modified warning suppression for dh_shlibdeps to accommodate 
228     changes in dpkg-dev (Closes: #354427)
229   * Added quotes to variable tests for maintainer name and email 
230     (Closes: #342623)
231   * Refactored architecture evaluation to eliminate repetition and
232     evaluate DEB_BUILD_GNU_TYPE correctly for i486-linux-gnu
233   * Removed dependency on 'coreutils | stat' from control file, as
234     the dependency is satisfied within essential (Closes: #370002)
235
236  -- Barry Hawkins <barry@alltc.com>  Mon, 26 Jun 2006 11:19:08 -0400
237
238 java-package (0.27) unstable; urgency=low
239
240   * Added support for IBM Java2 5.0 JREs and JDKs (Closes: #337129)
241   * Corrected missing alternatives links for all JREs and JDKs
242     (Closes: #317492)
243   * Added conditional wrapping around dh_compress to account for
244     JRE/JDKs that do not ship manpages (Closes: 301738)
245   * Removed java-common from Provides: for JRE and JDK packages.
246
247  -- Barry Hawkins <barry@bytemason.org>  Tue, 08 Nov 2005 12:16:24 -0500
248
249 java-package (0.26) unstable; urgency=low
250
251   * Update standards version to 3.6.2
252   * Resolve issues with powerpc-linux support detection (Closes: #317671)
253   * Added support for Blackdown 1.4.2+02 release (Closes: #316831)
254   * Added support for packaging Sun JDK documentation (Closes: #272971)
255   * Modified make-jpkg behavior to default the generated packages' 
256     name and email address for the maintainer to Debian Java Maintainers
257     (Closes: #325554)
258
259  -- Barry Hawkins <barry@bytemason.org>  Thu, 18 Aug 2005 00:43:17 -0400
260
261 java-package (0.25) unstable; urgency=low
262
263   * Cope with dpkg's new way of expressing architectures (Closes: #313555)
264   * Re-exec with fakeroot if needed (Closes: #310132)
265
266  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Sun, 10 Jul 2005 18:50:40 +0200
267
268 java-package (0.24) unstable; urgency=low
269
270   * Added plugin alternatives support for i386 IBM JREs and JDKs
271   * Corrected pathing for plugin alternatives to reflect difference in 
272     layout between JREs and JDKs for Sun and Blackdown (Closes: #305219,
273     #301806)
274
275  -- Barry Hawkins <barry@bytemason.org>  Wed, 21 Apr 2005 01:02:03 -0400
276
277 java-package (0.23.1) experimental; urgency=low
278
279   * Added architecture-specific pathing for plugin alternatives for 
280     Blackdown 1.3 and 1.4 JREs and JDKs
281
282  -- Barry Hawkins <barry@bytemason.org>  Wed, 06 Apr 2005 00:03:40 -0500
283
284 java-package (0.23) unstable; urgency=low
285
286   * Further expanded 1.3.1 Blackdown JRE/JDK support for i386
287   * Added architecture-specific pathing for plugin alternatives for 
288     Sun 1.4 and 1.5 JREs and JDKs (Closes: #301806)
289   * Added recommends for system elements required by applets and 
290     graphical user interface elements (Closes: #300817)
291   * Jeroen van Wolffelaar:
292     + Fixed packages description to not have too long lines, and make the 3
293       items an enumeration
294
295  -- Barry Hawkins <barry@bytemason.org>  Fri, 01 Apr 2005 00:36:40 -0500
296
297 java-package (0.22.1) experimental; urgency=low
298
299   * Corrected IBM and Blackdown JRE/JDK file size specifications
300   * Added support for additional 1.3.1 Blackdown JREs and JDKs for i386,
301     powerpc (Closes: #301092)
302   * Added installation of javaws alternative for Sun 1.5 JREs and JDKs 
303     (Closes: #300303)
304
305  -- Barry Hawkins <barry@bytemason.org>  Thu, 24 Mar 2005 13:20:18 -0500
306
307 java-package (0.22) unstable; urgency=low
308
309   * Corrected IBM JRE/JDK scripts to accurately reflect the supported 
310     IBM JDKs and JREs in the generated SUPPORTED file
311
312  -- Barry Hawkins <barry@alltc.com>  Fri, 18 Mar 2005 10:21:53 -0500
313
314 java-package (0.21) unstable; urgency=low
315
316   * Enable support for IBM JDKs and JREs for x86, amd64, powerpc, 
317     powerpc64, and s390 architectures, based upon a patch by Rico 
318     Schiekel (Closes: #264137)
319   * Enable suppport for Blackdown 1.3.1 JDK and JRE for PowerPC 
320     architecture. (Closes: #296205)
321   * Update documentation and to reflect current supported JDKs and JREs
322
323  -- Barry Hawkins <barry@alltc.com>  Mon, 14 Mar 2005 03:18:39 -0500
324
325 java-package (0.20) unstable; urgency=low
326
327   * Make the postinst & rm for generated packages #!/bin/bash, as we use
328     bash-specific features (Closes: #292179)
329   * Drop the df output parsing, use '/usr/bin/stat' instead (Closes: #293487,
330     #289006, #293350)
331   * Drop the now obsolete peer stuff from the source package
332   * Change priorities, 313 for 1.3, 314 for 1.4, etc (Closes: #292451)
333   * Don't dh_strip, fiddling with upstream's binaries apparantly breaks stuff
334     (Closes: #291238)
335
336  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Tue, 08 Feb 2005 15:04:51 +0100
337
338 java-package (0.19) unstable; urgency=low
339
340   The "Joshua Kwan <joshk@debian.org> rocks!" release.
341
342   Joshua Kwan:
343   * Unclutter Debian build system and rework package slightly so that
344     *debian packages are not needed anymore. The necessary files will be
345     included in the generated packages. (Closes: #291145, #289245, #284779)
346   * Add support for Blackdown 1.4.2+01 build. (Closes: #285405)
347   * Fix support for Sun 1.5.0 amd64 builds due to typo. (Closes: #290879)
348   * Mozilla browser plugin name changed in 1.4.2 versions. Detect and correct.
349     (Closes: #273730)
350   * Use --block-size=1M instead of -BM. (Closes: #289005, #291161)
351   * Disable support for Sun JDK 1.3 due to its dependencies on libraries
352     that are simply not available anymore. (Closes: #272972)
353   * Fix up short description a little bit.
354   * Bump Standards-Version to 3.6.1 (no changes)
355   * Be a bit more conservative with the real-root test.
356   * Remove last j2se-package references.
357   * Change Suggests on fakeroot to a Depends because it is worthless both
358     as real root and as a normal user without fakeroot.
359
360   Jeroen van Wolffelaar:
361   * Use DEBFULLNAME, DEBNAME and DEBEMAIL if available, and don't ask for
362     those values in that case. (Closes: #279653)
363   * Updated documentation regarding dropped Sun 1.3 support
364   * Work around multiline df output caused by long device names
365     (Closes: #289006)
366   * Add Replaces: for the generated packages on their *debian counterparts
367
368  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Tue, 25 Jan 2005 00:05:06 +0100
369
370 java-package (0.18) unstable; urgency=low
371
372   * Added myself to Uploaders
373   * Fix security hole (inscure temp file creation) plus lots of needless I/O
374     in free disk checking function
375   * Added support for Sun's JDK/JRE 1.5 patch levels, based on a patch by
376     Peter Marschall <peter@adpm.de> (Closes: #286718, #287857)
377   * Bail out if running as real root (works around the evil parts of Sun's
378     install script that unconditionally writes to /etc, see #266273, #280707)
379   * Fix typo in j2re.sh that apparantly with some versions of
380     bash/dpkg/whatever cause package build failure (Closes: #281780, #282902)
381   * Reduce minimum expected size a bit Sun's 1.5.0 amd64 package, it was set
382     too high (Closes: #284033)
383   * Substitute package version number at build time in the make-jpkg
384     executable (Closes: #282221)
385   * Added a README.Debian explaining the existance of make-jpkg and what
386     binary packages are supported and where to get them. Thanks Thijs
387     Kinkhorst for the draft (Closes: #283362)
388   * Added automatically-generated file SUPPORTED that lists all binary
389     filenames that are supported, thanks Alex Owen <owen@cus.org.uk> for the
390     idea (Closes: #275296)
391
392  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Mon,  3 Jan 2005 18:47:47 +0100
393
394 java-package (0.17) unstable; urgency=low
395
396   * added a patch for detecting the architecture (Closes: #274844,
397     #270949, #271846). This patch should also close this one (Closes:
398     #280685).
399
400  -- Arnaud Vandyck <avdyk@debian.org>  Fri, 12 Nov 2004 17:28:38 +0100
401
402 java-package (0.16) unstable; urgency=low
403
404   * added myself as an uploader.
405   * Carlos already closed the support for 1.5 request but it seems he did
406     not upload the package (Closes: #277088).
407
408  -- Arnaud Vandyck <avdyk@debian.org>  Wed, 10 Nov 2004 16:38:44 +0100
409
410 java-package (0.15) unstable; urgency=low
411
412   * lib/sun-j2re.sh: Added support for JRE 1.5.0 (aka "Java 5.0").
413   * lib/sun-j2sdk.sh: Added support for Java SDK 1.5.0.
414
415  -- Carlos Laviola <claviola@debian.org>  Mon, 11 Oct 2004 21:08:59 -0300
416
417 java-package (0.14) unstable; urgency=low
418
419   * debian/control: Commented out the lines that generate the Debian-specific
420     packages, thus making alternatives available.
421     - Also made all of the generated packages depend on their Debian-specific
422     counterparts by default.  (Closes: #266671)
423
424  -- Carlos Laviola <claviola@debian.org>  Mon, 13 Sep 2004 03:38:31 -0300
425
426 java-package (0.13) unstable; urgency=low
427
428   * References to j2se-package are gone.  (Closes: #267642)
429   * Added support for Blackdown Java 1.4.2 RC1 JRE/SDK.  (Closes: #267643)
430
431  -- Carlos Laviola <claviola@debian.org>  Mon, 13 Sep 2004 03:17:54 -0300
432
433 java-package (0.12) unstable; urgency=low
434
435   * remove to contrib because this package depend on non-free J2SE.
436
437  -- Takashi Okamoto <tora@debian.org>  Tue,  3 Aug 2004 00:37:13 +0900
438
439 java-package (0.11) unstable; urgency=low
440
441   * change package name java-package and the command build package is 
442     make-jpkg.
443
444  -- Takashi Okamoto <tora@debian.org>  Sat, 31 Jul 2004 15:07:36 +0900
445
446 java-package (0.10) unstable; urgency=low
447
448   * change package name mpkg-j2se.
449   * not use *-j2[re|sdk]debian package. Instead of this, add package 
450     dependency to generated package. This reduce the installation for 
451     such extra package. 
452   * SUN's jdk1.5 beta2 support.
453
454  -- Takashi Okamoto <tora@debian.org>  Sun, 18 Jul 2004 13:53:36 +0900
455
456 java-package (0.9) unstable; urgency=low
457
458   * more generic support for j2re1.3.1/j2sdk1.3.1 from SUN.
459
460   * add alternative for jarsigner (in j2sdk1.4 and j2sdk1.5 from SUN).
461
462  -- Hubert Schmid <ude2@z42.de>  Sun, 23 May 2004 23:35:14 +0200
463
464 java-package (0.8) unstable; urgency=low
465
466   * java plugin: support for mozilla-firefox.
467
468  -- Hubert Schmid <ude2@z42.de>  Tue,  4 May 2004 22:39:39 +0200
469
470 java-package (0.7) unstable; urgency=low
471
472   * Optionally create .changes file.
473
474   * Add command line options: --help, --version, --full-name,
475     --email, --changes.
476
477   * Add environment variables: J2SE_PACKAGE_FULL_NAME,
478     J2SE_PACKAGE_EMAIL.
479
480  -- Hubert Schmid <ude2@z42.de>  Sat, 27 Mar 2004 23:01:08 +0100
481
482 java-package (0.6) unstable; urgency=low
483
484   * More generic support for Java2 1.4.2 from SUN.
485
486  -- Hubert Schmid <ude2@z42.de>  Thu, 11 Mar 2004 20:39:51 +0100
487
488 java-package (0.5) unstable; urgency=low
489
490   * NEW: build Blackdown J2RE 1.4.1 (gcc-2.95) and J2SDK 1.4.1 (gcc-2.95).
491
492   * NEW: support for SUN J2RE 1.5.0 beta, SUN J2SDK 1.5.0 beta.
493
494  -- Hubert Schmid <ude2@z42.de>  Sat,  7 Feb 2004 21:57:09 +0100
495
496 java-package (0.4) unstable; urgency=low
497
498   * Added support for: SUN J2RE 1.4.2_03, SUN J2SDK 1.4.2_03
499
500  -- Hubert Schmid <ude2@z42.de>  Thu, 15 Jan 2004 22:27:52 +0100
501
502 java-package (0.3) unstable; urgency=low
503
504   * Added support for: Blackdown J2RE 1.3, 1.4, J2SDK 1.3, 1.4
505
506   * Removed usage of "du --apparent-size". This should fix a problem
507     with old fileutils.
508
509  -- Hubert Schmid <ude2@z42.de>  Sun,  9 Nov 2003 21:13:38 +0100
510
511 java-package (0.2) unstable; urgency=low
512
513   * Added support for: Sun J2RE 1.3, Sun J2SDK 1.3, Sun J2SDK 1.4
514
515   * Moved peer packages into this source package.
516
517  -- Hubert Schmid <ude2@z42.de>  Thu, 30 Oct 2003 00:10:01 +0100
518
519 java-package (0.1) unstable; urgency=low
520
521   * Initial Release.
522
523  -- Hubert Schmid <j2se-package@z42.de>  Sun, 26 Oct 2003 20:06:57 +0100