465393edd0e8bee16e1c9e25f0c984a896f63b1e
[sven/java-package.git] / debian / changelog
1 java-package (0.53) UNRELEASED; urgency=low
2
3   * Team upload.
4   * Added support for early access releases (Closes: #721136)
5   * Added support for GA and FCS releases
6   * Updated the package description:
7     - no longer recommend openjdk-6
8     - mention the compatibility with Java 8
9   * Removed 'Replaces: ${j2se_package}debian' from the generated control file
10   * Adjusted the disk space required to unpack the Java 8 documentation
11
12  -- Emmanuel Bourg <ebourg@apache.org>  Wed, 28 Aug 2013 19:34:41 +0200
13
14 java-package (0.52) unstable; urgency=low
15
16   [ Sylvestre Ledru ]
17   * Team upload
18   * Upload to unstable
19   * Ack the NMU of David Prévot (thanks!)
20   * Standards-Version updated to version 3.9.4
21   * Remove obsolete variable from the changelog
22   * Add support of ARM upstream binary by James Page and Matthias Vill.
23     Thanks guys! (Closes: #687375)
24   * Change the installation path from
25     /usr/lib/jvm/jdk-6.38-oracle-x64 or /usr/lib/jvm/jdk-7.10-oracle-x64
26     to
27     /usr/lib/jvm/jdk-6-oracle-x64 and /usr/lib/jvm/jdk-7-oracle-x64
28     Thanks to Constantin Makshin for the patch (Closes: #696227)
29
30   [ Cédric Pineau ]
31   * Fix lintian errors and warnings
32
33   [ Gabriele Giacone ]
34   * Add {mozilla,firefox}-javaplugin.so for update-java-alternatives.
35   * Fix plugin directories. Closes: #686216
36
37   [ Emmanuel Bourg ]
38   * Switched to the 3.0 (native) package format
39   * debian/control: Use canonical URLs for the Vcs-* fields
40   * debian/copyright: Switched to the Machine-readable format 1.0
41   * Updated the manpages to reflect the latest naming changes
42   * Removed the unused provided dependencies (j2sdk<version>, j2re<version>)
43   * Provide the java<version-1>-runtime and java<version-2>-runtime dependencies
44     (Closes: #691063)
45   * Provide the java<version>-sdk dependencies to match the openjdk package
46   * Use the upstream versioning scheme (i.e 7u13 instead of 7.13)
47     to match the convention used by the new openjdk packages
48   * Renamed the script files (j2sdk->jdk, j2re->jre, j2se->javase)
49
50  -- Sylvestre Ledru <sylvestre@debian.org>  Wed, 05 Jun 2013 13:43:55 +0200
51
52 java-package (0.51~exp1) experimental; urgency=low
53
54   * Add firefox-javaplugin.so alternative Closes: #673670 and LP: #1024368
55   * Add java5 and 6-{runtime|sdk|...} to the provides line in generated packages Closes: #684993 and LP: #995655
56   * Drop installation debconf note Closes: #685082
57   * Correct handling of amd64 in oracle-jdk6.1->4 and improve error message when used with unknown archives
58   * Add support for earlier oracle-jdk6 version
59
60   [Emmanuel Bourg]
61   * Improved detection of the JRE/JDK version (supports 2 digits Java 7 updates) Closes: #597294
62   * Brand and naming cleanup
63   * Documentation directory changed to be /usr/share/doc/oracle-javaV-doc (for oracle)
64
65   [Joerg Schirottke]
66   * Add mozilla-javaplugin.so alternative
67
68  -- Cédric Pineau <cedric.pineau@gmail.com>  Sat, 18 Aug 2012 11:00:34 +0200
69
70 java-package (0.50+nmu2) unstable; urgency=high
71
72   * Non-maintainer upload.
73   * Allow two digits in Java 7 updates. Closes: #597294, #698108
74
75  -- David Prévot <taffit@debian.org>  Tue, 15 Jan 2013 15:06:26 -0400
76
77 java-package (0.50+nmu1) unstable; urgency=low
78
79   * Non-maintainer upload.
80   * Drop installation debconf note. Closes: #685082
81
82  -- David Prévot <taffit@debian.org>  Thu, 06 Sep 2012 18:38:03 -0400
83
84 java-package (0.50) unstable; urgency=low
85
86   * Java-package reset for reintroduction in debian (removal of all
87     previously supported jvm, global refactoring).
88   * Add support for Oracle Java 6 (update >= 10)
89   * Add support for Oracle Java 7
90   * Add support for .jinfo file (update-java-alternatives tool)
91   * Use jdk included jre binaries (jdk/jre/bin/*)
92   * Print usage information on install
93
94   [ Sylvestre Ledru ]
95   * Long description removed
96   * debian-rules-missing-recommended-target removed
97   * maintainer-script-lacks-debhelper-token removed
98   * Declare the debian/compat to 7 to avoid warnings
99   
100   [ Michael Kock ]
101   * Remove Java plugins for all browsers (Closes: #367887).
102   * Add support for Sun Java 6 Update XX (Closes: #514364).
103
104  -- Cédric Pineau <cedric.pineau@gmail.com>  Thu, 22 Dec 2011 11:42:13 +0100
105
106 java-package (0.42) unstable; urgency=low
107
108   * Provide java*-runtime-headless and java*-sdk names for generated
109     packages.
110   * Recommend dpkg-dev and gcc. Closes: #281766, #405814.
111
112  -- Matthias Klose <doko@debian.org>  Sat, 02 Aug 2008 12:10:52 +0200
113
114 java-package (0.41) unstable; urgency=low
115
116   * Added support for new SUN JDK/JRE for amd64 downloads. Thanks to
117     Artyom Gavrichenkov for the initial patch.
118
119  -- Michael Koch <konqueror@gmx.de>  Fri, 21 Mar 2008 17:20:35 +0100
120
121 java-package (0.40) unstable; urgency=low
122
123   * Add support for ibm-java2-sdk-5.0-6.0-linux-$arch.tgz. Closes: #462399
124     Thanks to Evgeni Dobrev for the patch.
125   * Fixed spelling error in long description: debian -> Debian.
126
127  -- Michael Koch <konqueror@gmx.de>  Thu, 24 Jan 2008 22:48:46 +0100
128
129 java-package (0.39) unstable; urgency=low
130
131   * Added support for IBM JDK 6.0 final release.
132   * Updated Standard-Version to 3.7.3.
133   * Updated debhelper level to 5.
134
135  -- Michael Koch <konqueror@gmx.de>  Tue, 18 Dec 2007 07:38:34 +0100
136
137 java-package (0.38) unstable; urgency=low
138
139   * Mention SUN JDK 6 in REAME.Debian. Closes: #448258.
140   * Fixed typo when creating version number for SUN JDK 6. Closes: #451935.
141   * Fix handling of symlinks for ControlPanel, HtmlConverter and java-rmi.cgi
142     from SUN JDK 6. Closes: #448351.
143
144  -- Michael Koch <konqueror@gmx.de>  Fri, 30 Nov 2007 00:03:50 +0100
145
146 java-package (0.37) unstable; urgency=low
147
148   * Added libstdc++5 to Recommends of generated package. Closes: #446334.
149
150  -- Michael Koch <konqueror@gmx.de>  Thu, 25 Oct 2007 22:45:42 +0200
151
152 java-package (0.36) unstable; urgency=low
153
154   * Fixed package description to include more supported JDKs.
155     Closes: #447615, #447617.
156
157  -- Michael Koch <konqueror@gmx.de>  Wed, 24 Oct 2007 09:56:52 +0200
158
159 java-package (0.35) unstable; urgency=low
160
161   * Use 'date -R' instead of the deprecated '822-date'. Closes: #441229.
162   * Fix generation of .changes file. Closes: #332643.
163     Thanks to Christoph Goehre for the patch.
164   * Add possibility to add a configured revision to the version.
165     Closes: #442246. Thanks to Christoph Goehre again for the patch.
166
167  -- Michael Koch <konqueror@gmx.de>  Fri, 14 Sep 2007 17:28:13 +0200
168
169 java-package (0.34) unstable; urgency=low
170
171   * Fixed SUN JDK on amd64. Closes: #439221.
172
173  -- Michael Koch <konqueror@gmx.de>  Fri, 24 Aug 2007 00:41:54 +0200
174
175 java-package (0.33) unstable; urgency=low
176
177   * Fixed postinst scripts for SUN JDK 1.4, 5 and 6. Closes: #435632.
178
179  -- Michael Koch <konqueror@gmx.de>  Thu, 02 Aug 2007 18:43:40 +0200
180
181 java-package (0.32) unstable; urgency=low
182
183   * Added support for iceweasel. Closes: #433445.
184   * Fix dangling links for SUN Java 5. Closes: #305053.
185   * Depend on libx11-6 and libasound2. Closes: #289004.
186   * Fix building on ia64. Closes: #355465.
187
188  -- Michael Koch <konqueror@gmx.de>  Thu, 19 Jul 2007 22:51:31 +0200
189
190 java-package (0.31) unstable; urgency=low
191
192   * Reapplied changes from 0.28 to 0.29. Closes: 322843.
193
194  -- Michael Koch <konqueror@gmx.de>  Tue, 10 Jul 2007 08:16:14 +0200
195
196 java-package (0.30) unstable; urgency=low
197
198   * Added support for SUN JDK 6u2 (and following updates).
199   * Added support for ibm-java2-jre-5.0-5.0-linux-ppc.tgz.
200     Thanks to B. Zhang.
201
202  -- Michael Koch <konqueror@gmx.de>  Sun, 08 Jul 2007 09:33:29 +0200
203
204 java-package (0.29) unstable; urgency=low
205
206   * Added support for SUN Java 6 and IBM Java 6.
207     Closes: #322843, #402642, #418592, #425508, #430026.
208   * Added myself to Uploaders.
209
210  -- Michael Koch <konqueror@gmx.de>  Tue, 26 Jun 2007 17:40:04 -0100
211
212 java-package (0.28) unstable; urgency=low
213
214   * Modified to reflect migration to Subversion
215   * Bumped standards to version 3.7.2, no changes
216   * Corrected test for AMD64 architecture during plug-in detection
217   * Corrected detected version for IBM Java 5 JDK on AMD64 (Closes: #345775)
218   * Repaired alternatives handling for IBM Java 5 JREs and JDKs
219     (Closes: #338569)
220   * Corrected pathing for alternatives installation for Mozilla and
221     Firefox plugins (Closes: #341751)
222   * Relaxed architectural restrictions on plugin alternative 
223     installation for IBM Java 5 JREs and JDKs (Closes: #343837)
224   * Added plugin installation for the new packaging of Firefox 1.5 and
225     later (Closes: #341749)
226   * Modified warning suppression for dh_shlibdeps to accommodate 
227     changes in dpkg-dev (Closes: #354427)
228   * Added quotes to variable tests for maintainer name and email 
229     (Closes: #342623)
230   * Refactored architecture evaluation to eliminate repetition and
231     evaluate DEB_BUILD_GNU_TYPE correctly for i486-linux-gnu
232   * Removed dependency on 'coreutils | stat' from control file, as
233     the dependency is satisfied within essential (Closes: #370002)
234
235  -- Barry Hawkins <barry@alltc.com>  Mon, 26 Jun 2006 11:19:08 -0400
236
237 java-package (0.27) unstable; urgency=low
238
239   * Added support for IBM Java2 5.0 JREs and JDKs (Closes: #337129)
240   * Corrected missing alternatives links for all JREs and JDKs
241     (Closes: #317492)
242   * Added conditional wrapping around dh_compress to account for
243     JRE/JDKs that do not ship manpages (Closes: 301738)
244   * Removed java-common from Provides: for JRE and JDK packages.
245
246  -- Barry Hawkins <barry@bytemason.org>  Tue, 08 Nov 2005 12:16:24 -0500
247
248 java-package (0.26) unstable; urgency=low
249
250   * Update standards version to 3.6.2
251   * Resolve issues with powerpc-linux support detection (Closes: #317671)
252   * Added support for Blackdown 1.4.2+02 release (Closes: #316831)
253   * Added support for packaging Sun JDK documentation (Closes: #272971)
254   * Modified make-jpkg behavior to default the generated packages' 
255     name and email address for the maintainer to Debian Java Maintainers
256     (Closes: #325554)
257
258  -- Barry Hawkins <barry@bytemason.org>  Thu, 18 Aug 2005 00:43:17 -0400
259
260 java-package (0.25) unstable; urgency=low
261
262   * Cope with dpkg's new way of expressing architectures (Closes: #313555)
263   * Re-exec with fakeroot if needed (Closes: #310132)
264
265  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Sun, 10 Jul 2005 18:50:40 +0200
266
267 java-package (0.24) unstable; urgency=low
268
269   * Added plugin alternatives support for i386 IBM JREs and JDKs
270   * Corrected pathing for plugin alternatives to reflect difference in 
271     layout between JREs and JDKs for Sun and Blackdown (Closes: #305219,
272     #301806)
273
274  -- Barry Hawkins <barry@bytemason.org>  Wed, 21 Apr 2005 01:02:03 -0400
275
276 java-package (0.23.1) experimental; urgency=low
277
278   * Added architecture-specific pathing for plugin alternatives for 
279     Blackdown 1.3 and 1.4 JREs and JDKs
280
281  -- Barry Hawkins <barry@bytemason.org>  Wed, 06 Apr 2005 00:03:40 -0500
282
283 java-package (0.23) unstable; urgency=low
284
285   * Further expanded 1.3.1 Blackdown JRE/JDK support for i386
286   * Added architecture-specific pathing for plugin alternatives for 
287     Sun 1.4 and 1.5 JREs and JDKs (Closes: #301806)
288   * Added recommends for system elements required by applets and 
289     graphical user interface elements (Closes: #300817)
290   * Jeroen van Wolffelaar:
291     + Fixed packages description to not have too long lines, and make the 3
292       items an enumeration
293
294  -- Barry Hawkins <barry@bytemason.org>  Fri, 01 Apr 2005 00:36:40 -0500
295
296 java-package (0.22.1) experimental; urgency=low
297
298   * Corrected IBM and Blackdown JRE/JDK file size specifications
299   * Added support for additional 1.3.1 Blackdown JREs and JDKs for i386,
300     powerpc (Closes: #301092)
301   * Added installation of javaws alternative for Sun 1.5 JREs and JDKs 
302     (Closes: #300303)
303
304  -- Barry Hawkins <barry@bytemason.org>  Thu, 24 Mar 2005 13:20:18 -0500
305
306 java-package (0.22) unstable; urgency=low
307
308   * Corrected IBM JRE/JDK scripts to accurately reflect the supported 
309     IBM JDKs and JREs in the generated SUPPORTED file
310
311  -- Barry Hawkins <barry@alltc.com>  Fri, 18 Mar 2005 10:21:53 -0500
312
313 java-package (0.21) unstable; urgency=low
314
315   * Enable support for IBM JDKs and JREs for x86, amd64, powerpc, 
316     powerpc64, and s390 architectures, based upon a patch by Rico 
317     Schiekel (Closes: #264137)
318   * Enable suppport for Blackdown 1.3.1 JDK and JRE for PowerPC 
319     architecture. (Closes: #296205)
320   * Update documentation and to reflect current supported JDKs and JREs
321
322  -- Barry Hawkins <barry@alltc.com>  Mon, 14 Mar 2005 03:18:39 -0500
323
324 java-package (0.20) unstable; urgency=low
325
326   * Make the postinst & rm for generated packages #!/bin/bash, as we use
327     bash-specific features (Closes: #292179)
328   * Drop the df output parsing, use '/usr/bin/stat' instead (Closes: #293487,
329     #289006, #293350)
330   * Drop the now obsolete peer stuff from the source package
331   * Change priorities, 313 for 1.3, 314 for 1.4, etc (Closes: #292451)
332   * Don't dh_strip, fiddling with upstream's binaries apparantly breaks stuff
333     (Closes: #291238)
334
335  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Tue, 08 Feb 2005 15:04:51 +0100
336
337 java-package (0.19) unstable; urgency=low
338
339   The "Joshua Kwan <joshk@debian.org> rocks!" release.
340
341   Joshua Kwan:
342   * Unclutter Debian build system and rework package slightly so that
343     *debian packages are not needed anymore. The necessary files will be
344     included in the generated packages. (Closes: #291145, #289245, #284779)
345   * Add support for Blackdown 1.4.2+01 build. (Closes: #285405)
346   * Fix support for Sun 1.5.0 amd64 builds due to typo. (Closes: #290879)
347   * Mozilla browser plugin name changed in 1.4.2 versions. Detect and correct.
348     (Closes: #273730)
349   * Use --block-size=1M instead of -BM. (Closes: #289005, #291161)
350   * Disable support for Sun JDK 1.3 due to its dependencies on libraries
351     that are simply not available anymore. (Closes: #272972)
352   * Fix up short description a little bit.
353   * Bump Standards-Version to 3.6.1 (no changes)
354   * Be a bit more conservative with the real-root test.
355   * Remove last j2se-package references.
356   * Change Suggests on fakeroot to a Depends because it is worthless both
357     as real root and as a normal user without fakeroot.
358
359   Jeroen van Wolffelaar:
360   * Use DEBFULLNAME, DEBNAME and DEBEMAIL if available, and don't ask for
361     those values in that case. (Closes: #279653)
362   * Updated documentation regarding dropped Sun 1.3 support
363   * Work around multiline df output caused by long device names
364     (Closes: #289006)
365   * Add Replaces: for the generated packages on their *debian counterparts
366
367  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Tue, 25 Jan 2005 00:05:06 +0100
368
369 java-package (0.18) unstable; urgency=low
370
371   * Added myself to Uploaders
372   * Fix security hole (inscure temp file creation) plus lots of needless I/O
373     in free disk checking function
374   * Added support for Sun's JDK/JRE 1.5 patch levels, based on a patch by
375     Peter Marschall <peter@adpm.de> (Closes: #286718, #287857)
376   * Bail out if running as real root (works around the evil parts of Sun's
377     install script that unconditionally writes to /etc, see #266273, #280707)
378   * Fix typo in j2re.sh that apparantly with some versions of
379     bash/dpkg/whatever cause package build failure (Closes: #281780, #282902)
380   * Reduce minimum expected size a bit Sun's 1.5.0 amd64 package, it was set
381     too high (Closes: #284033)
382   * Substitute package version number at build time in the make-jpkg
383     executable (Closes: #282221)
384   * Added a README.Debian explaining the existance of make-jpkg and what
385     binary packages are supported and where to get them. Thanks Thijs
386     Kinkhorst for the draft (Closes: #283362)
387   * Added automatically-generated file SUPPORTED that lists all binary
388     filenames that are supported, thanks Alex Owen <owen@cus.org.uk> for the
389     idea (Closes: #275296)
390
391  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Mon,  3 Jan 2005 18:47:47 +0100
392
393 java-package (0.17) unstable; urgency=low
394
395   * added a patch for detecting the architecture (Closes: #274844,
396     #270949, #271846). This patch should also close this one (Closes:
397     #280685).
398
399  -- Arnaud Vandyck <avdyk@debian.org>  Fri, 12 Nov 2004 17:28:38 +0100
400
401 java-package (0.16) unstable; urgency=low
402
403   * added myself as an uploader.
404   * Carlos already closed the support for 1.5 request but it seems he did
405     not upload the package (Closes: #277088).
406
407  -- Arnaud Vandyck <avdyk@debian.org>  Wed, 10 Nov 2004 16:38:44 +0100
408
409 java-package (0.15) unstable; urgency=low
410
411   * lib/sun-j2re.sh: Added support for JRE 1.5.0 (aka "Java 5.0").
412   * lib/sun-j2sdk.sh: Added support for Java SDK 1.5.0.
413
414  -- Carlos Laviola <claviola@debian.org>  Mon, 11 Oct 2004 21:08:59 -0300
415
416 java-package (0.14) unstable; urgency=low
417
418   * debian/control: Commented out the lines that generate the Debian-specific
419     packages, thus making alternatives available.
420     - Also made all of the generated packages depend on their Debian-specific
421     counterparts by default.  (Closes: #266671)
422
423  -- Carlos Laviola <claviola@debian.org>  Mon, 13 Sep 2004 03:38:31 -0300
424
425 java-package (0.13) unstable; urgency=low
426
427   * References to j2se-package are gone.  (Closes: #267642)
428   * Added support for Blackdown Java 1.4.2 RC1 JRE/SDK.  (Closes: #267643)
429
430  -- Carlos Laviola <claviola@debian.org>  Mon, 13 Sep 2004 03:17:54 -0300
431
432 java-package (0.12) unstable; urgency=low
433
434   * remove to contrib because this package depend on non-free J2SE.
435
436  -- Takashi Okamoto <tora@debian.org>  Tue,  3 Aug 2004 00:37:13 +0900
437
438 java-package (0.11) unstable; urgency=low
439
440   * change package name java-package and the command build package is 
441     make-jpkg.
442
443  -- Takashi Okamoto <tora@debian.org>  Sat, 31 Jul 2004 15:07:36 +0900
444
445 java-package (0.10) unstable; urgency=low
446
447   * change package name mpkg-j2se.
448   * not use *-j2[re|sdk]debian package. Instead of this, add package 
449     dependency to generated package. This reduce the installation for 
450     such extra package. 
451   * SUN's jdk1.5 beta2 support.
452
453  -- Takashi Okamoto <tora@debian.org>  Sun, 18 Jul 2004 13:53:36 +0900
454
455 java-package (0.9) unstable; urgency=low
456
457   * more generic support for j2re1.3.1/j2sdk1.3.1 from SUN.
458
459   * add alternative for jarsigner (in j2sdk1.4 and j2sdk1.5 from SUN).
460
461  -- Hubert Schmid <ude2@z42.de>  Sun, 23 May 2004 23:35:14 +0200
462
463 java-package (0.8) unstable; urgency=low
464
465   * java plugin: support for mozilla-firefox.
466
467  -- Hubert Schmid <ude2@z42.de>  Tue,  4 May 2004 22:39:39 +0200
468
469 java-package (0.7) unstable; urgency=low
470
471   * Optionally create .changes file.
472
473   * Add command line options: --help, --version, --full-name,
474     --email, --changes.
475
476   * Add environment variables: J2SE_PACKAGE_FULL_NAME,
477     J2SE_PACKAGE_EMAIL.
478
479  -- Hubert Schmid <ude2@z42.de>  Sat, 27 Mar 2004 23:01:08 +0100
480
481 java-package (0.6) unstable; urgency=low
482
483   * More generic support for Java2 1.4.2 from SUN.
484
485  -- Hubert Schmid <ude2@z42.de>  Thu, 11 Mar 2004 20:39:51 +0100
486
487 java-package (0.5) unstable; urgency=low
488
489   * NEW: build Blackdown J2RE 1.4.1 (gcc-2.95) and J2SDK 1.4.1 (gcc-2.95).
490
491   * NEW: support for SUN J2RE 1.5.0 beta, SUN J2SDK 1.5.0 beta.
492
493  -- Hubert Schmid <ude2@z42.de>  Sat,  7 Feb 2004 21:57:09 +0100
494
495 java-package (0.4) unstable; urgency=low
496
497   * Added support for: SUN J2RE 1.4.2_03, SUN J2SDK 1.4.2_03
498
499  -- Hubert Schmid <ude2@z42.de>  Thu, 15 Jan 2004 22:27:52 +0100
500
501 java-package (0.3) unstable; urgency=low
502
503   * Added support for: Blackdown J2RE 1.3, 1.4, J2SDK 1.3, 1.4
504
505   * Removed usage of "du --apparent-size". This should fix a problem
506     with old fileutils.
507
508  -- Hubert Schmid <ude2@z42.de>  Sun,  9 Nov 2003 21:13:38 +0100
509
510 java-package (0.2) unstable; urgency=low
511
512   * Added support for: Sun J2RE 1.3, Sun J2SDK 1.3, Sun J2SDK 1.4
513
514   * Moved peer packages into this source package.
515
516  -- Hubert Schmid <ude2@z42.de>  Thu, 30 Oct 2003 00:10:01 +0100
517
518 java-package (0.1) unstable; urgency=low
519
520   * Initial Release.
521
522  -- Hubert Schmid <j2se-package@z42.de>  Sun, 26 Oct 2003 20:06:57 +0100