50323235156669b9e030bf27704fd0d1dcc75dfa
[sven/java-package.git] / debian / changelog
1 java-package (0.62) UNRELEASED; urgency=medium
2
3   * Team upload.
4   * Bump Standards-Version to 3.9.8 (no changes)
5   * Add --distribution option to override hard-coded value of unstable.
6     Thank you to Martin Gerhard Loschwitz for the patch. (Closes: #819537)
7   * Add --jce-policy <policy.zip> option to build with JCE policy file.
8     Thank you to Alex Brown for the patch. (Closes: #833301)
9
10  -- tony mancill <tmancill@debian.org>  Sat, 10 Sep 2016 10:01:07 -0700
11
12 java-package (0.61) unstable; urgency=medium
13
14   * Team upload.
15   * Bump Standards-Version to 3.9.7 (no changes)
16   * Use package name plus architecture as directory in /usr/lib/jvm
17   * Add support for server JRE (Closes: #776389)
18   * Update Vcs-Browser and Vcs-Git to use HTTPS
19
20  -- Benjamin Drung <benjamin.drung@profitbricks.com>  Fri, 18 Mar 2016 17:50:51 +0100
21
22 java-package (0.60) unstable; urgency=medium
23
24   * Team upload.
25
26   [ Emmanuel Bourg ]
27   * Added jcontrol to the command line alternatives (Closes: #799370)
28   * Fixed the detection of the latest Java 8 documentation archives.
29   * Fixed the dh_shlibdeps error when generating a documentation package
30     (Closes: #753071)
31   * Changed the architecture of the documentation packages from any to all.
32   * Changed the section of the documentation packages to non-free/doc
33   * Disabled dh_strip_nondeterminism when generating the Java packages
34     to speed up the build
35
36   [ tony mancill ]
37   * Update the package long description.
38   * Add build-essential as a dependency and drop the (now redundant)
39     recommends on gcc. (Closes: #787809)
40   * Use du --apparent-size when checking the size of the unpacked
41     distribution. (Closes: #794401)
42
43  -- Emmanuel Bourg <ebourg@apache.org>  Mon, 30 Nov 2015 14:23:05 +0100
44
45 java-package (0.59) unstable; urgency=medium
46
47   * Team upload.
48   * Upload to unstable.
49   * Add following dependencies to address build failures for dpkg-shlibdeps
50     errors during make-jpkg of JDK/JRE:
51     libgl1-mesa-glx libfontconfig1 libxslt1.1 libxtst6 libxxf86vm1 libgtk2.0-0
52     (Closes: #782132)
53
54  -- tony mancill <tmancill@debian.org>  Sat, 16 May 2015 13:46:27 -0700
55
56 java-package (0.58) experimental; urgency=medium
57
58   [ Francesc Zacarias ]
59   * New --with-system-certs option to use the system keystore (Closes: #776395)
60
61   [ Emmanuel Bourg ]
62   * Removed the generated package mistakenly included in the source package
63     (Closes: #779727)
64
65  -- Emmanuel Bourg <ebourg@apache.org>  Thu, 05 Mar 2015 00:09:05 +0100
66
67 java-package (0.57) experimental; urgency=medium
68
69   * Team upload.
70   * Include Java 8 in the help message of make-jpkg (Closes: #775977)
71   * Provide all runtimes since Java 5, thanks to Laurens Blankers
72     (Closes: #775987)
73   * Added more command line tool alternatives: jmc and jvisualvm
74     (Closes: #676877)
75   * Standards-Version updated to 3.9.6 (no changes)
76
77  -- Emmanuel Bourg <ebourg@apache.org>  Sun, 25 Jan 2015 00:02:59 +0100
78
79 java-package (0.56) unstable; urgency=medium
80
81   * Team upload.
82   * Do not Build-Depends libavcodec53 and libavformat53 for Java 8.
83     Thanks to Chris Jester-Young for the patch. (Closes: #751974)
84   * Set the urcency of the guest package to medium.
85
86  -- Benjamin Drung <benjamin.drung@profitbricks.com>  Fri, 20 Jun 2014 11:10:45 +0200
87
88 java-package (0.55) unstable; urgency=medium
89
90   [ tony mancill ]
91   * Team upload.
92   * Add lsb-release to Depends (used in make-jpkg).
93   * Apply patch to honor --revision argument.
94     Thanks to Alberto Caso Palomino. (Closes: #743919)
95
96   [ Emmanuel Bourg ]
97   * Bumped the Standards-Version of the generated package to 3.9.5
98   * Use debhelper level 9 in the generated package
99
100   [ Benjamin Drung ]
101   * Add a debian/rules file to the generated source package.
102   * Use dpkg-buildpackage to build the guest package.
103   * Add ${misc:Depends} to the guest dependency.
104   * Add --source option to build a source package instead of a binary deb
105     package. (Closes: #745762)
106   * Replace lsb_release call by dpkg-vendor call.
107   * Convert copyright file content to UTF-8 for guest debian/copyright.
108   * Remove trailing spaces from copyright file.
109   * Create build depends for JDK guest package.
110
111  -- Benjamin Drung <benjamin.drung@profitbricks.com>  Tue, 17 Jun 2014 20:41:39 +0200
112
113 java-package (0.54) unstable; urgency=medium
114
115   * Team upload.
116   * Added support for ARM VFP/hard-float JDK releases.
117     Thanks to Christopher Huhn <C.Huhn@gsi.de> (Closes: #724455)
118   * Added more command line tool alternatives: jcmd, jdeps, jhat, jrunscript,
119     schemagen, wsgen, wsimport and xjc
120   * Standards-Version updated to 3.9.5 (no changes)
121   * Removed the suggested dependency on openjdk-6-jre
122   * Switch to debhelper level 9
123
124  -- Emmanuel Bourg <ebourg@apache.org>  Mon, 24 Mar 2014 18:44:58 +0100
125
126 java-package (0.53) unstable; urgency=low
127
128   * Team upload.
129   * Added support for early access releases (Closes: #721136)
130   * Added support for GA and FCS releases
131   * Excluded the fxavcodecplugin libraries used by JavaFX from the dependency
132     calculation performed by dh_shlibdeps to avoid errors (Closes: #687075)
133   * Updated the package description and debian/README.Debian:
134     - no longer recommend openjdk-6
135     - mention the compatibility with Java 8
136   * Removed 'Replaces: ${j2se_package}debian' from the generated control file
137   * Adjusted the disk space required to unpack the Java 8 documentation
138   * Updated the manpages for Java 8
139   * Updated debhelper level to 7
140   * debian/rules: Use dh_prep instead of dh_clean -k
141   * Removed the recommended dependency on libstdc++5 from the generated
142     control file (used by the now unsupported IBM JDK 5)
143   * Removed the recommended dependency on libgtk1.2 from the generated
144     control file (removed from Squeeze)
145   * Removed the recommended dependency on libx11-6 and libasound2 from
146     the generated control file (these dependencies are already injected
147     by dh_shlibdeps)
148   * Removed the references to "Java 2" from the description of the generated
149     JRE package
150   * Changed the short description of the generate packages to match
151     the official name
152
153  -- Emmanuel Bourg <ebourg@apache.org>  Tue, 10 Sep 2013 14:42:43 +0200
154
155 java-package (0.52) unstable; urgency=low
156
157   [ Sylvestre Ledru ]
158   * Team upload
159   * Upload to unstable
160   * Ack the NMU of David Prévot (thanks!)
161   * Standards-Version updated to version 3.9.4
162   * Remove obsolete variable from the changelog
163   * Add support of ARM upstream binary by James Page and Matthias Vill.
164     Thanks guys! (Closes: #687375)
165   * Change the installation path from
166     /usr/lib/jvm/jdk-6.38-oracle-x64 or /usr/lib/jvm/jdk-7.10-oracle-x64
167     to
168     /usr/lib/jvm/jdk-6-oracle-x64 and /usr/lib/jvm/jdk-7-oracle-x64
169     Thanks to Constantin Makshin for the patch (Closes: #696227)
170
171   [ Cédric Pineau ]
172   * Fix lintian errors and warnings
173
174   [ Gabriele Giacone ]
175   * Add {mozilla,firefox}-javaplugin.so for update-java-alternatives.
176   * Fix plugin directories. Closes: #686216
177
178   [ Emmanuel Bourg ]
179   * Switched to the 3.0 (native) package format
180   * debian/control: Use canonical URLs for the Vcs-* fields
181   * debian/copyright: Switched to the Machine-readable format 1.0
182   * Updated the manpages to reflect the latest naming changes
183   * Removed the unused provided dependencies (j2sdk<version>, j2re<version>)
184   * Provide the java<version-1>-runtime and java<version-2>-runtime dependencies
185     (Closes: #691063)
186   * Provide the java<version>-sdk dependencies to match the openjdk package
187   * Use the upstream versioning scheme (i.e 7u13 instead of 7.13)
188     to match the convention used by the new openjdk packages
189   * Renamed the script files (j2sdk->jdk, j2re->jre, j2se->javase)
190
191  -- Sylvestre Ledru <sylvestre@debian.org>  Wed, 05 Jun 2013 13:43:55 +0200
192
193 java-package (0.51~exp1) experimental; urgency=low
194
195   * Add firefox-javaplugin.so alternative Closes: #673670 and LP: #1024368
196   * Add java5 and 6-{runtime|sdk|...} to the provides line in generated packages Closes: #684993 and LP: #995655
197   * Drop installation debconf note Closes: #685082
198   * Correct handling of amd64 in oracle-jdk6.1->4 and improve error message when used with unknown archives
199   * Add support for earlier oracle-jdk6 version
200
201   [Emmanuel Bourg]
202   * Improved detection of the JRE/JDK version (supports 2 digits Java 7 updates) Closes: #597294
203   * Brand and naming cleanup
204   * Documentation directory changed to be /usr/share/doc/oracle-javaV-doc (for oracle)
205
206   [Joerg Schirottke]
207   * Add mozilla-javaplugin.so alternative
208
209  -- Cédric Pineau <cedric.pineau@gmail.com>  Sat, 18 Aug 2012 11:00:34 +0200
210
211 java-package (0.50+nmu2) unstable; urgency=high
212
213   * Non-maintainer upload.
214   * Allow two digits in Java 7 updates. Closes: #597294, #698108
215
216  -- David Prévot <taffit@debian.org>  Tue, 15 Jan 2013 15:06:26 -0400
217
218 java-package (0.50+nmu1) unstable; urgency=low
219
220   * Non-maintainer upload.
221   * Drop installation debconf note. Closes: #685082
222
223  -- David Prévot <taffit@debian.org>  Thu, 06 Sep 2012 18:38:03 -0400
224
225 java-package (0.50) unstable; urgency=low
226
227   * Java-package reset for reintroduction in debian (removal of all
228     previously supported jvm, global refactoring).
229   * Add support for Oracle Java 6 (update >= 10)
230   * Add support for Oracle Java 7
231   * Add support for .jinfo file (update-java-alternatives tool)
232   * Use jdk included jre binaries (jdk/jre/bin/*)
233   * Print usage information on install
234
235   [ Sylvestre Ledru ]
236   * Long description removed
237   * debian-rules-missing-recommended-target removed
238   * maintainer-script-lacks-debhelper-token removed
239   * Declare the debian/compat to 7 to avoid warnings
240
241   [ Michael Koch ]
242   * Remove Java plugins for all browsers (Closes: #367887).
243   * Add support for Sun Java 6 Update XX (Closes: #514364).
244
245  -- Cédric Pineau <cedric.pineau@gmail.com>  Thu, 22 Dec 2011 11:42:13 +0100
246
247 java-package (0.42) unstable; urgency=low
248
249   * Provide java*-runtime-headless and java*-sdk names for generated
250     packages.
251   * Recommend dpkg-dev and gcc. Closes: #281766, #405814.
252
253  -- Matthias Klose <doko@debian.org>  Sat, 02 Aug 2008 12:10:52 +0200
254
255 java-package (0.41) unstable; urgency=low
256
257   * Added support for new SUN JDK/JRE for amd64 downloads. Thanks to
258     Artyom Gavrichenkov for the initial patch.
259
260  -- Michael Koch <konqueror@gmx.de>  Fri, 21 Mar 2008 17:20:35 +0100
261
262 java-package (0.40) unstable; urgency=low
263
264   * Add support for ibm-java2-sdk-5.0-6.0-linux-$arch.tgz. Closes: #462399
265     Thanks to Evgeni Dobrev for the patch.
266   * Fixed spelling error in long description: debian -> Debian.
267
268  -- Michael Koch <konqueror@gmx.de>  Thu, 24 Jan 2008 22:48:46 +0100
269
270 java-package (0.39) unstable; urgency=low
271
272   * Added support for IBM JDK 6.0 final release.
273   * Updated Standard-Version to 3.7.3.
274   * Updated debhelper level to 5.
275
276  -- Michael Koch <konqueror@gmx.de>  Tue, 18 Dec 2007 07:38:34 +0100
277
278 java-package (0.38) unstable; urgency=low
279
280   * Mention SUN JDK 6 in REAME.Debian. Closes: #448258.
281   * Fixed typo when creating version number for SUN JDK 6. Closes: #451935.
282   * Fix handling of symlinks for ControlPanel, HtmlConverter and java-rmi.cgi
283     from SUN JDK 6. Closes: #448351.
284
285  -- Michael Koch <konqueror@gmx.de>  Fri, 30 Nov 2007 00:03:50 +0100
286
287 java-package (0.37) unstable; urgency=low
288
289   * Added libstdc++5 to Recommends of generated package. Closes: #446334.
290
291  -- Michael Koch <konqueror@gmx.de>  Thu, 25 Oct 2007 22:45:42 +0200
292
293 java-package (0.36) unstable; urgency=low
294
295   * Fixed package description to include more supported JDKs.
296     Closes: #447615, #447617.
297
298  -- Michael Koch <konqueror@gmx.de>  Wed, 24 Oct 2007 09:56:52 +0200
299
300 java-package (0.35) unstable; urgency=low
301
302   * Use 'date -R' instead of the deprecated '822-date'. Closes: #441229.
303   * Fix generation of .changes file. Closes: #332643.
304     Thanks to Christoph Goehre for the patch.
305   * Add possibility to add a configured revision to the version.
306     Closes: #442246. Thanks to Christoph Goehre again for the patch.
307
308  -- Michael Koch <konqueror@gmx.de>  Fri, 14 Sep 2007 17:28:13 +0200
309
310 java-package (0.34) unstable; urgency=low
311
312   * Fixed SUN JDK on amd64. Closes: #439221.
313
314  -- Michael Koch <konqueror@gmx.de>  Fri, 24 Aug 2007 00:41:54 +0200
315
316 java-package (0.33) unstable; urgency=low
317
318   * Fixed postinst scripts for SUN JDK 1.4, 5 and 6. Closes: #435632.
319
320  -- Michael Koch <konqueror@gmx.de>  Thu, 02 Aug 2007 18:43:40 +0200
321
322 java-package (0.32) unstable; urgency=low
323
324   * Added support for iceweasel. Closes: #433445.
325   * Fix dangling links for SUN Java 5. Closes: #305053.
326   * Depend on libx11-6 and libasound2. Closes: #289004.
327   * Fix building on ia64. Closes: #355465.
328
329  -- Michael Koch <konqueror@gmx.de>  Thu, 19 Jul 2007 22:51:31 +0200
330
331 java-package (0.31) unstable; urgency=low
332
333   * Reapplied changes from 0.28 to 0.29. Closes: 322843.
334
335  -- Michael Koch <konqueror@gmx.de>  Tue, 10 Jul 2007 08:16:14 +0200
336
337 java-package (0.30) unstable; urgency=low
338
339   * Added support for SUN JDK 6u2 (and following updates).
340   * Added support for ibm-java2-jre-5.0-5.0-linux-ppc.tgz.
341     Thanks to B. Zhang.
342
343  -- Michael Koch <konqueror@gmx.de>  Sun, 08 Jul 2007 09:33:29 +0200
344
345 java-package (0.29) unstable; urgency=low
346
347   * Added support for SUN Java 6 and IBM Java 6.
348     Closes: #322843, #402642, #418592, #425508, #430026.
349   * Added myself to Uploaders.
350
351  -- Michael Koch <konqueror@gmx.de>  Tue, 26 Jun 2007 17:40:04 -0100
352
353 java-package (0.28) unstable; urgency=low
354
355   * Modified to reflect migration to Subversion
356   * Bumped standards to version 3.7.2, no changes
357   * Corrected test for AMD64 architecture during plug-in detection
358   * Corrected detected version for IBM Java 5 JDK on AMD64 (Closes: #345775)
359   * Repaired alternatives handling for IBM Java 5 JREs and JDKs
360     (Closes: #338569)
361   * Corrected pathing for alternatives installation for Mozilla and
362     Firefox plugins (Closes: #341751)
363   * Relaxed architectural restrictions on plugin alternative
364     installation for IBM Java 5 JREs and JDKs (Closes: #343837)
365   * Added plugin installation for the new packaging of Firefox 1.5 and
366     later (Closes: #341749)
367   * Modified warning suppression for dh_shlibdeps to accommodate
368     changes in dpkg-dev (Closes: #354427)
369   * Added quotes to variable tests for maintainer name and email
370     (Closes: #342623)
371   * Refactored architecture evaluation to eliminate repetition and
372     evaluate DEB_BUILD_GNU_TYPE correctly for i486-linux-gnu
373   * Removed dependency on 'coreutils | stat' from control file, as
374     the dependency is satisfied within essential (Closes: #370002)
375
376  -- Barry Hawkins <barry@alltc.com>  Mon, 26 Jun 2006 11:19:08 -0400
377
378 java-package (0.27) unstable; urgency=low
379
380   * Added support for IBM Java2 5.0 JREs and JDKs (Closes: #337129)
381   * Corrected missing alternatives links for all JREs and JDKs
382     (Closes: #317492)
383   * Added conditional wrapping around dh_compress to account for
384     JRE/JDKs that do not ship manpages (Closes: 301738)
385   * Removed java-common from Provides: for JRE and JDK packages.
386
387  -- Barry Hawkins <barry@bytemason.org>  Tue, 08 Nov 2005 12:16:24 -0500
388
389 java-package (0.26) unstable; urgency=low
390
391   * Update standards version to 3.6.2
392   * Resolve issues with powerpc-linux support detection (Closes: #317671)
393   * Added support for Blackdown 1.4.2+02 release (Closes: #316831)
394   * Added support for packaging Sun JDK documentation (Closes: #272971)
395   * Modified make-jpkg behavior to default the generated packages'
396     name and email address for the maintainer to Debian Java Maintainers
397     (Closes: #325554)
398
399  -- Barry Hawkins <barry@bytemason.org>  Thu, 18 Aug 2005 00:43:17 -0400
400
401 java-package (0.25) unstable; urgency=low
402
403   * Cope with dpkg's new way of expressing architectures (Closes: #313555)
404   * Re-exec with fakeroot if needed (Closes: #310132)
405
406  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Sun, 10 Jul 2005 18:50:40 +0200
407
408 java-package (0.24) unstable; urgency=low
409
410   * Added plugin alternatives support for i386 IBM JREs and JDKs
411   * Corrected pathing for plugin alternatives to reflect difference in
412     layout between JREs and JDKs for Sun and Blackdown (Closes: #305219,
413     #301806)
414
415  -- Barry Hawkins <barry@bytemason.org>  Wed, 21 Apr 2005 01:02:03 -0400
416
417 java-package (0.23.1) experimental; urgency=low
418
419   * Added architecture-specific pathing for plugin alternatives for
420     Blackdown 1.3 and 1.4 JREs and JDKs
421
422  -- Barry Hawkins <barry@bytemason.org>  Wed, 06 Apr 2005 00:03:40 -0500
423
424 java-package (0.23) unstable; urgency=low
425
426   * Further expanded 1.3.1 Blackdown JRE/JDK support for i386
427   * Added architecture-specific pathing for plugin alternatives for
428     Sun 1.4 and 1.5 JREs and JDKs (Closes: #301806)
429   * Added recommends for system elements required by applets and
430     graphical user interface elements (Closes: #300817)
431   * Jeroen van Wolffelaar:
432     + Fixed packages description to not have too long lines, and make the 3
433       items an enumeration
434
435  -- Barry Hawkins <barry@bytemason.org>  Fri, 01 Apr 2005 00:36:40 -0500
436
437 java-package (0.22.1) experimental; urgency=low
438
439   * Corrected IBM and Blackdown JRE/JDK file size specifications
440   * Added support for additional 1.3.1 Blackdown JREs and JDKs for i386,
441     powerpc (Closes: #301092)
442   * Added installation of javaws alternative for Sun 1.5 JREs and JDKs
443     (Closes: #300303)
444
445  -- Barry Hawkins <barry@bytemason.org>  Thu, 24 Mar 2005 13:20:18 -0500
446
447 java-package (0.22) unstable; urgency=low
448
449   * Corrected IBM JRE/JDK scripts to accurately reflect the supported
450     IBM JDKs and JREs in the generated SUPPORTED file
451
452  -- Barry Hawkins <barry@alltc.com>  Fri, 18 Mar 2005 10:21:53 -0500
453
454 java-package (0.21) unstable; urgency=low
455
456   * Enable support for IBM JDKs and JREs for x86, amd64, powerpc,
457     powerpc64, and s390 architectures, based upon a patch by Rico
458     Schiekel (Closes: #264137)
459   * Enable suppport for Blackdown 1.3.1 JDK and JRE for PowerPC
460     architecture. (Closes: #296205)
461   * Update documentation and to reflect current supported JDKs and JREs
462
463  -- Barry Hawkins <barry@alltc.com>  Mon, 14 Mar 2005 03:18:39 -0500
464
465 java-package (0.20) unstable; urgency=low
466
467   * Make the postinst & rm for generated packages #!/bin/bash, as we use
468     bash-specific features (Closes: #292179)
469   * Drop the df output parsing, use '/usr/bin/stat' instead (Closes: #293487,
470     #289006, #293350)
471   * Drop the now obsolete peer stuff from the source package
472   * Change priorities, 313 for 1.3, 314 for 1.4, etc (Closes: #292451)
473   * Don't dh_strip, fiddling with upstream's binaries apparantly breaks stuff
474     (Closes: #291238)
475
476  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Tue, 08 Feb 2005 15:04:51 +0100
477
478 java-package (0.19) unstable; urgency=low
479
480   The "Joshua Kwan <joshk@debian.org> rocks!" release.
481
482   Joshua Kwan:
483   * Unclutter Debian build system and rework package slightly so that
484     *debian packages are not needed anymore. The necessary files will be
485     included in the generated packages. (Closes: #291145, #289245, #284779)
486   * Add support for Blackdown 1.4.2+01 build. (Closes: #285405)
487   * Fix support for Sun 1.5.0 amd64 builds due to typo. (Closes: #290879)
488   * Mozilla browser plugin name changed in 1.4.2 versions. Detect and correct.
489     (Closes: #273730)
490   * Use --block-size=1M instead of -BM. (Closes: #289005, #291161)
491   * Disable support for Sun JDK 1.3 due to its dependencies on libraries
492     that are simply not available anymore. (Closes: #272972)
493   * Fix up short description a little bit.
494   * Bump Standards-Version to 3.6.1 (no changes)
495   * Be a bit more conservative with the real-root test.
496   * Remove last j2se-package references.
497   * Change Suggests on fakeroot to a Depends because it is worthless both
498     as real root and as a normal user without fakeroot.
499
500   Jeroen van Wolffelaar:
501   * Use DEBFULLNAME, DEBNAME and DEBEMAIL if available, and don't ask for
502     those values in that case. (Closes: #279653)
503   * Updated documentation regarding dropped Sun 1.3 support
504   * Work around multiline df output caused by long device names
505     (Closes: #289006)
506   * Add Replaces: for the generated packages on their *debian counterparts
507
508  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Tue, 25 Jan 2005 00:05:06 +0100
509
510 java-package (0.18) unstable; urgency=low
511
512   * Added myself to Uploaders
513   * Fix security hole (inscure temp file creation) plus lots of needless I/O
514     in free disk checking function
515   * Added support for Sun's JDK/JRE 1.5 patch levels, based on a patch by
516     Peter Marschall <peter@adpm.de> (Closes: #286718, #287857)
517   * Bail out if running as real root (works around the evil parts of Sun's
518     install script that unconditionally writes to /etc, see #266273, #280707)
519   * Fix typo in j2re.sh that apparantly with some versions of
520     bash/dpkg/whatever cause package build failure (Closes: #281780, #282902)
521   * Reduce minimum expected size a bit Sun's 1.5.0 amd64 package, it was set
522     too high (Closes: #284033)
523   * Substitute package version number at build time in the make-jpkg
524     executable (Closes: #282221)
525   * Added a README.Debian explaining the existance of make-jpkg and what
526     binary packages are supported and where to get them. Thanks Thijs
527     Kinkhorst for the draft (Closes: #283362)
528   * Added automatically-generated file SUPPORTED that lists all binary
529     filenames that are supported, thanks Alex Owen <owen@cus.org.uk> for the
530     idea (Closes: #275296)
531
532  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Mon,  3 Jan 2005 18:47:47 +0100
533
534 java-package (0.17) unstable; urgency=low
535
536   * added a patch for detecting the architecture (Closes: #274844,
537     #270949, #271846). This patch should also close this one (Closes:
538     #280685).
539
540  -- Arnaud Vandyck <avdyk@debian.org>  Fri, 12 Nov 2004 17:28:38 +0100
541
542 java-package (0.16) unstable; urgency=low
543
544   * added myself as an uploader.
545   * Carlos already closed the support for 1.5 request but it seems he did
546     not upload the package (Closes: #277088).
547
548  -- Arnaud Vandyck <avdyk@debian.org>  Wed, 10 Nov 2004 16:38:44 +0100
549
550 java-package (0.15) unstable; urgency=low
551
552   * lib/sun-j2re.sh: Added support for JRE 1.5.0 (aka "Java 5.0").
553   * lib/sun-j2sdk.sh: Added support for Java SDK 1.5.0.
554
555  -- Carlos Laviola <claviola@debian.org>  Mon, 11 Oct 2004 21:08:59 -0300
556
557 java-package (0.14) unstable; urgency=low
558
559   * debian/control: Commented out the lines that generate the Debian-specific
560     packages, thus making alternatives available.
561     - Also made all of the generated packages depend on their Debian-specific
562     counterparts by default.  (Closes: #266671)
563
564  -- Carlos Laviola <claviola@debian.org>  Mon, 13 Sep 2004 03:38:31 -0300
565
566 java-package (0.13) unstable; urgency=low
567
568   * References to j2se-package are gone.  (Closes: #267642)
569   * Added support for Blackdown Java 1.4.2 RC1 JRE/SDK.  (Closes: #267643)
570
571  -- Carlos Laviola <claviola@debian.org>  Mon, 13 Sep 2004 03:17:54 -0300
572
573 java-package (0.12) unstable; urgency=low
574
575   * remove to contrib because this package depend on non-free J2SE.
576
577  -- Takashi Okamoto <tora@debian.org>  Tue,  3 Aug 2004 00:37:13 +0900
578
579 java-package (0.11) unstable; urgency=low
580
581   * change package name java-package and the command build package is
582     make-jpkg.
583
584  -- Takashi Okamoto <tora@debian.org>  Sat, 31 Jul 2004 15:07:36 +0900
585
586 java-package (0.10) unstable; urgency=low
587
588   * change package name mpkg-j2se.
589   * not use *-j2[re|sdk]debian package. Instead of this, add package
590     dependency to generated package. This reduce the installation for
591     such extra package.
592   * SUN's jdk1.5 beta2 support.
593
594  -- Takashi Okamoto <tora@debian.org>  Sun, 18 Jul 2004 13:53:36 +0900
595
596 java-package (0.9) unstable; urgency=low
597
598   * more generic support for j2re1.3.1/j2sdk1.3.1 from SUN.
599
600   * add alternative for jarsigner (in j2sdk1.4 and j2sdk1.5 from SUN).
601
602  -- Hubert Schmid <ude2@z42.de>  Sun, 23 May 2004 23:35:14 +0200
603
604 java-package (0.8) unstable; urgency=low
605
606   * java plugin: support for mozilla-firefox.
607
608  -- Hubert Schmid <ude2@z42.de>  Tue,  4 May 2004 22:39:39 +0200
609
610 java-package (0.7) unstable; urgency=low
611
612   * Optionally create .changes file.
613
614   * Add command line options: --help, --version, --full-name,
615     --email, --changes.
616
617   * Add environment variables: J2SE_PACKAGE_FULL_NAME,
618     J2SE_PACKAGE_EMAIL.
619
620  -- Hubert Schmid <ude2@z42.de>  Sat, 27 Mar 2004 23:01:08 +0100
621
622 java-package (0.6) unstable; urgency=low
623
624   * More generic support for Java2 1.4.2 from SUN.
625
626  -- Hubert Schmid <ude2@z42.de>  Thu, 11 Mar 2004 20:39:51 +0100
627
628 java-package (0.5) unstable; urgency=low
629
630   * NEW: build Blackdown J2RE 1.4.1 (gcc-2.95) and J2SDK 1.4.1 (gcc-2.95).
631
632   * NEW: support for SUN J2RE 1.5.0 beta, SUN J2SDK 1.5.0 beta.
633
634  -- Hubert Schmid <ude2@z42.de>  Sat,  7 Feb 2004 21:57:09 +0100
635
636 java-package (0.4) unstable; urgency=low
637
638   * Added support for: SUN J2RE 1.4.2_03, SUN J2SDK 1.4.2_03
639
640  -- Hubert Schmid <ude2@z42.de>  Thu, 15 Jan 2004 22:27:52 +0100
641
642 java-package (0.3) unstable; urgency=low
643
644   * Added support for: Blackdown J2RE 1.3, 1.4, J2SDK 1.3, 1.4
645
646   * Removed usage of "du --apparent-size". This should fix a problem
647     with old fileutils.
648
649  -- Hubert Schmid <ude2@z42.de>  Sun,  9 Nov 2003 21:13:38 +0100
650
651 java-package (0.2) unstable; urgency=low
652
653   * Added support for: Sun J2RE 1.3, Sun J2SDK 1.3, Sun J2SDK 1.4
654
655   * Moved peer packages into this source package.
656
657  -- Hubert Schmid <ude2@z42.de>  Thu, 30 Oct 2003 00:10:01 +0100
658
659 java-package (0.1) unstable; urgency=low
660
661   * Initial Release.
662
663  -- Hubert Schmid <j2se-package@z42.de>  Sun, 26 Oct 2003 20:06:57 +0100