9124b6685b1571ed67c3c18e3206bc41cb9847c8
[sven/java-package.git] / debian / changelog
1 java-package (0.62) UNRELEASED; urgency=medium
2
3   * Team upload.
4   * Bump Standards-Version to 3.9.8 (no changes)
5   * Add --distribution option to override hard-coded value of unstable.
6     Thank you to Martin Gerhard Loschwitz for the patch. (Closes: #819537)
7   * Add --jce-policy <policy.zip> option to build with JCE policy file.
8     Thank you to Alex Brown for the patch. (Closes: #833301)
9   * Freshen the manpage example for JDK 8.
10   * Add --jce-policy option to manpage.
11
12  -- tony mancill <tmancill@debian.org>  Sat, 10 Sep 2016 10:01:07 -0700
13
14 java-package (0.61) unstable; urgency=medium
15
16   * Team upload.
17   * Bump Standards-Version to 3.9.7 (no changes)
18   * Use package name plus architecture as directory in /usr/lib/jvm
19   * Add support for server JRE (Closes: #776389)
20   * Update Vcs-Browser and Vcs-Git to use HTTPS
21
22  -- Benjamin Drung <benjamin.drung@profitbricks.com>  Fri, 18 Mar 2016 17:50:51 +0100
23
24 java-package (0.60) unstable; urgency=medium
25
26   * Team upload.
27
28   [ Emmanuel Bourg ]
29   * Added jcontrol to the command line alternatives (Closes: #799370)
30   * Fixed the detection of the latest Java 8 documentation archives.
31   * Fixed the dh_shlibdeps error when generating a documentation package
32     (Closes: #753071)
33   * Changed the architecture of the documentation packages from any to all.
34   * Changed the section of the documentation packages to non-free/doc
35   * Disabled dh_strip_nondeterminism when generating the Java packages
36     to speed up the build
37
38   [ tony mancill ]
39   * Update the package long description.
40   * Add build-essential as a dependency and drop the (now redundant)
41     recommends on gcc. (Closes: #787809)
42   * Use du --apparent-size when checking the size of the unpacked
43     distribution. (Closes: #794401)
44
45  -- Emmanuel Bourg <ebourg@apache.org>  Mon, 30 Nov 2015 14:23:05 +0100
46
47 java-package (0.59) unstable; urgency=medium
48
49   * Team upload.
50   * Upload to unstable.
51   * Add following dependencies to address build failures for dpkg-shlibdeps
52     errors during make-jpkg of JDK/JRE:
53     libgl1-mesa-glx libfontconfig1 libxslt1.1 libxtst6 libxxf86vm1 libgtk2.0-0
54     (Closes: #782132)
55
56  -- tony mancill <tmancill@debian.org>  Sat, 16 May 2015 13:46:27 -0700
57
58 java-package (0.58) experimental; urgency=medium
59
60   [ Francesc Zacarias ]
61   * New --with-system-certs option to use the system keystore (Closes: #776395)
62
63   [ Emmanuel Bourg ]
64   * Removed the generated package mistakenly included in the source package
65     (Closes: #779727)
66
67  -- Emmanuel Bourg <ebourg@apache.org>  Thu, 05 Mar 2015 00:09:05 +0100
68
69 java-package (0.57) experimental; urgency=medium
70
71   * Team upload.
72   * Include Java 8 in the help message of make-jpkg (Closes: #775977)
73   * Provide all runtimes since Java 5, thanks to Laurens Blankers
74     (Closes: #775987)
75   * Added more command line tool alternatives: jmc and jvisualvm
76     (Closes: #676877)
77   * Standards-Version updated to 3.9.6 (no changes)
78
79  -- Emmanuel Bourg <ebourg@apache.org>  Sun, 25 Jan 2015 00:02:59 +0100
80
81 java-package (0.56) unstable; urgency=medium
82
83   * Team upload.
84   * Do not Build-Depends libavcodec53 and libavformat53 for Java 8.
85     Thanks to Chris Jester-Young for the patch. (Closes: #751974)
86   * Set the urcency of the guest package to medium.
87
88  -- Benjamin Drung <benjamin.drung@profitbricks.com>  Fri, 20 Jun 2014 11:10:45 +0200
89
90 java-package (0.55) unstable; urgency=medium
91
92   [ tony mancill ]
93   * Team upload.
94   * Add lsb-release to Depends (used in make-jpkg).
95   * Apply patch to honor --revision argument.
96     Thanks to Alberto Caso Palomino. (Closes: #743919)
97
98   [ Emmanuel Bourg ]
99   * Bumped the Standards-Version of the generated package to 3.9.5
100   * Use debhelper level 9 in the generated package
101
102   [ Benjamin Drung ]
103   * Add a debian/rules file to the generated source package.
104   * Use dpkg-buildpackage to build the guest package.
105   * Add ${misc:Depends} to the guest dependency.
106   * Add --source option to build a source package instead of a binary deb
107     package. (Closes: #745762)
108   * Replace lsb_release call by dpkg-vendor call.
109   * Convert copyright file content to UTF-8 for guest debian/copyright.
110   * Remove trailing spaces from copyright file.
111   * Create build depends for JDK guest package.
112
113  -- Benjamin Drung <benjamin.drung@profitbricks.com>  Tue, 17 Jun 2014 20:41:39 +0200
114
115 java-package (0.54) unstable; urgency=medium
116
117   * Team upload.
118   * Added support for ARM VFP/hard-float JDK releases.
119     Thanks to Christopher Huhn <C.Huhn@gsi.de> (Closes: #724455)
120   * Added more command line tool alternatives: jcmd, jdeps, jhat, jrunscript,
121     schemagen, wsgen, wsimport and xjc
122   * Standards-Version updated to 3.9.5 (no changes)
123   * Removed the suggested dependency on openjdk-6-jre
124   * Switch to debhelper level 9
125
126  -- Emmanuel Bourg <ebourg@apache.org>  Mon, 24 Mar 2014 18:44:58 +0100
127
128 java-package (0.53) unstable; urgency=low
129
130   * Team upload.
131   * Added support for early access releases (Closes: #721136)
132   * Added support for GA and FCS releases
133   * Excluded the fxavcodecplugin libraries used by JavaFX from the dependency
134     calculation performed by dh_shlibdeps to avoid errors (Closes: #687075)
135   * Updated the package description and debian/README.Debian:
136     - no longer recommend openjdk-6
137     - mention the compatibility with Java 8
138   * Removed 'Replaces: ${j2se_package}debian' from the generated control file
139   * Adjusted the disk space required to unpack the Java 8 documentation
140   * Updated the manpages for Java 8
141   * Updated debhelper level to 7
142   * debian/rules: Use dh_prep instead of dh_clean -k
143   * Removed the recommended dependency on libstdc++5 from the generated
144     control file (used by the now unsupported IBM JDK 5)
145   * Removed the recommended dependency on libgtk1.2 from the generated
146     control file (removed from Squeeze)
147   * Removed the recommended dependency on libx11-6 and libasound2 from
148     the generated control file (these dependencies are already injected
149     by dh_shlibdeps)
150   * Removed the references to "Java 2" from the description of the generated
151     JRE package
152   * Changed the short description of the generate packages to match
153     the official name
154
155  -- Emmanuel Bourg <ebourg@apache.org>  Tue, 10 Sep 2013 14:42:43 +0200
156
157 java-package (0.52) unstable; urgency=low
158
159   [ Sylvestre Ledru ]
160   * Team upload
161   * Upload to unstable
162   * Ack the NMU of David Prévot (thanks!)
163   * Standards-Version updated to version 3.9.4
164   * Remove obsolete variable from the changelog
165   * Add support of ARM upstream binary by James Page and Matthias Vill.
166     Thanks guys! (Closes: #687375)
167   * Change the installation path from
168     /usr/lib/jvm/jdk-6.38-oracle-x64 or /usr/lib/jvm/jdk-7.10-oracle-x64
169     to
170     /usr/lib/jvm/jdk-6-oracle-x64 and /usr/lib/jvm/jdk-7-oracle-x64
171     Thanks to Constantin Makshin for the patch (Closes: #696227)
172
173   [ Cédric Pineau ]
174   * Fix lintian errors and warnings
175
176   [ Gabriele Giacone ]
177   * Add {mozilla,firefox}-javaplugin.so for update-java-alternatives.
178   * Fix plugin directories. Closes: #686216
179
180   [ Emmanuel Bourg ]
181   * Switched to the 3.0 (native) package format
182   * debian/control: Use canonical URLs for the Vcs-* fields
183   * debian/copyright: Switched to the Machine-readable format 1.0
184   * Updated the manpages to reflect the latest naming changes
185   * Removed the unused provided dependencies (j2sdk<version>, j2re<version>)
186   * Provide the java<version-1>-runtime and java<version-2>-runtime dependencies
187     (Closes: #691063)
188   * Provide the java<version>-sdk dependencies to match the openjdk package
189   * Use the upstream versioning scheme (i.e 7u13 instead of 7.13)
190     to match the convention used by the new openjdk packages
191   * Renamed the script files (j2sdk->jdk, j2re->jre, j2se->javase)
192
193  -- Sylvestre Ledru <sylvestre@debian.org>  Wed, 05 Jun 2013 13:43:55 +0200
194
195 java-package (0.51~exp1) experimental; urgency=low
196
197   * Add firefox-javaplugin.so alternative Closes: #673670 and LP: #1024368
198   * Add java5 and 6-{runtime|sdk|...} to the provides line in generated packages Closes: #684993 and LP: #995655
199   * Drop installation debconf note Closes: #685082
200   * Correct handling of amd64 in oracle-jdk6.1->4 and improve error message when used with unknown archives
201   * Add support for earlier oracle-jdk6 version
202
203   [Emmanuel Bourg]
204   * Improved detection of the JRE/JDK version (supports 2 digits Java 7 updates) Closes: #597294
205   * Brand and naming cleanup
206   * Documentation directory changed to be /usr/share/doc/oracle-javaV-doc (for oracle)
207
208   [Joerg Schirottke]
209   * Add mozilla-javaplugin.so alternative
210
211  -- Cédric Pineau <cedric.pineau@gmail.com>  Sat, 18 Aug 2012 11:00:34 +0200
212
213 java-package (0.50+nmu2) unstable; urgency=high
214
215   * Non-maintainer upload.
216   * Allow two digits in Java 7 updates. Closes: #597294, #698108
217
218  -- David Prévot <taffit@debian.org>  Tue, 15 Jan 2013 15:06:26 -0400
219
220 java-package (0.50+nmu1) unstable; urgency=low
221
222   * Non-maintainer upload.
223   * Drop installation debconf note. Closes: #685082
224
225  -- David Prévot <taffit@debian.org>  Thu, 06 Sep 2012 18:38:03 -0400
226
227 java-package (0.50) unstable; urgency=low
228
229   * Java-package reset for reintroduction in debian (removal of all
230     previously supported jvm, global refactoring).
231   * Add support for Oracle Java 6 (update >= 10)
232   * Add support for Oracle Java 7
233   * Add support for .jinfo file (update-java-alternatives tool)
234   * Use jdk included jre binaries (jdk/jre/bin/*)
235   * Print usage information on install
236
237   [ Sylvestre Ledru ]
238   * Long description removed
239   * debian-rules-missing-recommended-target removed
240   * maintainer-script-lacks-debhelper-token removed
241   * Declare the debian/compat to 7 to avoid warnings
242
243   [ Michael Koch ]
244   * Remove Java plugins for all browsers (Closes: #367887).
245   * Add support for Sun Java 6 Update XX (Closes: #514364).
246
247  -- Cédric Pineau <cedric.pineau@gmail.com>  Thu, 22 Dec 2011 11:42:13 +0100
248
249 java-package (0.42) unstable; urgency=low
250
251   * Provide java*-runtime-headless and java*-sdk names for generated
252     packages.
253   * Recommend dpkg-dev and gcc. Closes: #281766, #405814.
254
255  -- Matthias Klose <doko@debian.org>  Sat, 02 Aug 2008 12:10:52 +0200
256
257 java-package (0.41) unstable; urgency=low
258
259   * Added support for new SUN JDK/JRE for amd64 downloads. Thanks to
260     Artyom Gavrichenkov for the initial patch.
261
262  -- Michael Koch <konqueror@gmx.de>  Fri, 21 Mar 2008 17:20:35 +0100
263
264 java-package (0.40) unstable; urgency=low
265
266   * Add support for ibm-java2-sdk-5.0-6.0-linux-$arch.tgz. Closes: #462399
267     Thanks to Evgeni Dobrev for the patch.
268   * Fixed spelling error in long description: debian -> Debian.
269
270  -- Michael Koch <konqueror@gmx.de>  Thu, 24 Jan 2008 22:48:46 +0100
271
272 java-package (0.39) unstable; urgency=low
273
274   * Added support for IBM JDK 6.0 final release.
275   * Updated Standard-Version to 3.7.3.
276   * Updated debhelper level to 5.
277
278  -- Michael Koch <konqueror@gmx.de>  Tue, 18 Dec 2007 07:38:34 +0100
279
280 java-package (0.38) unstable; urgency=low
281
282   * Mention SUN JDK 6 in REAME.Debian. Closes: #448258.
283   * Fixed typo when creating version number for SUN JDK 6. Closes: #451935.
284   * Fix handling of symlinks for ControlPanel, HtmlConverter and java-rmi.cgi
285     from SUN JDK 6. Closes: #448351.
286
287  -- Michael Koch <konqueror@gmx.de>  Fri, 30 Nov 2007 00:03:50 +0100
288
289 java-package (0.37) unstable; urgency=low
290
291   * Added libstdc++5 to Recommends of generated package. Closes: #446334.
292
293  -- Michael Koch <konqueror@gmx.de>  Thu, 25 Oct 2007 22:45:42 +0200
294
295 java-package (0.36) unstable; urgency=low
296
297   * Fixed package description to include more supported JDKs.
298     Closes: #447615, #447617.
299
300  -- Michael Koch <konqueror@gmx.de>  Wed, 24 Oct 2007 09:56:52 +0200
301
302 java-package (0.35) unstable; urgency=low
303
304   * Use 'date -R' instead of the deprecated '822-date'. Closes: #441229.
305   * Fix generation of .changes file. Closes: #332643.
306     Thanks to Christoph Goehre for the patch.
307   * Add possibility to add a configured revision to the version.
308     Closes: #442246. Thanks to Christoph Goehre again for the patch.
309
310  -- Michael Koch <konqueror@gmx.de>  Fri, 14 Sep 2007 17:28:13 +0200
311
312 java-package (0.34) unstable; urgency=low
313
314   * Fixed SUN JDK on amd64. Closes: #439221.
315
316  -- Michael Koch <konqueror@gmx.de>  Fri, 24 Aug 2007 00:41:54 +0200
317
318 java-package (0.33) unstable; urgency=low
319
320   * Fixed postinst scripts for SUN JDK 1.4, 5 and 6. Closes: #435632.
321
322  -- Michael Koch <konqueror@gmx.de>  Thu, 02 Aug 2007 18:43:40 +0200
323
324 java-package (0.32) unstable; urgency=low
325
326   * Added support for iceweasel. Closes: #433445.
327   * Fix dangling links for SUN Java 5. Closes: #305053.
328   * Depend on libx11-6 and libasound2. Closes: #289004.
329   * Fix building on ia64. Closes: #355465.
330
331  -- Michael Koch <konqueror@gmx.de>  Thu, 19 Jul 2007 22:51:31 +0200
332
333 java-package (0.31) unstable; urgency=low
334
335   * Reapplied changes from 0.28 to 0.29. Closes: 322843.
336
337  -- Michael Koch <konqueror@gmx.de>  Tue, 10 Jul 2007 08:16:14 +0200
338
339 java-package (0.30) unstable; urgency=low
340
341   * Added support for SUN JDK 6u2 (and following updates).
342   * Added support for ibm-java2-jre-5.0-5.0-linux-ppc.tgz.
343     Thanks to B. Zhang.
344
345  -- Michael Koch <konqueror@gmx.de>  Sun, 08 Jul 2007 09:33:29 +0200
346
347 java-package (0.29) unstable; urgency=low
348
349   * Added support for SUN Java 6 and IBM Java 6.
350     Closes: #322843, #402642, #418592, #425508, #430026.
351   * Added myself to Uploaders.
352
353  -- Michael Koch <konqueror@gmx.de>  Tue, 26 Jun 2007 17:40:04 -0100
354
355 java-package (0.28) unstable; urgency=low
356
357   * Modified to reflect migration to Subversion
358   * Bumped standards to version 3.7.2, no changes
359   * Corrected test for AMD64 architecture during plug-in detection
360   * Corrected detected version for IBM Java 5 JDK on AMD64 (Closes: #345775)
361   * Repaired alternatives handling for IBM Java 5 JREs and JDKs
362     (Closes: #338569)
363   * Corrected pathing for alternatives installation for Mozilla and
364     Firefox plugins (Closes: #341751)
365   * Relaxed architectural restrictions on plugin alternative
366     installation for IBM Java 5 JREs and JDKs (Closes: #343837)
367   * Added plugin installation for the new packaging of Firefox 1.5 and
368     later (Closes: #341749)
369   * Modified warning suppression for dh_shlibdeps to accommodate
370     changes in dpkg-dev (Closes: #354427)
371   * Added quotes to variable tests for maintainer name and email
372     (Closes: #342623)
373   * Refactored architecture evaluation to eliminate repetition and
374     evaluate DEB_BUILD_GNU_TYPE correctly for i486-linux-gnu
375   * Removed dependency on 'coreutils | stat' from control file, as
376     the dependency is satisfied within essential (Closes: #370002)
377
378  -- Barry Hawkins <barry@alltc.com>  Mon, 26 Jun 2006 11:19:08 -0400
379
380 java-package (0.27) unstable; urgency=low
381
382   * Added support for IBM Java2 5.0 JREs and JDKs (Closes: #337129)
383   * Corrected missing alternatives links for all JREs and JDKs
384     (Closes: #317492)
385   * Added conditional wrapping around dh_compress to account for
386     JRE/JDKs that do not ship manpages (Closes: 301738)
387   * Removed java-common from Provides: for JRE and JDK packages.
388
389  -- Barry Hawkins <barry@bytemason.org>  Tue, 08 Nov 2005 12:16:24 -0500
390
391 java-package (0.26) unstable; urgency=low
392
393   * Update standards version to 3.6.2
394   * Resolve issues with powerpc-linux support detection (Closes: #317671)
395   * Added support for Blackdown 1.4.2+02 release (Closes: #316831)
396   * Added support for packaging Sun JDK documentation (Closes: #272971)
397   * Modified make-jpkg behavior to default the generated packages'
398     name and email address for the maintainer to Debian Java Maintainers
399     (Closes: #325554)
400
401  -- Barry Hawkins <barry@bytemason.org>  Thu, 18 Aug 2005 00:43:17 -0400
402
403 java-package (0.25) unstable; urgency=low
404
405   * Cope with dpkg's new way of expressing architectures (Closes: #313555)
406   * Re-exec with fakeroot if needed (Closes: #310132)
407
408  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Sun, 10 Jul 2005 18:50:40 +0200
409
410 java-package (0.24) unstable; urgency=low
411
412   * Added plugin alternatives support for i386 IBM JREs and JDKs
413   * Corrected pathing for plugin alternatives to reflect difference in
414     layout between JREs and JDKs for Sun and Blackdown (Closes: #305219,
415     #301806)
416
417  -- Barry Hawkins <barry@bytemason.org>  Wed, 21 Apr 2005 01:02:03 -0400
418
419 java-package (0.23.1) experimental; urgency=low
420
421   * Added architecture-specific pathing for plugin alternatives for
422     Blackdown 1.3 and 1.4 JREs and JDKs
423
424  -- Barry Hawkins <barry@bytemason.org>  Wed, 06 Apr 2005 00:03:40 -0500
425
426 java-package (0.23) unstable; urgency=low
427
428   * Further expanded 1.3.1 Blackdown JRE/JDK support for i386
429   * Added architecture-specific pathing for plugin alternatives for
430     Sun 1.4 and 1.5 JREs and JDKs (Closes: #301806)
431   * Added recommends for system elements required by applets and
432     graphical user interface elements (Closes: #300817)
433   * Jeroen van Wolffelaar:
434     + Fixed packages description to not have too long lines, and make the 3
435       items an enumeration
436
437  -- Barry Hawkins <barry@bytemason.org>  Fri, 01 Apr 2005 00:36:40 -0500
438
439 java-package (0.22.1) experimental; urgency=low
440
441   * Corrected IBM and Blackdown JRE/JDK file size specifications
442   * Added support for additional 1.3.1 Blackdown JREs and JDKs for i386,
443     powerpc (Closes: #301092)
444   * Added installation of javaws alternative for Sun 1.5 JREs and JDKs
445     (Closes: #300303)
446
447  -- Barry Hawkins <barry@bytemason.org>  Thu, 24 Mar 2005 13:20:18 -0500
448
449 java-package (0.22) unstable; urgency=low
450
451   * Corrected IBM JRE/JDK scripts to accurately reflect the supported
452     IBM JDKs and JREs in the generated SUPPORTED file
453
454  -- Barry Hawkins <barry@alltc.com>  Fri, 18 Mar 2005 10:21:53 -0500
455
456 java-package (0.21) unstable; urgency=low
457
458   * Enable support for IBM JDKs and JREs for x86, amd64, powerpc,
459     powerpc64, and s390 architectures, based upon a patch by Rico
460     Schiekel (Closes: #264137)
461   * Enable suppport for Blackdown 1.3.1 JDK and JRE for PowerPC
462     architecture. (Closes: #296205)
463   * Update documentation and to reflect current supported JDKs and JREs
464
465  -- Barry Hawkins <barry@alltc.com>  Mon, 14 Mar 2005 03:18:39 -0500
466
467 java-package (0.20) unstable; urgency=low
468
469   * Make the postinst & rm for generated packages #!/bin/bash, as we use
470     bash-specific features (Closes: #292179)
471   * Drop the df output parsing, use '/usr/bin/stat' instead (Closes: #293487,
472     #289006, #293350)
473   * Drop the now obsolete peer stuff from the source package
474   * Change priorities, 313 for 1.3, 314 for 1.4, etc (Closes: #292451)
475   * Don't dh_strip, fiddling with upstream's binaries apparantly breaks stuff
476     (Closes: #291238)
477
478  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Tue, 08 Feb 2005 15:04:51 +0100
479
480 java-package (0.19) unstable; urgency=low
481
482   The "Joshua Kwan <joshk@debian.org> rocks!" release.
483
484   Joshua Kwan:
485   * Unclutter Debian build system and rework package slightly so that
486     *debian packages are not needed anymore. The necessary files will be
487     included in the generated packages. (Closes: #291145, #289245, #284779)
488   * Add support for Blackdown 1.4.2+01 build. (Closes: #285405)
489   * Fix support for Sun 1.5.0 amd64 builds due to typo. (Closes: #290879)
490   * Mozilla browser plugin name changed in 1.4.2 versions. Detect and correct.
491     (Closes: #273730)
492   * Use --block-size=1M instead of -BM. (Closes: #289005, #291161)
493   * Disable support for Sun JDK 1.3 due to its dependencies on libraries
494     that are simply not available anymore. (Closes: #272972)
495   * Fix up short description a little bit.
496   * Bump Standards-Version to 3.6.1 (no changes)
497   * Be a bit more conservative with the real-root test.
498   * Remove last j2se-package references.
499   * Change Suggests on fakeroot to a Depends because it is worthless both
500     as real root and as a normal user without fakeroot.
501
502   Jeroen van Wolffelaar:
503   * Use DEBFULLNAME, DEBNAME and DEBEMAIL if available, and don't ask for
504     those values in that case. (Closes: #279653)
505   * Updated documentation regarding dropped Sun 1.3 support
506   * Work around multiline df output caused by long device names
507     (Closes: #289006)
508   * Add Replaces: for the generated packages on their *debian counterparts
509
510  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Tue, 25 Jan 2005 00:05:06 +0100
511
512 java-package (0.18) unstable; urgency=low
513
514   * Added myself to Uploaders
515   * Fix security hole (inscure temp file creation) plus lots of needless I/O
516     in free disk checking function
517   * Added support for Sun's JDK/JRE 1.5 patch levels, based on a patch by
518     Peter Marschall <peter@adpm.de> (Closes: #286718, #287857)
519   * Bail out if running as real root (works around the evil parts of Sun's
520     install script that unconditionally writes to /etc, see #266273, #280707)
521   * Fix typo in j2re.sh that apparantly with some versions of
522     bash/dpkg/whatever cause package build failure (Closes: #281780, #282902)
523   * Reduce minimum expected size a bit Sun's 1.5.0 amd64 package, it was set
524     too high (Closes: #284033)
525   * Substitute package version number at build time in the make-jpkg
526     executable (Closes: #282221)
527   * Added a README.Debian explaining the existance of make-jpkg and what
528     binary packages are supported and where to get them. Thanks Thijs
529     Kinkhorst for the draft (Closes: #283362)
530   * Added automatically-generated file SUPPORTED that lists all binary
531     filenames that are supported, thanks Alex Owen <owen@cus.org.uk> for the
532     idea (Closes: #275296)
533
534  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Mon,  3 Jan 2005 18:47:47 +0100
535
536 java-package (0.17) unstable; urgency=low
537
538   * added a patch for detecting the architecture (Closes: #274844,
539     #270949, #271846). This patch should also close this one (Closes:
540     #280685).
541
542  -- Arnaud Vandyck <avdyk@debian.org>  Fri, 12 Nov 2004 17:28:38 +0100
543
544 java-package (0.16) unstable; urgency=low
545
546   * added myself as an uploader.
547   * Carlos already closed the support for 1.5 request but it seems he did
548     not upload the package (Closes: #277088).
549
550  -- Arnaud Vandyck <avdyk@debian.org>  Wed, 10 Nov 2004 16:38:44 +0100
551
552 java-package (0.15) unstable; urgency=low
553
554   * lib/sun-j2re.sh: Added support for JRE 1.5.0 (aka "Java 5.0").
555   * lib/sun-j2sdk.sh: Added support for Java SDK 1.5.0.
556
557  -- Carlos Laviola <claviola@debian.org>  Mon, 11 Oct 2004 21:08:59 -0300
558
559 java-package (0.14) unstable; urgency=low
560
561   * debian/control: Commented out the lines that generate the Debian-specific
562     packages, thus making alternatives available.
563     - Also made all of the generated packages depend on their Debian-specific
564     counterparts by default.  (Closes: #266671)
565
566  -- Carlos Laviola <claviola@debian.org>  Mon, 13 Sep 2004 03:38:31 -0300
567
568 java-package (0.13) unstable; urgency=low
569
570   * References to j2se-package are gone.  (Closes: #267642)
571   * Added support for Blackdown Java 1.4.2 RC1 JRE/SDK.  (Closes: #267643)
572
573  -- Carlos Laviola <claviola@debian.org>  Mon, 13 Sep 2004 03:17:54 -0300
574
575 java-package (0.12) unstable; urgency=low
576
577   * remove to contrib because this package depend on non-free J2SE.
578
579  -- Takashi Okamoto <tora@debian.org>  Tue,  3 Aug 2004 00:37:13 +0900
580
581 java-package (0.11) unstable; urgency=low
582
583   * change package name java-package and the command build package is
584     make-jpkg.
585
586  -- Takashi Okamoto <tora@debian.org>  Sat, 31 Jul 2004 15:07:36 +0900
587
588 java-package (0.10) unstable; urgency=low
589
590   * change package name mpkg-j2se.
591   * not use *-j2[re|sdk]debian package. Instead of this, add package
592     dependency to generated package. This reduce the installation for
593     such extra package.
594   * SUN's jdk1.5 beta2 support.
595
596  -- Takashi Okamoto <tora@debian.org>  Sun, 18 Jul 2004 13:53:36 +0900
597
598 java-package (0.9) unstable; urgency=low
599
600   * more generic support for j2re1.3.1/j2sdk1.3.1 from SUN.
601
602   * add alternative for jarsigner (in j2sdk1.4 and j2sdk1.5 from SUN).
603
604  -- Hubert Schmid <ude2@z42.de>  Sun, 23 May 2004 23:35:14 +0200
605
606 java-package (0.8) unstable; urgency=low
607
608   * java plugin: support for mozilla-firefox.
609
610  -- Hubert Schmid <ude2@z42.de>  Tue,  4 May 2004 22:39:39 +0200
611
612 java-package (0.7) unstable; urgency=low
613
614   * Optionally create .changes file.
615
616   * Add command line options: --help, --version, --full-name,
617     --email, --changes.
618
619   * Add environment variables: J2SE_PACKAGE_FULL_NAME,
620     J2SE_PACKAGE_EMAIL.
621
622  -- Hubert Schmid <ude2@z42.de>  Sat, 27 Mar 2004 23:01:08 +0100
623
624 java-package (0.6) unstable; urgency=low
625
626   * More generic support for Java2 1.4.2 from SUN.
627
628  -- Hubert Schmid <ude2@z42.de>  Thu, 11 Mar 2004 20:39:51 +0100
629
630 java-package (0.5) unstable; urgency=low
631
632   * NEW: build Blackdown J2RE 1.4.1 (gcc-2.95) and J2SDK 1.4.1 (gcc-2.95).
633
634   * NEW: support for SUN J2RE 1.5.0 beta, SUN J2SDK 1.5.0 beta.
635
636  -- Hubert Schmid <ude2@z42.de>  Sat,  7 Feb 2004 21:57:09 +0100
637
638 java-package (0.4) unstable; urgency=low
639
640   * Added support for: SUN J2RE 1.4.2_03, SUN J2SDK 1.4.2_03
641
642  -- Hubert Schmid <ude2@z42.de>  Thu, 15 Jan 2004 22:27:52 +0100
643
644 java-package (0.3) unstable; urgency=low
645
646   * Added support for: Blackdown J2RE 1.3, 1.4, J2SDK 1.3, 1.4
647
648   * Removed usage of "du --apparent-size". This should fix a problem
649     with old fileutils.
650
651  -- Hubert Schmid <ude2@z42.de>  Sun,  9 Nov 2003 21:13:38 +0100
652
653 java-package (0.2) unstable; urgency=low
654
655   * Added support for: Sun J2RE 1.3, Sun J2SDK 1.3, Sun J2SDK 1.4
656
657   * Moved peer packages into this source package.
658
659  -- Hubert Schmid <ude2@z42.de>  Thu, 30 Oct 2003 00:10:01 +0100
660
661 java-package (0.1) unstable; urgency=low
662
663   * Initial Release.
664
665  -- Hubert Schmid <j2se-package@z42.de>  Sun, 26 Oct 2003 20:06:57 +0100