Display usage info on install, docs polish
[sven/java-package.git] / debian / changelog
1 java-package (0.50) UNRELEASED; urgency=low
2
3   * Java-package reset for reintroduction in debian (removal of all
4     previously supported jvm, global refactoring).
5   * Add support for Oracle Java 6 (update >= 10)
6   * Add support for Oracle Java 7
7   * Add support for .jinfo file (update-java-alternatives tool)
8   * Use jdk included jre binaries (jdk/jre/bin/*)
9   * Print usage information on install
10
11  -- C├ędric Pineau <cedric.pineau@gmail.com>  Thu, 22 Dec 2011 11:42:13 +0100
12
13 java-package (0.43) UNRELEASED; urgency=low
14
15   * Remove Java plugins for all browsers (Closes: #367887).
16   * Add support for Sun Java 6 Update XX (Closes: #514364).
17
18  -- Michael Koch <konqueror@gmx.de>  Thu, 17 Sep 2009 13:15:55 +0200
19
20 java-package (0.42) unstable; urgency=low
21
22   * Provide java*-runtime-headless and java*-sdk names for generated
23     packages.
24   * Recommend dpkg-dev and gcc. Closes: #281766, #405814.
25
26  -- Matthias Klose <doko@debian.org>  Sat, 02 Aug 2008 12:10:52 +0200
27
28 java-package (0.41) unstable; urgency=low
29
30   * Added support for new SUN JDK/JRE for amd64 downloads. Thanks to
31     Artyom Gavrichenkov for the initial patch.
32
33  -- Michael Koch <konqueror@gmx.de>  Fri, 21 Mar 2008 17:20:35 +0100
34
35 java-package (0.40) unstable; urgency=low
36
37   * Add support for ibm-java2-sdk-5.0-6.0-linux-$arch.tgz. Closes: #462399
38     Thanks to Evgeni Dobrev for the patch.
39   * Fixed spelling error in long description: debian -> Debian.
40
41  -- Michael Koch <konqueror@gmx.de>  Thu, 24 Jan 2008 22:48:46 +0100
42
43 java-package (0.39) unstable; urgency=low
44
45   * Added support for IBM JDK 6.0 final release.
46   * Updated Standard-Version to 3.7.3.
47   * Updated debhelper level to 5.
48
49  -- Michael Koch <konqueror@gmx.de>  Tue, 18 Dec 2007 07:38:34 +0100
50
51 java-package (0.38) unstable; urgency=low
52
53   * Mention SUN JDK 6 in REAME.Debian. Closes: #448258.
54   * Fixed typo when creating version number for SUN JDK 6. Closes: #451935.
55   * Fix handling of symlinks for ControlPanel, HtmlConverter and java-rmi.cgi
56     from SUN JDK 6. Closes: #448351.
57
58  -- Michael Koch <konqueror@gmx.de>  Fri, 30 Nov 2007 00:03:50 +0100
59
60 java-package (0.37) unstable; urgency=low
61
62   * Added libstdc++5 to Recommends of generated package. Closes: #446334.
63
64  -- Michael Koch <konqueror@gmx.de>  Thu, 25 Oct 2007 22:45:42 +0200
65
66 java-package (0.36) unstable; urgency=low
67
68   * Fixed package description to include more supported JDKs.
69     Closes: #447615, #447617.
70
71  -- Michael Koch <konqueror@gmx.de>  Wed, 24 Oct 2007 09:56:52 +0200
72
73 java-package (0.35) unstable; urgency=low
74
75   * Use 'date -R' instead of the deprecated '822-date'. Closes: #441229.
76   * Fix generation of .changes file. Closes: #332643.
77     Thanks to Christoph Goehre for the patch.
78   * Add possibility to add a configured revision to the version.
79     Closes: #442246. Thanks to Christoph Goehre again for the patch.
80
81  -- Michael Koch <konqueror@gmx.de>  Fri, 14 Sep 2007 17:28:13 +0200
82
83 java-package (0.34) unstable; urgency=low
84
85   * Fixed SUN JDK on amd64. Closes: #439221.
86
87  -- Michael Koch <konqueror@gmx.de>  Fri, 24 Aug 2007 00:41:54 +0200
88
89 java-package (0.33) unstable; urgency=low
90
91   * Fixed postinst scripts for SUN JDK 1.4, 5 and 6. Closes: #435632.
92
93  -- Michael Koch <konqueror@gmx.de>  Thu, 02 Aug 2007 18:43:40 +0200
94
95 java-package (0.32) unstable; urgency=low
96
97   * Added support for iceweasel. Closes: #433445.
98   * Fix dangling links for SUN Java 5. Closes: #305053.
99   * Depend on libx11-6 and libasound2. Closes: #289004.
100   * Fix building on ia64. Closes: #355465.
101
102  -- Michael Koch <konqueror@gmx.de>  Thu, 19 Jul 2007 22:51:31 +0200
103
104 java-package (0.31) unstable; urgency=low
105
106   * Reapplied changes from 0.28 to 0.29. Closes: 322843.
107
108  -- Michael Koch <konqueror@gmx.de>  Tue, 10 Jul 2007 08:16:14 +0200
109
110 java-package (0.30) unstable; urgency=low
111
112   * Added support for SUN JDK 6u2 (and following updates).
113   * Added support for ibm-java2-jre-5.0-5.0-linux-ppc.tgz.
114     Thanks to B. Zhang.
115
116  -- Michael Koch <konqueror@gmx.de>  Sun, 08 Jul 2007 09:33:29 +0200
117
118 java-package (0.29) unstable; urgency=low
119
120   * Added support for SUN Java 6 and IBM Java 6.
121     Closes: #322843, #402642, #418592, #425508, #430026.
122   * Added myself to Uploaders.
123
124  -- Michael Koch <konqueror@gmx.de>  Tue, 26 Jun 2007 17:40:04 -0100
125
126 java-package (0.28) unstable; urgency=low
127
128   * Modified to reflect migration to Subversion
129   * Bumped standards to version 3.7.2, no changes
130   * Corrected test for AMD64 architecture during plug-in detection
131   * Corrected detected version for IBM Java 5 JDK on AMD64 (Closes: #345775)
132   * Repaired alternatives handling for IBM Java 5 JREs and JDKs
133     (Closes: #338569)
134   * Corrected pathing for alternatives installation for Mozilla and
135     Firefox plugins (Closes: #341751)
136   * Relaxed architectural restrictions on plugin alternative 
137     installation for IBM Java 5 JREs and JDKs (Closes: #343837)
138   * Added plugin installation for the new packaging of Firefox 1.5 and
139     later (Closes: #341749)
140   * Modified warning suppression for dh_shlibdeps to accommodate 
141     changes in dpkg-dev (Closes: #354427)
142   * Added quotes to variable tests for maintainer name and email 
143     (Closes: #342623)
144   * Refactored architecture evaluation to eliminate repetition and
145     evaluate DEB_BUILD_GNU_TYPE correctly for i486-linux-gnu
146   * Removed dependency on 'coreutils | stat' from control file, as
147     the dependency is satisfied within essential (Closes: #370002)
148
149  -- Barry Hawkins <barry@alltc.com>  Mon, 26 Jun 2006 11:19:08 -0400
150
151 java-package (0.27) unstable; urgency=low
152
153   * Added support for IBM Java2 5.0 JREs and JDKs (Closes: #337129)
154   * Corrected missing alternatives links for all JREs and JDKs
155     (Closes: #317492)
156   * Added conditional wrapping around dh_compress to account for
157     JRE/JDKs that do not ship manpages (Closes: 301738)
158   * Removed java-common from Provides: for JRE and JDK packages.
159
160  -- Barry Hawkins <barry@bytemason.org>  Tue, 08 Nov 2005 12:16:24 -0500
161
162 java-package (0.26) unstable; urgency=low
163
164   * Update standards version to 3.6.2
165   * Resolve issues with powerpc-linux support detection (Closes: #317671)
166   * Added support for Blackdown 1.4.2+02 release (Closes: #316831)
167   * Added support for packaging Sun JDK documentation (Closes: #272971)
168   * Modified make-jpkg behavior to default the generated packages' 
169     name and email address for the maintainer to Debian Java Maintainers
170     (Closes: #325554)
171
172  -- Barry Hawkins <barry@bytemason.org>  Thu, 18 Aug 2005 00:43:17 -0400
173
174 java-package (0.25) unstable; urgency=low
175
176   * Cope with dpkg's new way of expressing architectures (Closes: #313555)
177   * Re-exec with fakeroot if needed (Closes: #310132)
178
179  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Sun, 10 Jul 2005 18:50:40 +0200
180
181 java-package (0.24) unstable; urgency=low
182
183   * Added plugin alternatives support for i386 IBM JREs and JDKs
184   * Corrected pathing for plugin alternatives to reflect difference in 
185     layout between JREs and JDKs for Sun and Blackdown (Closes: #305219,
186     #301806)
187
188  -- Barry Hawkins <barry@bytemason.org>  Wed, 21 Apr 2005 01:02:03 -0400
189
190 java-package (0.23.1) experimental; urgency=low
191
192   * Added architecture-specific pathing for plugin alternatives for 
193     Blackdown 1.3 and 1.4 JREs and JDKs
194
195  -- Barry Hawkins <barry@bytemason.org>  Wed, 06 Apr 2005 00:03:40 -0500
196
197 java-package (0.23) unstable; urgency=low
198
199   * Further expanded 1.3.1 Blackdown JRE/JDK support for i386
200   * Added architecture-specific pathing for plugin alternatives for 
201     Sun 1.4 and 1.5 JREs and JDKs (Closes: #301806)
202   * Added recommends for system elements required by applets and 
203     graphical user interface elements (Closes: #300817)
204   * Jeroen van Wolffelaar:
205     + Fixed packages description to not have too long lines, and make the 3
206       items an enumeration
207
208  -- Barry Hawkins <barry@bytemason.org>  Fri, 01 Apr 2005 00:36:40 -0500
209
210 java-package (0.22.1) experimental; urgency=low
211
212   * Corrected IBM and Blackdown JRE/JDK file size specifications
213   * Added support for additional 1.3.1 Blackdown JREs and JDKs for i386,
214     powerpc (Closes: #301092)
215   * Added installation of javaws alternative for Sun 1.5 JREs and JDKs 
216     (Closes: #300303)
217
218  -- Barry Hawkins <barry@bytemason.org>  Thu, 24 Mar 2005 13:20:18 -0500
219
220 java-package (0.22) unstable; urgency=low
221
222   * Corrected IBM JRE/JDK scripts to accurately reflect the supported 
223     IBM JDKs and JREs in the generated SUPPORTED file
224
225  -- Barry Hawkins <barry@alltc.com>  Fri, 18 Mar 2005 10:21:53 -0500
226
227 java-package (0.21) unstable; urgency=low
228
229   * Enable support for IBM JDKs and JREs for x86, amd64, powerpc, 
230     powerpc64, and s390 architectures, based upon a patch by Rico 
231     Schiekel (Closes: #264137)
232   * Enable suppport for Blackdown 1.3.1 JDK and JRE for PowerPC 
233     architecture. (Closes: #296205)
234   * Update documentation and to reflect current supported JDKs and JREs
235
236  -- Barry Hawkins <barry@alltc.com>  Mon, 14 Mar 2005 03:18:39 -0500
237
238 java-package (0.20) unstable; urgency=low
239
240   * Make the postinst & rm for generated packages #!/bin/bash, as we use
241     bash-specific features (Closes: #292179)
242   * Drop the df output parsing, use '/usr/bin/stat' instead (Closes: #293487,
243     #289006, #293350)
244   * Drop the now obsolete peer stuff from the source package
245   * Change priorities, 313 for 1.3, 314 for 1.4, etc (Closes: #292451)
246   * Don't dh_strip, fiddling with upstream's binaries apparantly breaks stuff
247     (Closes: #291238)
248
249  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Tue, 08 Feb 2005 15:04:51 +0100
250
251 java-package (0.19) unstable; urgency=low
252
253   The "Joshua Kwan <joshk@debian.org> rocks!" release.
254
255   Joshua Kwan:
256   * Unclutter Debian build system and rework package slightly so that
257     *debian packages are not needed anymore. The necessary files will be
258     included in the generated packages. (Closes: #291145, #289245, #284779)
259   * Add support for Blackdown 1.4.2+01 build. (Closes: #285405)
260   * Fix support for Sun 1.5.0 amd64 builds due to typo. (Closes: #290879)
261   * Mozilla browser plugin name changed in 1.4.2 versions. Detect and correct.
262     (Closes: #273730)
263   * Use --block-size=1M instead of -BM. (Closes: #289005, #291161)
264   * Disable support for Sun JDK 1.3 due to its dependencies on libraries
265     that are simply not available anymore. (Closes: #272972)
266   * Fix up short description a little bit.
267   * Bump Standards-Version to 3.6.1 (no changes)
268   * Be a bit more conservative with the real-root test.
269   * Remove last j2se-package references.
270   * Change Suggests on fakeroot to a Depends because it is worthless both
271     as real root and as a normal user without fakeroot.
272
273   Jeroen van Wolffelaar:
274   * Use DEBFULLNAME, DEBNAME and DEBEMAIL if available, and don't ask for
275     those values in that case. (Closes: #279653)
276   * Updated documentation regarding dropped Sun 1.3 support
277   * Work around multiline df output caused by long device names
278     (Closes: #289006)
279   * Add Replaces: for the generated packages on their *debian counterparts
280
281  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Tue, 25 Jan 2005 00:05:06 +0100
282
283 java-package (0.18) unstable; urgency=low
284
285   * Added myself to Uploaders
286   * Fix security hole (inscure temp file creation) plus lots of needless I/O
287     in free disk checking function
288   * Added support for Sun's JDK/JRE 1.5 patch levels, based on a patch by
289     Peter Marschall <peter@adpm.de> (Closes: #286718, #287857)
290   * Bail out if running as real root (works around the evil parts of Sun's
291     install script that unconditionally writes to /etc, see #266273, #280707)
292   * Fix typo in j2re.sh that apparantly with some versions of
293     bash/dpkg/whatever cause package build failure (Closes: #281780, #282902)
294   * Reduce minimum expected size a bit Sun's 1.5.0 amd64 package, it was set
295     too high (Closes: #284033)
296   * Substitute package version number at build time in the make-jpkg
297     executable (Closes: #282221)
298   * Added a README.Debian explaining the existance of make-jpkg and what
299     binary packages are supported and where to get them. Thanks Thijs
300     Kinkhorst for the draft (Closes: #283362)
301   * Added automatically-generated file SUPPORTED that lists all binary
302     filenames that are supported, thanks Alex Owen <owen@cus.org.uk> for the
303     idea (Closes: #275296)
304
305  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Mon,  3 Jan 2005 18:47:47 +0100
306
307 java-package (0.17) unstable; urgency=low
308
309   * added a patch for detecting the architecture (Closes: #274844,
310     #270949, #271846). This patch should also close this one (Closes:
311     #280685).
312
313  -- Arnaud Vandyck <avdyk@debian.org>  Fri, 12 Nov 2004 17:28:38 +0100
314
315 java-package (0.16) unstable; urgency=low
316
317   * added myself as an uploader.
318   * Carlos already closed the support for 1.5 request but it seems he did
319     not upload the package (Closes: #277088).
320
321  -- Arnaud Vandyck <avdyk@debian.org>  Wed, 10 Nov 2004 16:38:44 +0100
322
323 java-package (0.15) unstable; urgency=low
324
325   * lib/sun-j2re.sh: Added support for JRE 1.5.0 (aka "Java 5.0").
326   * lib/sun-j2sdk.sh: Added support for Java SDK 1.5.0.
327
328  -- Carlos Laviola <claviola@debian.org>  Mon, 11 Oct 2004 21:08:59 -0300
329
330 java-package (0.14) unstable; urgency=low
331
332   * debian/control: Commented out the lines that generate the Debian-specific
333     packages, thus making alternatives available.
334     - Also made all of the generated packages depend on their Debian-specific
335     counterparts by default.  (Closes: #266671)
336
337  -- Carlos Laviola <claviola@debian.org>  Mon, 13 Sep 2004 03:38:31 -0300
338
339 java-package (0.13) unstable; urgency=low
340
341   * References to j2se-package are gone.  (Closes: #267642)
342   * Added support for Blackdown Java 1.4.2 RC1 JRE/SDK.  (Closes: #267643)
343
344  -- Carlos Laviola <claviola@debian.org>  Mon, 13 Sep 2004 03:17:54 -0300
345
346 java-package (0.12) unstable; urgency=low
347
348   * remove to contrib because this package depend on non-free J2SE.
349
350  -- Takashi Okamoto <tora@debian.org>  Tue,  3 Aug 2004 00:37:13 +0900
351
352 java-package (0.11) unstable; urgency=low
353
354   * change package name java-package and the command build package is 
355     make-jpkg.
356
357  -- Takashi Okamoto <tora@debian.org>  Sat, 31 Jul 2004 15:07:36 +0900
358
359 java-package (0.10) unstable; urgency=low
360
361   * change package name mpkg-j2se.
362   * not use *-j2[re|sdk]debian package. Instead of this, add package 
363     dependency to generated package. This reduce the installation for 
364     such extra package. 
365   * SUN's jdk1.5 beta2 support.
366
367  -- Takashi Okamoto <tora@debian.org>  Sun, 18 Jul 2004 13:53:36 +0900
368
369 java-package (0.9) unstable; urgency=low
370
371   * more generic support for j2re1.3.1/j2sdk1.3.1 from SUN.
372
373   * add alternative for jarsigner (in j2sdk1.4 and j2sdk1.5 from SUN).
374
375  -- Hubert Schmid <ude2@z42.de>  Sun, 23 May 2004 23:35:14 +0200
376
377 java-package (0.8) unstable; urgency=low
378
379   * java plugin: support for mozilla-firefox.
380
381  -- Hubert Schmid <ude2@z42.de>  Tue,  4 May 2004 22:39:39 +0200
382
383 java-package (0.7) unstable; urgency=low
384
385   * Optionally create .changes file.
386
387   * Add command line options: --help, --version, --full-name,
388     --email, --changes.
389
390   * Add environment variables: J2SE_PACKAGE_FULL_NAME,
391     J2SE_PACKAGE_EMAIL.
392
393  -- Hubert Schmid <ude2@z42.de>  Sat, 27 Mar 2004 23:01:08 +0100
394
395 java-package (0.6) unstable; urgency=low
396
397   * More generic support for Java2 1.4.2 from SUN.
398
399  -- Hubert Schmid <ude2@z42.de>  Thu, 11 Mar 2004 20:39:51 +0100
400
401 java-package (0.5) unstable; urgency=low
402
403   * NEW: build Blackdown J2RE 1.4.1 (gcc-2.95) and J2SDK 1.4.1 (gcc-2.95).
404
405   * NEW: support for SUN J2RE 1.5.0 beta, SUN J2SDK 1.5.0 beta.
406
407  -- Hubert Schmid <ude2@z42.de>  Sat,  7 Feb 2004 21:57:09 +0100
408
409 java-package (0.4) unstable; urgency=low
410
411   * Added support for: SUN J2RE 1.4.2_03, SUN J2SDK 1.4.2_03
412
413  -- Hubert Schmid <ude2@z42.de>  Thu, 15 Jan 2004 22:27:52 +0100
414
415 java-package (0.3) unstable; urgency=low
416
417   * Added support for: Blackdown J2RE 1.3, 1.4, J2SDK 1.3, 1.4
418
419   * Removed usage of "du --apparent-size". This should fix a problem
420     with old fileutils.
421
422  -- Hubert Schmid <ude2@z42.de>  Sun,  9 Nov 2003 21:13:38 +0100
423
424 java-package (0.2) unstable; urgency=low
425
426   * Added support for: Sun J2RE 1.3, Sun J2SDK 1.3, Sun J2SDK 1.4
427
428   * Moved peer packages into this source package.
429
430  -- Hubert Schmid <ude2@z42.de>  Thu, 30 Oct 2003 00:10:01 +0100
431
432 java-package (0.1) unstable; urgency=low
433
434   * Initial Release.
435
436  -- Hubert Schmid <j2se-package@z42.de>  Sun, 26 Oct 2003 20:06:57 +0100
437
438 Local variables:
439 mode: debian-changelog
440 End: