adjust the expected min size for JDK 9 and prior releases
[sven/java-package.git] / lib / oracle-jdk.sh
index 9dc235a..65db778 100644 (file)
@@ -11,6 +11,7 @@ oracle_j2sdk_detect() {
       j2se_arch=x64
       j2se_version_name="${j2se_release} version ${j2se_release}${j2se_update}" 
       j2se_version=${j2se_relase}${j2se_update}${revision}
+      j2se_expected_min_size=340 #Mb
   fi
 
   # Update or GA release (jdk-7u15-linux-i586.tar.gz)
@@ -49,7 +50,7 @@ oracle_j2sdk_detect() {
   if [[ $j2se_release > 0 ]]
   then
     j2se_priority=$((310 + $j2se_release))
-    j2se_expected_min_size=130 #Mb
+    j2se_expected_min_size=${j2se_expected_min_size:-180} #Mb  
 
     # check if the architecture matches
     let compatible=1