Create build depends for JDK.
authorBenjamin Drung <benjamin.drung@profitbricks.com>
Tue, 17 Jun 2014 18:36:50 +0000 (20:36 +0200)
committerBenjamin Drung <benjamin.drung@profitbricks.com>
Tue, 17 Jun 2014 18:36:50 +0000 (20:36 +0200)
lib/javase.sh
lib/jdk.sh

index 0254725..e6592cc 100644 (file)
@@ -21,12 +21,15 @@ EOF
 }
 
 j2se_control() {
+    if test -n "$build_depends"; then
+        build_depends=", $build_depends"
+    fi
     cat << EOF
 Source: $j2se_package
 Section: non-free/devel
 Priority: optional
 Maintainer: $maintainer_name <$maintainer_email>
-Build-Depends: debhelper (>= 9)
+Build-Depends: debhelper (>= 9)${build_depends}
 Standards-Version: 3.9.5
 
 EOF
index 25d7d9c..39a4cee 100644 (file)
@@ -1,5 +1,9 @@
 
 j2sdk_control() {
+    build_depends="libasound2, libgl1-mesa-glx, libgtk2.0-0, libxslt1.1, libxtst6, libxxf86vm1"
+    if test "$j2se_release" = 8; then
+        build_depends="$build_depends, libavcodec53, libavformat53"
+    fi
     j2se_control
     java_browser_plugin="java-browser-plugin, "
     depends="\${shlibs:Depends}"