Add version matching code for JRE 9
authorSven Hoexter <sven@stormbind.net>
Sun, 17 Dec 2017 11:05:00 +0000 (12:05 +0100)
committerSven Hoexter <sven@stormbind.net>
Sun, 17 Dec 2017 11:05:00 +0000 (12:05 +0100)
lib/oracle-jre.sh

index 94e3d5d..4f408ff 100644 (file)
@@ -3,6 +3,16 @@ j2se_detect_oracle_j2re=oracle_j2re_detect
 oracle_j2re_detect() {
   j2se_release=0
 
+  # JRE 9 GA release (jre-9.0.1_linux-x64_bin.tar.gz)
+  if [[ $archive_name =~ ^jre-9(\.([0-9]+)\.([0-9]+))?_linux-x64_bin\.tar\.gz ]]
+  then
+      j2se_release=9
+      j2se_update=${BASH_REMATCH[1]:-.0.0}
+      j2se_arch=x64
+      j2se_version_name="${j2se_release} version ${j2se_release}${j2se_update}"
+      j2se_version=${j2se_release}${j2se_update}${revision}
+  fi
+
   # Update or GA release (jre-7u13-linux-x64.tar.gz)
   if [[ $archive_name =~ ^jre-([0-9]+)(u([0-9]+))?-linux-(i586|x64|amd64)\.(bin|tar\.gz) ]]
   then