]> git.sven.stormbind.net Git - sven/vym.git/blobdiff - debian/rules
Link the default vym hicolor icon also for the mime type
[sven/vym.git] / debian / rules
index fee12e1666afe21f505b1e0f616bfd844bd349ea..09b9c94913784f2d6790f43b9dde46e7e3acb36e 100755 (executable)
@@ -1,7 +1,5 @@
 #!/usr/bin/make -f
 
-DEB_COMPRESS_EXCLUDE = vym.pdf
-
 export DEB_BUILD_MAINT_OPTIONS = hardening=+all
 export DEB_CFLAGS_MAINT_APPEND = -Wall
 export QT_SELECT = 5
@@ -13,5 +11,14 @@ override_dh_auto_configure:
        dh_auto_configure -- \
                -DCMAKE_INSTALL_DATAROOTDIR="share/vym" \
                -DCMAKE_INSTALL_MANDIR="share/man/man1" \
-               -DCMAKE_INSTALL_DOCDIR="share/vym"
+               -DCMAKE_INSTALL_DOCDIR="share/doc/vym"
+
+override_dh_auto_install:
+       dh_auto_install --destdir=debian/vym/
+       # create a link to use the vym icon in the hicolor default theme
+       # for .vym files matched by the mime type
+       ln -s ../apps/vym.png debian/vym/usr/share/icons/hicolor/48x48/mimetypes/application-x-vym.png
 
+# prevent compression of pdf documentation
+override_dh_compress:
+       dh_compress -X.pdf