]> git.sven.stormbind.net Git - sven/vym.git/blobdiff - debian/rules
Remove license file from doc folder
[sven/vym.git] / debian / rules
index 65f92a2609bd9f77e5eeb633b5635a453870cacf..5d3420530873106200703b96e1ced09a1f1b81ad 100755 (executable)
@@ -1,7 +1,5 @@
 #!/usr/bin/make -f
 
-DEB_COMPRESS_EXCLUDE = vym.pdf
-
 export DEB_BUILD_MAINT_OPTIONS = hardening=+all
 export DEB_CFLAGS_MAINT_APPEND = -Wall
 export QT_SELECT = 5
@@ -15,3 +13,13 @@ override_dh_auto_configure:
                -DCMAKE_INSTALL_MANDIR="share/man/man1" \
                -DCMAKE_INSTALL_DOCDIR="share/doc/vym"
 
+override_dh_auto_install:
+       dh_auto_install --destdir=debian/vym/
+       # remove wrongly placed manpage
+       rm debian/vym/usr/share/doc/vym/doc/vym.1.gz
+       # remove installed lincense file
+       rm debian/vym/usr/share/doc/vym/LICENSE.txt
+
+# prevent compression of pdf documentation
+override_dh_compress:
+       dh_compress -X.pdf