]> git.sven.stormbind.net Git - sven/vym.git/blobdiff - debian/rules
patch cmake instructions to avoid some hacks
[sven/vym.git] / debian / rules
index fee12e1666afe21f505b1e0f616bfd844bd349ea..df0df7e238ccb8df74afd0ca10afd9352f1d2c76 100755 (executable)
@@ -1,7 +1,5 @@
 #!/usr/bin/make -f
 
-DEB_COMPRESS_EXCLUDE = vym.pdf
-
 export DEB_BUILD_MAINT_OPTIONS = hardening=+all
 export DEB_CFLAGS_MAINT_APPEND = -Wall
 export QT_SELECT = 5
@@ -13,5 +11,11 @@ override_dh_auto_configure:
        dh_auto_configure -- \
                -DCMAKE_INSTALL_DATAROOTDIR="share/vym" \
                -DCMAKE_INSTALL_MANDIR="share/man/man1" \
-               -DCMAKE_INSTALL_DOCDIR="share/vym"
+               -DCMAKE_INSTALL_DOCDIR="share/doc/vym"
+
+override_dh_auto_install:
+       dh_auto_install --destdir=debian/vym/
 
+# prevent compression of pdf documentation
+override_dh_compress:
+       dh_compress -X.pdf