]> git.sven.stormbind.net Git - sven/exfat-utils.git/blobdiff - debian/rules
Imported Debian patch 0.9.5-1
[sven/exfat-utils.git] / debian / rules
diff --git a/debian/rules b/debian/rules
new file mode 100755 (executable)
index 0000000..ceff3f1
--- /dev/null
@@ -0,0 +1,30 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+%:
+       dh $@ 
+
+override_dh_auto_build:
+       scons
+
+override_dh_auto_clean:
+       scons -c
+
+override_dh_auto_install:
+       mkdir -p debian/exfat-utils/sbin
+       cd debian/exfat-utils/sbin && \
+               ln -s exfatfsck fsck.exfat; \
+               ln -s mkexfatfs mkfs.exfat
+
+       mkdir -p debian/exfat-utils/usr/share/man/man8
+       cd debian/exfat-utils/usr/share/man/man8 && \
+               ln -s exfatfsck.8.gz fsck.exfat.8.gz; \
+               ln -s mkexfatfs.8.gz mkfs.exfat.8.gz