]> git.sven.stormbind.net Git - sven/exfat-utils.git/blobdiff - debian/rules
Add "-D_GNU_SOURCE" unconditionally to the list of CCFLAGS, needed to build on kfreebsd.
[sven/exfat-utils.git] / debian / rules
index 01a85aceceef9839d9400a8932080e2249eb0023..9f7d91a353fc3c6045112df2df7eda5b7fdec914 100755 (executable)
@@ -1,25 +1,16 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export CCFLAGS = $(CFLAGS) -Wall -std=c99 -D_GNU_SOURCE
 
 %:
-       dh $@ 
+       dh $@
 
 override_dh_auto_build:
        scons
 
 override_dh_auto_clean:
        scons -c
-
-override_dh_auto_install:
-       mkdir -p debian/exfat-utils/sbin
-       cd debian/exfat-utils/sbin && \
-               ln -s exfatfsck fsck.exfat; \
-               ln -s mkexfatfs mkfs.exfat
-
-       mkdir -p debian/exfat-utils/usr/share/man/man8
-       cd debian/exfat-utils/usr/share/man/man8 && \
-               ln -s exfatfsck.8.gz fsck.exfat.8.gz; \
-               ln -s mkexfatfs.8.gz mkfs.exfat.8.gz
+       rm -f config.log