]> git.sven.stormbind.net Git - sven/jattach.git/blob - jattach.spec
Close ITP bug
[sven/jattach.git] / jattach.spec
1 Name:           jattach
2 Version:        1.3
3 Release:        1
4 Summary:        JVM Dynamic Attach utility
5
6 Group:          Development/Tools
7 License:        ASL 2.0
8 URL:            https://github.com/apangin/jattach
9 Vendor:         Andrei Pangin
10 Packager:       Vadim Tsesko <incubos@yandex.com>
11
12 BuildRequires:  gcc
13 BuildRequires:  make
14
15 %description
16 The utility to send commands to remote JVM via Dynamic Attach mechanism.
17
18 All-in-one jmap + jstack + jcmd + jinfo functionality in a single tiny program.
19 No installed JDK required, works with just JRE.
20
21 This is the lightweight native version of HotSpot Attach API:
22 https://docs.oracle.com/javase/8/docs/jdk/api/attach/spec/
23
24 %build
25 # Do nothing
26
27 %install
28 BIN=%{buildroot}/usr/bin
29
30 mkdir -p ${BIN}
31
32 install -p -m 555 %{_sourcedir}/bin/jattach ${BIN}
33
34 %files
35 /usr/bin/jattach
36
37 %changelog
38 * Wed Nov 30 2016 Vadim Tsesko <incubos@yandex.com> - 0.1-1
39 - Initial version