]> git.sven.stormbind.net Git - sven/jattach.git/blobdiff - debian/patches/do-not-override-CFLAGS
New upstream release.
[sven/jattach.git] / debian / patches / do-not-override-CFLAGS
index a5b351f40b6cc2fcf0739d163cfd6c9d9431e519..50774fc2e53ce9b4e0bd6e2c18fbe0a88d363299 100644 (file)
@@ -3,13 +3,25 @@ Description: do not override CFLAGS
  exported by dh.
 Author: Sven Hoexter <hoexter@debian.org>
 
---- jattach-1.5.orig/Makefile
-+++ jattach-1.5/Makefile
-@@ -16,7 +16,6 @@ else
+Index: jattach/Makefile
+===================================================================
+--- jattach.orig/Makefile
++++ jattach/Makefile
+@@ -16,7 +16,7 @@ else
      SOURCES=$(RPM_ROOT)/SOURCES
      SPEC_FILE=jattach.spec
      CC=gcc
 -    CFLAGS=-O2
++    CFLAGS ?= -O2
      JATTACH_EXE=jattach
    endif
  endif
+@@ -27,7 +27,7 @@ build:
+       mkdir -p build
+ build/jattach: src/jattach_posix.c
+-      $(CC) $(CFLAGS) -DJATTACH_VERSION=\"$(JATTACH_VERSION)\" -o $@ $^
++      $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -DJATTACH_VERSION=\"$(JATTACH_VERSION)\" -o $@ $^
+ build/jattach.exe: src/jattach_windows.c
+       $(CL) $(CFLAGS) /DJATTACH_VERSION=\"$(JATTACH_VERSION)\" /Fobuild/jattach.obj /Fe$@ $^ advapi32.lib /link /SUBSYSTEM:CONSOLE,5.02