]> git.sven.stormbind.net Git - sven/mysqltcl.git/blobdiff - debian/README.source
* Bump Standards-Version to 3.8.0
[sven/mysqltcl.git] / debian / README.source
diff --git a/debian/README.source b/debian/README.source
new file mode 100644 (file)
index 0000000..acee5c3
--- /dev/null
@@ -0,0 +1,79 @@
+==================================
+Quilt using package in your hands
+==================================
+
+This package makes use of a debian/patches/ directory maintained
+with quilt. The integration of the actual patches in the build process
+is done with the inclusion of /usr/share/quilt/quilt.make in debian/rules.
+Thus you've the patch and unpatch target available to take a look at what
+the patched source will look like.
+
+Modify this package
+===================
+
+You can still modify this package (e.g. for NMUs) through editing
+the source but be aware that this might collide with patches integrated
+in the patch system.
+
+
+Modify this package with quilt
+==============================
+
+This is a small example to get you started with quilt on a similar package
+and is far from beeing complete.
+
+dpkg-source -x the package and change into that directory
+
+// Set the path to the patches correctly so that quilt can find them
+tclcurl-7.19.0$ export QUILT_PATCHES=debian/patches
+
+// Check on the different patches available
+tclcurl-7.19.0$ quilt series
+man-section
+reformat-tclcurl3
+correct-linking
+
+// Apply the correct-linking patch, this will cause quilt to apply all patches
+// stacked on the selected one first.
+tclcurl-7.19.0$ quilt push correct-linking
+[...]
+
+// Take a look at the current diff
+tclcurl-7.19.0$ quilt diff
+[...]
+
+
+// Open configure for editing
+tclcurl-7.19.0$ quilt edit configure
+[...]
+
+// Refresh the patch you're working on
+tclcurl-7.19.0$ quilt refresh
+Refreshed patch correct-linking
+
+// Remove the patch from your working stack
+tclcurl-7.19.0$ quilt pop
+Removing patch correct-linking
+Restoring configure
+Restoring configure.in
+
+Now at patch reformat-tclcurl3
+
+// Add a new patch
+tclcurl-7.19.0$ quilt new my-patch
+Patch my-patch is now on top
+
+You can now edit, refresh and pop this patch of the stack
+when you're done.
+
+// Importing an external patch is also possible
+tclcurl-7.19.0$ quilt import -P <patch> /path/to/ext-patch
+
+
+
+Adding patches to quilt without actually using it
+=================================================
+
+You can operate without using quilt. You just need
+to add a proper patch to debian/patches and add the
+name to the series file in the same directory.