]> git.sven.stormbind.net Git - sven/mysqltcl.git/blobdiff - debian/rules
Optimisation round 2
[sven/mysqltcl.git] / debian / rules
index 1b1dd99e7e43b4f6f5f218341715aa18be06d155..1249cfd0905425b8101c07a31d495ba525717127 100755 (executable)
@@ -23,12 +23,12 @@ CONFIGURE_OPTIONS += \
 
 LDFLAGS += -Wl,-z,defs -Wl,--as-needed
 
-CFLAGS += -Wall -g
+CFLAGS = -Wall -g
 
-ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-        CFLAGS += -O2
-else
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
         CFLAGS += -O0
+else
+        CFLAGS += -O2
 endif
 
 
@@ -62,6 +62,9 @@ install: build
        dh_installdirs
 
        $(MAKE) install DESTDIR=$(CURDIR)/debian/mysqltcl
+       mkdir $(CURDIR)/debian/mysqltcl/usr/lib/tcltk
+       mv $(CURDIR)/debian/mysqltcl/usr/lib/mysqltcl* \
+               $(CURDIR)/debian/mysqltcl/usr/lib/tcltk
        rm -rf \
                $(CURDIR)/debian/mysqltcl/usr/share/man/mann \
                $(CURDIR)/debian/mysqltcl/usr/bin \