]> git.sven.stormbind.net Git - sven/mysqltcl.git/blobdiff - debian/rules
Optimisation round 2
[sven/mysqltcl.git] / debian / rules
index cdacbbe2011f0753cd6bee9bf773a8c540ccf0aa..1249cfd0905425b8101c07a31d495ba525717127 100755 (executable)
@@ -23,12 +23,12 @@ CONFIGURE_OPTIONS += \
 
 LDFLAGS += -Wl,-z,defs -Wl,--as-needed
 
-CFLAGS += -Wall -g
+CFLAGS = -Wall -g
 
-ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-        CFLAGS += -O2
-else
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
         CFLAGS += -O0
+else
+        CFLAGS += -O2
 endif