]> git.sven.stormbind.net Git - sven/mysqltcl.git/blobdiff - debian/rules
Optimisation round 2
[sven/mysqltcl.git] / debian / rules
index d3c29cfb0ef032169522b7d2d3e9d84d70e8efc8..1249cfd0905425b8101c07a31d495ba525717127 100755 (executable)
@@ -23,12 +23,12 @@ CONFIGURE_OPTIONS += \
 
 LDFLAGS += -Wl,-z,defs -Wl,--as-needed
 
-CFLAGS += -Wall -g
+CFLAGS = -Wall -g
 
-ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-        CFLAGS += -O2
-else
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
         CFLAGS += -O0
+else
+        CFLAGS += -O2
 endif
 
 
@@ -63,7 +63,8 @@ install: build
 
        $(MAKE) install DESTDIR=$(CURDIR)/debian/mysqltcl
        mkdir $(CURDIR)/debian/mysqltcl/usr/lib/tcltk
-       mv $(CURDIR)/debian/mysqltcl/usr/lib/mysqltcl* $(CURDIR)/debian/mysqltcl/usr/lib/tcltk
+       mv $(CURDIR)/debian/mysqltcl/usr/lib/mysqltcl* \
+               $(CURDIR)/debian/mysqltcl/usr/lib/tcltk
        rm -rf \
                $(CURDIR)/debian/mysqltcl/usr/share/man/mann \
                $(CURDIR)/debian/mysqltcl/usr/bin \