]> git.sven.stormbind.net Git - sven/mysqltcl.git/blobdiff - debian/rules
Try to enable hardening=+all.
[sven/mysqltcl.git] / debian / rules
index 571e38bc4bed55b9304517452dc1286437f52e60..55b7693e232f1727c251426a3e47ed1ea36ea1ab 100755 (executable)
@@ -3,6 +3,7 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
 DPKG_EXPORT_BUILDFLAGS = 1
 include /usr/share/dpkg/buildflags.mk
 
@@ -24,13 +25,14 @@ override_dh_auto_configure:
 override_dh_auto_install:
        dh_auto_install --destdir=$(CURDIR)/debian/mysqltcl
 
-       mkdir $(CURDIR)/debian/mysqltcl/usr/lib/tcltk
-       mv $(CURDIR)/debian/mysqltcl/usr/lib/mysqltcl* \
-               $(CURDIR)/debian/mysqltcl/usr/lib/tcltk
+       mkdir -p $(CURDIR)/debian/mysqltcl/usr/lib/tcltk/$(DEB_HOST_MULTIARCH)
+       mv $(CURDIR)/debian/mysqltcl/usr/lib/$(DEB_HOST_MULTIARCH)/mysqltcl* \
+               $(CURDIR)/debian/mysqltcl/usr/lib/tcltk/$(DEB_HOST_MULTIARCH)
        rm -rf \
                $(CURDIR)/debian/mysqltcl/usr/share/man/mann \
                $(CURDIR)/debian/mysqltcl/usr/bin \
-               $(CURDIR)/debian/mysqltcl/usr/include
+               $(CURDIR)/debian/mysqltcl/usr/include \
+               $(CURDIR)/debian/mysqltcl/usr/lib/$(DEB_HOST_MULTIARCH)
 
 override_dh_makeshlibs:
        dh_makeshlibs