]> git.sven.stormbind.net Git - sven/mysqltcl.git/blobdiff - debian/rules
Try to enable hardening=+all.
[sven/mysqltcl.git] / debian / rules
index a1d4952258d709541cb4c62543b98c0cf515db3c..55b7693e232f1727c251426a3e47ed1ea36ea1ab 100755 (executable)
@@ -3,7 +3,11 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-LDFLAGS += -Wl,-z,defs -Wl,--as-needed
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/buildflags.mk
+
+DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
 
 %:
        dh $@ --with quilt,autoreconf
@@ -16,17 +20,19 @@ override_dh_auto_configure:
                --infodir=/usr/share/info \
                --with-tcl=/usr/lib \
                --with-tclinclude=/usr/include/tcl \
+               --with-mysql-lib=/usr/lib/$(DEB_HOST_MULTIARCH)
 
 override_dh_auto_install:
        dh_auto_install --destdir=$(CURDIR)/debian/mysqltcl
 
-       mkdir $(CURDIR)/debian/mysqltcl/usr/lib/tcltk
-       mv $(CURDIR)/debian/mysqltcl/usr/lib/mysqltcl* \
-               $(CURDIR)/debian/mysqltcl/usr/lib/tcltk
+       mkdir -p $(CURDIR)/debian/mysqltcl/usr/lib/tcltk/$(DEB_HOST_MULTIARCH)
+       mv $(CURDIR)/debian/mysqltcl/usr/lib/$(DEB_HOST_MULTIARCH)/mysqltcl* \
+               $(CURDIR)/debian/mysqltcl/usr/lib/tcltk/$(DEB_HOST_MULTIARCH)
        rm -rf \
                $(CURDIR)/debian/mysqltcl/usr/share/man/mann \
                $(CURDIR)/debian/mysqltcl/usr/bin \
-               $(CURDIR)/debian/mysqltcl/usr/include
+               $(CURDIR)/debian/mysqltcl/usr/include \
+               $(CURDIR)/debian/mysqltcl/usr/lib/$(DEB_HOST_MULTIARCH)
 
 override_dh_makeshlibs:
        dh_makeshlibs