]> git.sven.stormbind.net Git - sven/mysqltcl.git/blobdiff - debian/rules
* Reworked debian/rules partly to make it a little bit clearer.
[sven/mysqltcl.git] / debian / rules
index 439bc930e95ddbfbcec6e4e589828f63709cf525..c62250bc0a2ffa501b10199e4121fd8f275367df 100755 (executable)
@@ -5,21 +5,45 @@
 
 include /usr/share/quilt/quilt.make
 
+
+ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
+        CONFIGURE_OPTIONS += --build $(DEB_HOST_GNU_TYPE)
+else
+        CONFIGURE_OPTIONS += --build $(DEB_BUILD_GNU_TYPE) \
+                --host $(DEB_HOST_GNU_TYPE)
+endif
+
+
+CONFIGURE_OPTIONS += \
+               --prefix=/usr \
+               --enable-threads \
+               --mandir=/usr/share/man \
+               --infodir=/usr/share/info \
+
+
 LDFLAGS += -Wl,-z,defs -Wl,--as-needed
 
+CFLAGS += -Wall -g
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+        CFLAGS += -O2
+else
+        CFLAGS += -O0
+endif
+
+
 configure: patch configure-stamp
 configure-stamp:
        dh_testdir
-       ./configure \
-               --prefix=/usr
-               --enable-threads
+
+       CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" \
+       ./configure $(CONFIGURE_OPTIONS)
 
        touch configure-stamp
 
 build: configure build-stamp
 build-stamp:
        dh_testdir
-
        $(MAKE)
        touch build-stamp
 
@@ -28,7 +52,6 @@ cleaner:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-
        [ ! -f Makefile ] || $(MAKE) distclean
        dh_clean
 
@@ -50,7 +73,6 @@ binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installdocs
-       dh_installexamples
        dh_installman
        dh_installchangelogs ChangeLog
        dh_link