]> git.sven.stormbind.net Git - sven/mysqltcl.git/blobdiff - debian/rules
* Convert to dh:
[sven/mysqltcl.git] / debian / rules
index 723bf5212a509546c09b2be54d10efa73de96089..de1946d185ecdc28ebb1a6221e9e13f70b1faa17 100755 (executable)
@@ -3,18 +3,13 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-include /usr/share/quilt/quilt.make
-
-
-ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
-        CONFIGURE_OPTIONS += --build $(DEB_HOST_GNU_TYPE)
-else
-        CONFIGURE_OPTIONS += --build $(DEB_BUILD_GNU_TYPE) \
-                --host $(DEB_HOST_GNU_TYPE)
-endif
+LDFLAGS += -Wl,-z,defs -Wl,--as-needed
 
+%:
+       dh $@ --with quilt
 
-CONFIGURE_OPTIONS += \
+override_dh_auto_configure:
+       dh_auto_configure -- \
                --prefix=/usr \
                --enable-threads \
                --mandir=/usr/share/man \
@@ -22,48 +17,9 @@ CONFIGURE_OPTIONS += \
                --with-tcl=/usr/lib \
                --with-tclinclude=/usr/include/tcl \
 
+override_dh_auto_install:
+       dh_auto_install --destdir=$(CURDIR)/debian/mysqltcl
 
-LDFLAGS += -Wl,-z,defs -Wl,--as-needed
-
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-        CFLAGS += -O0
-else
-        CFLAGS += -O2
-endif
-
-
-configure: patch configure-stamp
-configure-stamp:
-       dh_testdir
-
-       CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" \
-       ./configure $(CONFIGURE_OPTIONS)
-
-       touch configure-stamp
-
-build: configure build-stamp
-build-stamp:
-       dh_testdir
-       $(MAKE)
-       touch build-stamp
-
-clean: cleaner unpatch
-cleaner:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp configure-stamp
-       [ ! -f Makefile ] || $(MAKE) distclean
-       dh_clean
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs
-
-       $(MAKE) install DESTDIR=$(CURDIR)/debian/mysqltcl
        mkdir $(CURDIR)/debian/mysqltcl/usr/lib/tcltk
        mv $(CURDIR)/debian/mysqltcl/usr/lib/mysqltcl* \
                $(CURDIR)/debian/mysqltcl/usr/lib/tcltk
@@ -72,28 +28,6 @@ install: build
                $(CURDIR)/debian/mysqltcl/usr/bin \
                $(CURDIR)/debian/mysqltcl/usr/include
 
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installdocs
-       dh_installman
-       dh_installchangelogs ChangeLog
-       dh_link
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
+override_dh_makeshlibs:
+       dh_makeshlibs
        tcltk-depends
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure