]> git.sven.stormbind.net Git - sven/tclcurl.git/blobdiff - debian/rules
Unification with mysqltcl rules files
[sven/tclcurl.git] / debian / rules
index 48d1e8424f897987ec2fd6df7fad64d45a4f82b6..b059de0b9bea232eec26135edd0feefcf10125e9 100755 (executable)
@@ -5,19 +5,40 @@
 
 include /usr/share/quilt/quilt.make
 
-LDFLAGS += -Wl,-z,defs -Wl,--as-needed
 
+ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
+        CONFIGURE_OPTIONS += --build $(DEB_HOST_GNU_TYPE)
+else
+        CONFIGURE_OPTIONS += --build $(DEB_BUILD_GNU_TYPE) \
+                --host $(DEB_HOST_GNU_TYPE)
+endif
 
-configure: patch configure-stamp
-configure-stamp:
-       dh_testdir
-       ./configure \
-       --host=${DEB_HOST_GNU_TYPE} \
-       --build=${DEB_BUILD_GNU_TYPE} \
+
+CONFIGURE_OPTIONS += \
        --prefix=/usr \
        --mandir=/usr/share/man \
        --infodir=/usr/share/info \
        --enable-threads
+
+
+LDFLAGS += -Wl,-z,defs -Wl,--as-needed
+
+CFLAGS += -Wall -g
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+        CFLAGS += -O2
+else
+        CFLAGS += -O0
+endif
+
+
+configure: patch configure-stamp
+configure-stamp:
+       dh_testdir
+
+        CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" \
+        ./configure $(CONFIGURE_OPTIONS)
+
        touch configure-stamp
 
 build: configure build-stamp
@@ -30,8 +51,8 @@ clean: cleaner unpatch
 cleaner:
        dh_testdir
        dh_testroot
-       [ ! -f Makefile ] || $(MAKE) distclean
        rm -f build-stamp configure-stamp   
+       [ ! -f Makefile ] || $(MAKE) distclean
        dh_clean
 
 install: build
@@ -39,8 +60,8 @@ install: build
        dh_testroot
        dh_clean -k
        dh_installdirs
-       $(MAKE) DESTDIR=`pwd`/debian/tmp install
-       dh_movefiles
+
+       $(MAKE) install DESTDIR=$(CURDIR)/debian/tclcurl
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -51,7 +72,6 @@ binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installdocs Changes.txt
-       dh_installexamples
        dh_installman
        dh_installchangelogs ChangeLog.txt
        dh_link
@@ -67,4 +87,4 @@ binary-arch: build install
 
 binary: binary-indep binary-arch
 
-.PHONY: binary binary-arch binary-indep build clean configure install
+.PHONY: build clean binary-arch binary-indep binary install configure