]> git.sven.stormbind.net Git - sven/pflogsumm.git/blobdiff - debian/rules
* Move to a minimized dh 7 rules file.
[sven/pflogsumm.git] / debian / rules
index fa4571a08999fa1f818ee7773c99293bd3b0f3d8..e95e6afa3dcd1be3535e11b89d93c1b23f982831 100755 (executable)
@@ -1,88 +1,8 @@
 #!/usr/bin/make -f
 #!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
+%:
+        dh $@
 
 
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
 
 
-# This is the debhelper compatability version to use.
-export DH_COMPAT=4
-
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-       
-
-       touch configure-stamp
-
-build: configure-stamp build-stamp
-build-stamp:
-       dh_testdir
-
-       # Add here commands to compile the package.
-       #/usr/bin/docbook-to-man debian/pflogsumm.sgml > pflogsumm.1
-
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp configure-stamp
-
-       # Add here commands to clean up after the build process.
-
-       dh_clean
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs
-
-       # Add here commands to install the package into debian/pflogsumm.
-       #$(MAKE) install DESTDIR=$(CURDIR)/debian/pflogsumm
-       cp pflogsumm.pl $(CURDIR)/debian/pflogsumm/usr/sbin/pflogsumm
-       cd $(CURDIR)/debian/pflogsumm/usr/sbin && ln -s pflogsumm pflogsumm.pl
-       cp pflogsumm.1 $(CURDIR)/debian/pflogsumm/usr/share/man/man1
-
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
-#      dh_testversion 2
-       dh_testdir
-       dh_testroot
-#      dh_installdebconf       
-       dh_installdocs rem_smtpd_stats_supp.pl pflogsumm-faq.txt README ToDo
-       dh_installexamples debian/example.cron.daily debian/example.cron.weekly 
-#      dh_installmenu
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installinit
-#      dh_installcron
-#      dh_installmanpages
-#      dh_installinfo
-#      dh_undocumented
-       dh_installchangelogs ChangeLog
-       dh_link
-       dh_strip
-       dh_compress
-       cd $(CURDIR)/debian/pflogsumm/usr/share/man/man1/ && ln -s pflogsumm.1.gz pflogsumm.pl.1.gz
-       
-       dh_fixperms
-       # You may want to make some executables suid here.
-#      dh_suidregister
-#      dh_makeshlibs
-       dh_installdeb
-#      dh_perl
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+override_dh_auto_install:
+        dh_auto_install
+        install --mode=644 pflogsumm.pl debian/pflogsumm/usr/sbin/pflogsumm