]> git.sven.stormbind.net Git - sven/java-package.git/blobdiff - debian/rules
Suppress debconf dependency and call
[sven/java-package.git] / debian / rules
index 9e6a0ad1a4b7831a32e762efa169debf4be763e0..7e1f875e8ec43ef665ae987d4272bbb049b49b75 100755 (executable)
@@ -8,11 +8,12 @@
 VERSION := $(shell head -n 1 $(CURDIR)/debian/changelog | sed 's/.*(//;s/).*//')
 B := $(CURDIR)/debian/java-package
 
 VERSION := $(shell head -n 1 $(CURDIR)/debian/changelog | sed 's/.*(//;s/).*//')
 B := $(CURDIR)/debian/java-package
 
-build: build-stamp 
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
 
 build-stamp:
        dh_testdir
 
 build-stamp:
        dh_testdir
-       # Add here commands to compile the indep part of the package.
        sed s/@VERSION@/$(VERSION)/ make-jpkg > make-jpkg.out
        touch $@
 
        sed s/@VERSION@/$(VERSION)/ make-jpkg > make-jpkg.out
        touch $@
 
@@ -27,7 +28,6 @@ install: build
        dh_testroot
        dh_clean -k
        dh_installdirs
        dh_testroot
        dh_clean -k
        dh_installdirs
-
        install -m 755 make-jpkg.out $(B)/usr/bin/make-jpkg
        cp lib/*.sh $(B)/usr/share/java-package/
        find $(B) -type d -name .svn | xargs -r rm -r
        install -m 755 make-jpkg.out $(B)/usr/bin/make-jpkg
        cp lib/*.sh $(B)/usr/share/java-package/
        find $(B) -type d -name .svn | xargs -r rm -r