]> git.sven.stormbind.net Git - sven/tclcurl.git/blobdiff - debian/rules
Re-add dh_installexamples
[sven/tclcurl.git] / debian / rules
index 1045a76ef37836e5433b466197499bdda99fc1a5..1e3bc3a73194e8981814cc484968d71f1cd07058 100755 (executable)
@@ -18,17 +18,19 @@ CONFIGURE_OPTIONS += \
        --prefix=/usr \
        --mandir=/usr/share/man \
        --infodir=/usr/share/info \
-       --enable-threads
+       --enable-threads \
+       --with-tcl=/usr/lib \
+       --with-tclinclude=/usr/include/tcl \
 
 
 LDFLAGS += -Wl,-z,defs -Wl,--as-needed
 
-CFLAGS += -Wall -g
+CFLAGS = -Wall -g
 
-ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-        CFLAGS += -O2
-else
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
         CFLAGS += -O0
+else
+        CFLAGS += -O2
 endif
 
 
@@ -36,8 +38,8 @@ configure: patch configure-stamp
 configure-stamp:
        dh_testdir
 
-        CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" \
-        ./configure $(CONFIGURE_OPTIONS)
+       CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" \
+       ./configure $(CONFIGURE_OPTIONS)
 
        touch configure-stamp
 
@@ -51,8 +53,8 @@ clean: cleaner unpatch
 cleaner:
        dh_testdir
        dh_testroot
-       [ ! -f Makefile ] || $(MAKE) distclean
        rm -f build-stamp configure-stamp   
+       [ ! -f Makefile ] || $(MAKE) distclean
        dh_clean
 
 install: build
@@ -60,8 +62,16 @@ install: build
        dh_testroot
        dh_clean -k
        dh_installdirs
+
        $(MAKE) install DESTDIR=$(CURDIR)/debian/tclcurl
-       dh_movefiles
+       mkdir $(CURDIR)/debian/tclcurl/usr/lib/tcltk
+       mv $(CURDIR)/debian/tclcurl/usr/lib/TclCurl* \
+               $(CURDIR)/debian/tclcurl/usr/lib/tcltk
+       rm -rf \
+               $(CURDIR)/debian/tclcurl/usr/share/man/mann \
+               $(CURDIR)/debian/tclcurl/usr/bin \
+               $(CURDIR)/debian/tclcurl/usr/include
+
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -74,6 +84,7 @@ binary-arch: build install
        dh_installdocs Changes.txt
        dh_installman
        dh_installchangelogs ChangeLog.txt
+       dh_installexamples tests
        dh_link
        dh_strip
        dh_compress
@@ -86,5 +97,4 @@ binary-arch: build install
        dh_builddeb
 
 binary: binary-indep binary-arch
-
-.PHONY: binary binary-arch binary-indep build clean configure install
+.PHONY: build clean binary-indep binary-arch binary install configure