]> git.sven.stormbind.net Git - sven/tclcurl.git/blobdiff - debian/rules
Re-add dh_installexamples
[sven/tclcurl.git] / debian / rules
index 48d1e8424f897987ec2fd6df7fad64d45a4f82b6..1e3bc3a73194e8981814cc484968d71f1cd07058 100755 (executable)
@@ -5,19 +5,42 @@
 
 include /usr/share/quilt/quilt.make
 
+
+ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
+        CONFIGURE_OPTIONS += --build $(DEB_HOST_GNU_TYPE)
+else
+        CONFIGURE_OPTIONS += --build $(DEB_BUILD_GNU_TYPE) \
+                --host $(DEB_HOST_GNU_TYPE)
+endif
+
+
+CONFIGURE_OPTIONS += \
+       --prefix=/usr \
+       --mandir=/usr/share/man \
+       --infodir=/usr/share/info \
+       --enable-threads \
+       --with-tcl=/usr/lib \
+       --with-tclinclude=/usr/include/tcl \
+
+
 LDFLAGS += -Wl,-z,defs -Wl,--as-needed
 
+CFLAGS = -Wall -g
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+        CFLAGS += -O0
+else
+        CFLAGS += -O2
+endif
+
 
 configure: patch configure-stamp
 configure-stamp:
        dh_testdir
-       ./configure \
-       --host=${DEB_HOST_GNU_TYPE} \
-       --build=${DEB_BUILD_GNU_TYPE} \
-       --prefix=/usr \
-       --mandir=/usr/share/man \
-       --infodir=/usr/share/info \
-       --enable-threads
+
+       CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" \
+       ./configure $(CONFIGURE_OPTIONS)
+
        touch configure-stamp
 
 build: configure build-stamp
@@ -30,8 +53,8 @@ clean: cleaner unpatch
 cleaner:
        dh_testdir
        dh_testroot
-       [ ! -f Makefile ] || $(MAKE) distclean
        rm -f build-stamp configure-stamp   
+       [ ! -f Makefile ] || $(MAKE) distclean
        dh_clean
 
 install: build
@@ -39,8 +62,16 @@ install: build
        dh_testroot
        dh_clean -k
        dh_installdirs
-       $(MAKE) DESTDIR=`pwd`/debian/tmp install
-       dh_movefiles
+
+       $(MAKE) install DESTDIR=$(CURDIR)/debian/tclcurl
+       mkdir $(CURDIR)/debian/tclcurl/usr/lib/tcltk
+       mv $(CURDIR)/debian/tclcurl/usr/lib/TclCurl* \
+               $(CURDIR)/debian/tclcurl/usr/lib/tcltk
+       rm -rf \
+               $(CURDIR)/debian/tclcurl/usr/share/man/mann \
+               $(CURDIR)/debian/tclcurl/usr/bin \
+               $(CURDIR)/debian/tclcurl/usr/include
+
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -51,9 +82,9 @@ binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installdocs Changes.txt
-       dh_installexamples
        dh_installman
        dh_installchangelogs ChangeLog.txt
+       dh_installexamples tests
        dh_link
        dh_strip
        dh_compress
@@ -66,5 +97,4 @@ binary-arch: build install
        dh_builddeb
 
 binary: binary-indep binary-arch
-
-.PHONY: binary binary-arch binary-indep build clean configure install
+.PHONY: build clean binary-indep binary-arch binary install configure