]> git.sven.stormbind.net Git - sven/tclcurl.git/blobdiff - debian/rules
Re-add dh_installexamples
[sven/tclcurl.git] / debian / rules
index 92d16e66d56cfb5d019e4383044203abea092e4c..1e3bc3a73194e8981814cc484968d71f1cd07058 100755 (executable)
@@ -19,16 +19,18 @@ CONFIGURE_OPTIONS += \
        --mandir=/usr/share/man \
        --infodir=/usr/share/info \
        --enable-threads \
+       --with-tcl=/usr/lib \
+       --with-tclinclude=/usr/include/tcl \
 
 
 LDFLAGS += -Wl,-z,defs -Wl,--as-needed
 
-CFLAGS += -Wall -g
+CFLAGS = -Wall -g
 
-ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-        CFLAGS += -O2
-else
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
         CFLAGS += -O0
+else
+        CFLAGS += -O2
 endif
 
 
@@ -82,6 +84,7 @@ binary-arch: build install
        dh_installdocs Changes.txt
        dh_installman
        dh_installchangelogs ChangeLog.txt
+       dh_installexamples tests
        dh_link
        dh_strip
        dh_compress