]> git.sven.stormbind.net Git - sven/tclcurl.git/blobdiff - debian/rules
Do not Build-Depend on quilt, removed --with quilt from d/rules.
[sven/tclcurl.git] / debian / rules
index 78cf4e3fb5c632888eef8647a91d266c9d2bd159..8b07692905fc705f393c65beef3d6deb5ea93f78 100755 (executable)
@@ -3,13 +3,11 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-LDFLAGS += -Wl,-z,defs -Wl,--as-needed
+export DEB_LDFLAGS_MAINT_PREPEND := -Wl,-z,defs -Wl,--as-needed
+DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
 
 %:
-       dh $@ --with quilt
-
-override_dh_clean:
-       dh_clean -Xautom4te.cache -Xtests/a.tcl~
+       dh $@
 
 override_dh_auto_configure:
        dh_auto_configure -- \
@@ -24,18 +22,21 @@ override_dh_auto_install:
        dh_auto_install --destdir=$(CURDIR)/debian/tclcurl
 
        mkdir $(CURDIR)/debian/tclcurl/usr/lib/tcltk
-       mv $(CURDIR)/debian/tclcurl/usr/lib/TclCurl* \
+       mv $(CURDIR)/debian/tclcurl/usr/lib/$(DEB_HOST_MULTIARCH)/TclCurl* \
                $(CURDIR)/debian/tclcurl/usr/lib/tcltk
        rm -rf \
                $(CURDIR)/debian/tclcurl/usr/share/man/mann \
                $(CURDIR)/debian/tclcurl/usr/bin \
-               $(CURDIR)/debian/tclcurl/usr/include
+               $(CURDIR)/debian/tclcurl/usr/include \
+               $(CURDIR)/debian/tclcurl/usr/lib/$(DEB_HOST_MULTIARCH)
 
        chmod 644 \
                $(CURDIR)/tests/*.tcl \
                $(CURDIR)/tests/multi/double.tcl \
                $(CURDIR)/tests/multi/single.tcl
 
+override_dh_auto_test:
+
 override_dh_makeshlibs:
        dh_makeshlibs
        tcltk-depends