]> git.sven.stormbind.net Git - sven/tclcurl.git/blobdiff - debian/rules
Set the permissions for the example files to 644, except for those
[sven/tclcurl.git] / debian / rules
index 92d16e66d56cfb5d019e4383044203abea092e4c..99e4f0a9ade149f7f874858b91cc229fcfe54f62 100755 (executable)
@@ -19,16 +19,18 @@ CONFIGURE_OPTIONS += \
        --mandir=/usr/share/man \
        --infodir=/usr/share/info \
        --enable-threads \
+       --with-tcl=/usr/lib \
+       --with-tclinclude=/usr/include/tcl \
 
 
 LDFLAGS += -Wl,-z,defs -Wl,--as-needed
 
-CFLAGS += -Wall -g
+CFLAGS = -Wall -g
 
-ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-        CFLAGS += -O2
-else
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
         CFLAGS += -O0
+else
+        CFLAGS += -O2
 endif
 
 
@@ -70,6 +72,11 @@ install: build
                $(CURDIR)/debian/tclcurl/usr/bin \
                $(CURDIR)/debian/tclcurl/usr/include
 
+       chmod 644 \
+               $(CURDIR)/tests/*.tcl \
+               $(CURDIR)/tests/multi/double.tcl \
+               $(CURDIR)/tests/multi/single.tcl
+
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -82,6 +89,7 @@ binary-arch: build install
        dh_installdocs Changes.txt
        dh_installman
        dh_installchangelogs ChangeLog.txt
+       dh_installexamples
        dh_link
        dh_strip
        dh_compress