]> git.sven.stormbind.net Git - sven/tclcurl.git/blobdiff - debian/rules
Set the permissions for the example files to 644, except for those
[sven/tclcurl.git] / debian / rules
index eefbb001cdadcc260870445867ba922fafd7196e..99e4f0a9ade149f7f874858b91cc229fcfe54f62 100755 (executable)
@@ -19,6 +19,8 @@ CONFIGURE_OPTIONS += \
        --mandir=/usr/share/man \
        --infodir=/usr/share/info \
        --enable-threads \
+       --with-tcl=/usr/lib \
+       --with-tclinclude=/usr/include/tcl \
 
 
 LDFLAGS += -Wl,-z,defs -Wl,--as-needed
@@ -70,6 +72,11 @@ install: build
                $(CURDIR)/debian/tclcurl/usr/bin \
                $(CURDIR)/debian/tclcurl/usr/include
 
+       chmod 644 \
+               $(CURDIR)/tests/*.tcl \
+               $(CURDIR)/tests/multi/double.tcl \
+               $(CURDIR)/tests/multi/single.tcl
+
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -82,6 +89,7 @@ binary-arch: build install
        dh_installdocs Changes.txt
        dh_installman
        dh_installchangelogs ChangeLog.txt
+       dh_installexamples
        dh_link
        dh_strip
        dh_compress