]> git.sven.stormbind.net Git - sven/tclcurl.git/blobdiff - debian/rules
Make rules work again - remove spaces and replace them with tabs
[sven/tclcurl.git] / debian / rules
index 1045a76ef37836e5433b466197499bdda99fc1a5..b88d963d4f63cdfc67288ae06dd5af97614c5c6c 100755 (executable)
@@ -18,7 +18,7 @@ CONFIGURE_OPTIONS += \
        --prefix=/usr \
        --mandir=/usr/share/man \
        --infodir=/usr/share/info \
-       --enable-threads
+       --enable-threads \
 
 
 LDFLAGS += -Wl,-z,defs -Wl,--as-needed
@@ -36,8 +36,8 @@ configure: patch configure-stamp
 configure-stamp:
        dh_testdir
 
-        CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" \
-        ./configure $(CONFIGURE_OPTIONS)
+       CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" \
+       ./configure $(CONFIGURE_OPTIONS)
 
        touch configure-stamp
 
@@ -51,8 +51,8 @@ clean: cleaner unpatch
 cleaner:
        dh_testdir
        dh_testroot
-       [ ! -f Makefile ] || $(MAKE) distclean
        rm -f build-stamp configure-stamp   
+       [ ! -f Makefile ] || $(MAKE) distclean
        dh_clean
 
 install: build
@@ -60,8 +60,8 @@ install: build
        dh_testroot
        dh_clean -k
        dh_installdirs
+
        $(MAKE) install DESTDIR=$(CURDIR)/debian/tclcurl
-       dh_movefiles
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -86,5 +86,4 @@ binary-arch: build install
        dh_builddeb
 
 binary: binary-indep binary-arch
-
-.PHONY: binary binary-arch binary-indep build clean configure install
+.PHONY: build clean binary-indep binary-arch binary install configure