]> git.sven.stormbind.net Git - sven/jattach.git/blob - jattach.spec
releasing package jattach version 2.2-1
[sven/jattach.git] / jattach.spec
1 Name:           jattach
2 Version:        2.2
3 Release:        1
4 Summary:        JVM Dynamic Attach utility
5
6 Group:          Development/Tools
7 License:        ASL 2.0
8 URL:            https://github.com/jattach/jattach
9 Vendor:         Andrei Pangin
10 Packager:       Vadim Tsesko <incubos@yandex.com>
11
12 BuildRequires:  gcc
13 BuildRequires:  make
14
15 %description
16 The utility to send commands to remote JVM via Dynamic Attach mechanism.
17
18 All-in-one jmap + jstack + jcmd + jinfo functionality in a single tiny program.
19 No installed JDK required, works with just JRE.
20
21 This is the lightweight native version of HotSpot Attach API:
22 https://docs.oracle.com/javase/8/docs/jdk/api/attach/spec/
23
24 %build
25 # Do nothing
26
27 %install
28 BIN=%{buildroot}/usr/bin
29
30 mkdir -p ${BIN}
31
32 install -p -m 555 %{_sourcedir}/bin/jattach ${BIN}
33
34 %files
35 /usr/bin/jattach
36
37 %changelog
38 * Wed Jan 10 2024 Andrei Pangin <noreply@pangin.pro> - 2.2-1
39 - Automatically concatenate jcmd arguments
40 - Fixed attach to OpenJ9 on macOS
41 - Fixed container support on Linux 3.x
42
43 * Mon Jul 25 2022 Vadim Tsesko <incubos@yandex.com> - 2.1-1
44 - Handle both tabs and spaces when parsing /proc/pid/status
45 - Socket timeout while reading response from OpenJ9 VM
46
47 * Wed Aug 11 2021 Vadim Tsesko <incubos@yandex.com> - 2.0-1
48 - Attach to OpenJ9 VMs
49 - Pass agent error codes
50 - Improved container support
51
52 * Wed Jan 09 2018 Vadim Tsesko <incubos@yandex.com> - 1.5-1
53 - Improved attach to containerized JVMs
54 - chroot support
55
56 * Wed Nov 30 2016 Vadim Tsesko <incubos@yandex.com> - 0.1-1
57 - Initial version