]> git.sven.stormbind.net Git - sven/mysqltcl.git/blobdiff - debian/rules
Include /usr/share/dpkg/buildflags.mk and use DPKG_EXPORT_BUILDFLAGS in debian/rules...
[sven/mysqltcl.git] / debian / rules
index de1946d185ecdc28ebb1a6221e9e13f70b1faa17..571e38bc4bed55b9304517452dc1286437f52e60 100755 (executable)
@@ -3,10 +3,13 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-LDFLAGS += -Wl,-z,defs -Wl,--as-needed
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/buildflags.mk
+
+DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
 
 %:
-       dh $@ --with quilt
+       dh $@ --with quilt,autoreconf
 
 override_dh_auto_configure:
        dh_auto_configure -- \
@@ -16,6 +19,7 @@ override_dh_auto_configure:
                --infodir=/usr/share/info \
                --with-tcl=/usr/lib \
                --with-tclinclude=/usr/include/tcl \
+               --with-mysql-lib=/usr/lib/$(DEB_HOST_MULTIARCH)
 
 override_dh_auto_install:
        dh_auto_install --destdir=$(CURDIR)/debian/mysqltcl