Removed the recommended dependency on libgtk1.2 from the generated control file
[sven/java-package.git] / debian / changelog
1 java-package (0.53) UNRELEASED; urgency=low
2
3   * Team upload.
4   * Added support for early access releases (Closes: #721136)
5   * Added support for GA and FCS releases
6   * Updated the package description and debian/README.Debian:
7     - no longer recommend openjdk-6
8     - mention the compatibility with Java 8
9   * Removed 'Replaces: ${j2se_package}debian' from the generated control file
10   * Adjusted the disk space required to unpack the Java 8 documentation
11   * Updated the manpages for Java 8
12   * Updated debhelper level to 7
13   * debian/rules: Use dh_prep instead of dh_clean -k
14   * Removed the recommended dependency on libstdc++5 from the generated
15     control file (used by the now unsupported IBM JDK 5)
16   * Removed the recommended dependency on libgtk1.2 from the generated
17     control file (removed from Squeeze)
18
19  -- Emmanuel Bourg <ebourg@apache.org>  Wed, 28 Aug 2013 19:34:41 +0200
20
21 java-package (0.52) unstable; urgency=low
22
23   [ Sylvestre Ledru ]
24   * Team upload
25   * Upload to unstable
26   * Ack the NMU of David Prévot (thanks!)
27   * Standards-Version updated to version 3.9.4
28   * Remove obsolete variable from the changelog
29   * Add support of ARM upstream binary by James Page and Matthias Vill.
30     Thanks guys! (Closes: #687375)
31   * Change the installation path from
32     /usr/lib/jvm/jdk-6.38-oracle-x64 or /usr/lib/jvm/jdk-7.10-oracle-x64
33     to
34     /usr/lib/jvm/jdk-6-oracle-x64 and /usr/lib/jvm/jdk-7-oracle-x64
35     Thanks to Constantin Makshin for the patch (Closes: #696227)
36
37   [ Cédric Pineau ]
38   * Fix lintian errors and warnings
39
40   [ Gabriele Giacone ]
41   * Add {mozilla,firefox}-javaplugin.so for update-java-alternatives.
42   * Fix plugin directories. Closes: #686216
43
44   [ Emmanuel Bourg ]
45   * Switched to the 3.0 (native) package format
46   * debian/control: Use canonical URLs for the Vcs-* fields
47   * debian/copyright: Switched to the Machine-readable format 1.0
48   * Updated the manpages to reflect the latest naming changes
49   * Removed the unused provided dependencies (j2sdk<version>, j2re<version>)
50   * Provide the java<version-1>-runtime and java<version-2>-runtime dependencies
51     (Closes: #691063)
52   * Provide the java<version>-sdk dependencies to match the openjdk package
53   * Use the upstream versioning scheme (i.e 7u13 instead of 7.13)
54     to match the convention used by the new openjdk packages
55   * Renamed the script files (j2sdk->jdk, j2re->jre, j2se->javase)
56
57  -- Sylvestre Ledru <sylvestre@debian.org>  Wed, 05 Jun 2013 13:43:55 +0200
58
59 java-package (0.51~exp1) experimental; urgency=low
60
61   * Add firefox-javaplugin.so alternative Closes: #673670 and LP: #1024368
62   * Add java5 and 6-{runtime|sdk|...} to the provides line in generated packages Closes: #684993 and LP: #995655
63   * Drop installation debconf note Closes: #685082
64   * Correct handling of amd64 in oracle-jdk6.1->4 and improve error message when used with unknown archives
65   * Add support for earlier oracle-jdk6 version
66
67   [Emmanuel Bourg]
68   * Improved detection of the JRE/JDK version (supports 2 digits Java 7 updates) Closes: #597294
69   * Brand and naming cleanup
70   * Documentation directory changed to be /usr/share/doc/oracle-javaV-doc (for oracle)
71
72   [Joerg Schirottke]
73   * Add mozilla-javaplugin.so alternative
74
75  -- Cédric Pineau <cedric.pineau@gmail.com>  Sat, 18 Aug 2012 11:00:34 +0200
76
77 java-package (0.50+nmu2) unstable; urgency=high
78
79   * Non-maintainer upload.
80   * Allow two digits in Java 7 updates. Closes: #597294, #698108
81
82  -- David Prévot <taffit@debian.org>  Tue, 15 Jan 2013 15:06:26 -0400
83
84 java-package (0.50+nmu1) unstable; urgency=low
85
86   * Non-maintainer upload.
87   * Drop installation debconf note. Closes: #685082
88
89  -- David Prévot <taffit@debian.org>  Thu, 06 Sep 2012 18:38:03 -0400
90
91 java-package (0.50) unstable; urgency=low
92
93   * Java-package reset for reintroduction in debian (removal of all
94     previously supported jvm, global refactoring).
95   * Add support for Oracle Java 6 (update >= 10)
96   * Add support for Oracle Java 7
97   * Add support for .jinfo file (update-java-alternatives tool)
98   * Use jdk included jre binaries (jdk/jre/bin/*)
99   * Print usage information on install
100
101   [ Sylvestre Ledru ]
102   * Long description removed
103   * debian-rules-missing-recommended-target removed
104   * maintainer-script-lacks-debhelper-token removed
105   * Declare the debian/compat to 7 to avoid warnings
106   
107   [ Michael Koch ]
108   * Remove Java plugins for all browsers (Closes: #367887).
109   * Add support for Sun Java 6 Update XX (Closes: #514364).
110
111  -- Cédric Pineau <cedric.pineau@gmail.com>  Thu, 22 Dec 2011 11:42:13 +0100
112
113 java-package (0.42) unstable; urgency=low
114
115   * Provide java*-runtime-headless and java*-sdk names for generated
116     packages.
117   * Recommend dpkg-dev and gcc. Closes: #281766, #405814.
118
119  -- Matthias Klose <doko@debian.org>  Sat, 02 Aug 2008 12:10:52 +0200
120
121 java-package (0.41) unstable; urgency=low
122
123   * Added support for new SUN JDK/JRE for amd64 downloads. Thanks to
124     Artyom Gavrichenkov for the initial patch.
125
126  -- Michael Koch <konqueror@gmx.de>  Fri, 21 Mar 2008 17:20:35 +0100
127
128 java-package (0.40) unstable; urgency=low
129
130   * Add support for ibm-java2-sdk-5.0-6.0-linux-$arch.tgz. Closes: #462399
131     Thanks to Evgeni Dobrev for the patch.
132   * Fixed spelling error in long description: debian -> Debian.
133
134  -- Michael Koch <konqueror@gmx.de>  Thu, 24 Jan 2008 22:48:46 +0100
135
136 java-package (0.39) unstable; urgency=low
137
138   * Added support for IBM JDK 6.0 final release.
139   * Updated Standard-Version to 3.7.3.
140   * Updated debhelper level to 5.
141
142  -- Michael Koch <konqueror@gmx.de>  Tue, 18 Dec 2007 07:38:34 +0100
143
144 java-package (0.38) unstable; urgency=low
145
146   * Mention SUN JDK 6 in REAME.Debian. Closes: #448258.
147   * Fixed typo when creating version number for SUN JDK 6. Closes: #451935.
148   * Fix handling of symlinks for ControlPanel, HtmlConverter and java-rmi.cgi
149     from SUN JDK 6. Closes: #448351.
150
151  -- Michael Koch <konqueror@gmx.de>  Fri, 30 Nov 2007 00:03:50 +0100
152
153 java-package (0.37) unstable; urgency=low
154
155   * Added libstdc++5 to Recommends of generated package. Closes: #446334.
156
157  -- Michael Koch <konqueror@gmx.de>  Thu, 25 Oct 2007 22:45:42 +0200
158
159 java-package (0.36) unstable; urgency=low
160
161   * Fixed package description to include more supported JDKs.
162     Closes: #447615, #447617.
163
164  -- Michael Koch <konqueror@gmx.de>  Wed, 24 Oct 2007 09:56:52 +0200
165
166 java-package (0.35) unstable; urgency=low
167
168   * Use 'date -R' instead of the deprecated '822-date'. Closes: #441229.
169   * Fix generation of .changes file. Closes: #332643.
170     Thanks to Christoph Goehre for the patch.
171   * Add possibility to add a configured revision to the version.
172     Closes: #442246. Thanks to Christoph Goehre again for the patch.
173
174  -- Michael Koch <konqueror@gmx.de>  Fri, 14 Sep 2007 17:28:13 +0200
175
176 java-package (0.34) unstable; urgency=low
177
178   * Fixed SUN JDK on amd64. Closes: #439221.
179
180  -- Michael Koch <konqueror@gmx.de>  Fri, 24 Aug 2007 00:41:54 +0200
181
182 java-package (0.33) unstable; urgency=low
183
184   * Fixed postinst scripts for SUN JDK 1.4, 5 and 6. Closes: #435632.
185
186  -- Michael Koch <konqueror@gmx.de>  Thu, 02 Aug 2007 18:43:40 +0200
187
188 java-package (0.32) unstable; urgency=low
189
190   * Added support for iceweasel. Closes: #433445.
191   * Fix dangling links for SUN Java 5. Closes: #305053.
192   * Depend on libx11-6 and libasound2. Closes: #289004.
193   * Fix building on ia64. Closes: #355465.
194
195  -- Michael Koch <konqueror@gmx.de>  Thu, 19 Jul 2007 22:51:31 +0200
196
197 java-package (0.31) unstable; urgency=low
198
199   * Reapplied changes from 0.28 to 0.29. Closes: 322843.
200
201  -- Michael Koch <konqueror@gmx.de>  Tue, 10 Jul 2007 08:16:14 +0200
202
203 java-package (0.30) unstable; urgency=low
204
205   * Added support for SUN JDK 6u2 (and following updates).
206   * Added support for ibm-java2-jre-5.0-5.0-linux-ppc.tgz.
207     Thanks to B. Zhang.
208
209  -- Michael Koch <konqueror@gmx.de>  Sun, 08 Jul 2007 09:33:29 +0200
210
211 java-package (0.29) unstable; urgency=low
212
213   * Added support for SUN Java 6 and IBM Java 6.
214     Closes: #322843, #402642, #418592, #425508, #430026.
215   * Added myself to Uploaders.
216
217  -- Michael Koch <konqueror@gmx.de>  Tue, 26 Jun 2007 17:40:04 -0100
218
219 java-package (0.28) unstable; urgency=low
220
221   * Modified to reflect migration to Subversion
222   * Bumped standards to version 3.7.2, no changes
223   * Corrected test for AMD64 architecture during plug-in detection
224   * Corrected detected version for IBM Java 5 JDK on AMD64 (Closes: #345775)
225   * Repaired alternatives handling for IBM Java 5 JREs and JDKs
226     (Closes: #338569)
227   * Corrected pathing for alternatives installation for Mozilla and
228     Firefox plugins (Closes: #341751)
229   * Relaxed architectural restrictions on plugin alternative 
230     installation for IBM Java 5 JREs and JDKs (Closes: #343837)
231   * Added plugin installation for the new packaging of Firefox 1.5 and
232     later (Closes: #341749)
233   * Modified warning suppression for dh_shlibdeps to accommodate 
234     changes in dpkg-dev (Closes: #354427)
235   * Added quotes to variable tests for maintainer name and email 
236     (Closes: #342623)
237   * Refactored architecture evaluation to eliminate repetition and
238     evaluate DEB_BUILD_GNU_TYPE correctly for i486-linux-gnu
239   * Removed dependency on 'coreutils | stat' from control file, as
240     the dependency is satisfied within essential (Closes: #370002)
241
242  -- Barry Hawkins <barry@alltc.com>  Mon, 26 Jun 2006 11:19:08 -0400
243
244 java-package (0.27) unstable; urgency=low
245
246   * Added support for IBM Java2 5.0 JREs and JDKs (Closes: #337129)
247   * Corrected missing alternatives links for all JREs and JDKs
248     (Closes: #317492)
249   * Added conditional wrapping around dh_compress to account for
250     JRE/JDKs that do not ship manpages (Closes: 301738)
251   * Removed java-common from Provides: for JRE and JDK packages.
252
253  -- Barry Hawkins <barry@bytemason.org>  Tue, 08 Nov 2005 12:16:24 -0500
254
255 java-package (0.26) unstable; urgency=low
256
257   * Update standards version to 3.6.2
258   * Resolve issues with powerpc-linux support detection (Closes: #317671)
259   * Added support for Blackdown 1.4.2+02 release (Closes: #316831)
260   * Added support for packaging Sun JDK documentation (Closes: #272971)
261   * Modified make-jpkg behavior to default the generated packages' 
262     name and email address for the maintainer to Debian Java Maintainers
263     (Closes: #325554)
264
265  -- Barry Hawkins <barry@bytemason.org>  Thu, 18 Aug 2005 00:43:17 -0400
266
267 java-package (0.25) unstable; urgency=low
268
269   * Cope with dpkg's new way of expressing architectures (Closes: #313555)
270   * Re-exec with fakeroot if needed (Closes: #310132)
271
272  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Sun, 10 Jul 2005 18:50:40 +0200
273
274 java-package (0.24) unstable; urgency=low
275
276   * Added plugin alternatives support for i386 IBM JREs and JDKs
277   * Corrected pathing for plugin alternatives to reflect difference in 
278     layout between JREs and JDKs for Sun and Blackdown (Closes: #305219,
279     #301806)
280
281  -- Barry Hawkins <barry@bytemason.org>  Wed, 21 Apr 2005 01:02:03 -0400
282
283 java-package (0.23.1) experimental; urgency=low
284
285   * Added architecture-specific pathing for plugin alternatives for 
286     Blackdown 1.3 and 1.4 JREs and JDKs
287
288  -- Barry Hawkins <barry@bytemason.org>  Wed, 06 Apr 2005 00:03:40 -0500
289
290 java-package (0.23) unstable; urgency=low
291
292   * Further expanded 1.3.1 Blackdown JRE/JDK support for i386
293   * Added architecture-specific pathing for plugin alternatives for 
294     Sun 1.4 and 1.5 JREs and JDKs (Closes: #301806)
295   * Added recommends for system elements required by applets and 
296     graphical user interface elements (Closes: #300817)
297   * Jeroen van Wolffelaar:
298     + Fixed packages description to not have too long lines, and make the 3
299       items an enumeration
300
301  -- Barry Hawkins <barry@bytemason.org>  Fri, 01 Apr 2005 00:36:40 -0500
302
303 java-package (0.22.1) experimental; urgency=low
304
305   * Corrected IBM and Blackdown JRE/JDK file size specifications
306   * Added support for additional 1.3.1 Blackdown JREs and JDKs for i386,
307     powerpc (Closes: #301092)
308   * Added installation of javaws alternative for Sun 1.5 JREs and JDKs 
309     (Closes: #300303)
310
311  -- Barry Hawkins <barry@bytemason.org>  Thu, 24 Mar 2005 13:20:18 -0500
312
313 java-package (0.22) unstable; urgency=low
314
315   * Corrected IBM JRE/JDK scripts to accurately reflect the supported 
316     IBM JDKs and JREs in the generated SUPPORTED file
317
318  -- Barry Hawkins <barry@alltc.com>  Fri, 18 Mar 2005 10:21:53 -0500
319
320 java-package (0.21) unstable; urgency=low
321
322   * Enable support for IBM JDKs and JREs for x86, amd64, powerpc, 
323     powerpc64, and s390 architectures, based upon a patch by Rico 
324     Schiekel (Closes: #264137)
325   * Enable suppport for Blackdown 1.3.1 JDK and JRE for PowerPC 
326     architecture. (Closes: #296205)
327   * Update documentation and to reflect current supported JDKs and JREs
328
329  -- Barry Hawkins <barry@alltc.com>  Mon, 14 Mar 2005 03:18:39 -0500
330
331 java-package (0.20) unstable; urgency=low
332
333   * Make the postinst & rm for generated packages #!/bin/bash, as we use
334     bash-specific features (Closes: #292179)
335   * Drop the df output parsing, use '/usr/bin/stat' instead (Closes: #293487,
336     #289006, #293350)
337   * Drop the now obsolete peer stuff from the source package
338   * Change priorities, 313 for 1.3, 314 for 1.4, etc (Closes: #292451)
339   * Don't dh_strip, fiddling with upstream's binaries apparantly breaks stuff
340     (Closes: #291238)
341
342  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Tue, 08 Feb 2005 15:04:51 +0100
343
344 java-package (0.19) unstable; urgency=low
345
346   The "Joshua Kwan <joshk@debian.org> rocks!" release.
347
348   Joshua Kwan:
349   * Unclutter Debian build system and rework package slightly so that
350     *debian packages are not needed anymore. The necessary files will be
351     included in the generated packages. (Closes: #291145, #289245, #284779)
352   * Add support for Blackdown 1.4.2+01 build. (Closes: #285405)
353   * Fix support for Sun 1.5.0 amd64 builds due to typo. (Closes: #290879)
354   * Mozilla browser plugin name changed in 1.4.2 versions. Detect and correct.
355     (Closes: #273730)
356   * Use --block-size=1M instead of -BM. (Closes: #289005, #291161)
357   * Disable support for Sun JDK 1.3 due to its dependencies on libraries
358     that are simply not available anymore. (Closes: #272972)
359   * Fix up short description a little bit.
360   * Bump Standards-Version to 3.6.1 (no changes)
361   * Be a bit more conservative with the real-root test.
362   * Remove last j2se-package references.
363   * Change Suggests on fakeroot to a Depends because it is worthless both
364     as real root and as a normal user without fakeroot.
365
366   Jeroen van Wolffelaar:
367   * Use DEBFULLNAME, DEBNAME and DEBEMAIL if available, and don't ask for
368     those values in that case. (Closes: #279653)
369   * Updated documentation regarding dropped Sun 1.3 support
370   * Work around multiline df output caused by long device names
371     (Closes: #289006)
372   * Add Replaces: for the generated packages on their *debian counterparts
373
374  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Tue, 25 Jan 2005 00:05:06 +0100
375
376 java-package (0.18) unstable; urgency=low
377
378   * Added myself to Uploaders
379   * Fix security hole (inscure temp file creation) plus lots of needless I/O
380     in free disk checking function
381   * Added support for Sun's JDK/JRE 1.5 patch levels, based on a patch by
382     Peter Marschall <peter@adpm.de> (Closes: #286718, #287857)
383   * Bail out if running as real root (works around the evil parts of Sun's
384     install script that unconditionally writes to /etc, see #266273, #280707)
385   * Fix typo in j2re.sh that apparantly with some versions of
386     bash/dpkg/whatever cause package build failure (Closes: #281780, #282902)
387   * Reduce minimum expected size a bit Sun's 1.5.0 amd64 package, it was set
388     too high (Closes: #284033)
389   * Substitute package version number at build time in the make-jpkg
390     executable (Closes: #282221)
391   * Added a README.Debian explaining the existance of make-jpkg and what
392     binary packages are supported and where to get them. Thanks Thijs
393     Kinkhorst for the draft (Closes: #283362)
394   * Added automatically-generated file SUPPORTED that lists all binary
395     filenames that are supported, thanks Alex Owen <owen@cus.org.uk> for the
396     idea (Closes: #275296)
397
398  -- Jeroen van Wolffelaar <jeroen@wolffelaar.nl>  Mon,  3 Jan 2005 18:47:47 +0100
399
400 java-package (0.17) unstable; urgency=low
401
402   * added a patch for detecting the architecture (Closes: #274844,
403     #270949, #271846). This patch should also close this one (Closes:
404     #280685).
405
406  -- Arnaud Vandyck <avdyk@debian.org>  Fri, 12 Nov 2004 17:28:38 +0100
407
408 java-package (0.16) unstable; urgency=low
409
410   * added myself as an uploader.
411   * Carlos already closed the support for 1.5 request but it seems he did
412     not upload the package (Closes: #277088).
413
414  -- Arnaud Vandyck <avdyk@debian.org>  Wed, 10 Nov 2004 16:38:44 +0100
415
416 java-package (0.15) unstable; urgency=low
417
418   * lib/sun-j2re.sh: Added support for JRE 1.5.0 (aka "Java 5.0").
419   * lib/sun-j2sdk.sh: Added support for Java SDK 1.5.0.
420
421  -- Carlos Laviola <claviola@debian.org>  Mon, 11 Oct 2004 21:08:59 -0300
422
423 java-package (0.14) unstable; urgency=low
424
425   * debian/control: Commented out the lines that generate the Debian-specific
426     packages, thus making alternatives available.
427     - Also made all of the generated packages depend on their Debian-specific
428     counterparts by default.  (Closes: #266671)
429
430  -- Carlos Laviola <claviola@debian.org>  Mon, 13 Sep 2004 03:38:31 -0300
431
432 java-package (0.13) unstable; urgency=low
433
434   * References to j2se-package are gone.  (Closes: #267642)
435   * Added support for Blackdown Java 1.4.2 RC1 JRE/SDK.  (Closes: #267643)
436
437  -- Carlos Laviola <claviola@debian.org>  Mon, 13 Sep 2004 03:17:54 -0300
438
439 java-package (0.12) unstable; urgency=low
440
441   * remove to contrib because this package depend on non-free J2SE.
442
443  -- Takashi Okamoto <tora@debian.org>  Tue,  3 Aug 2004 00:37:13 +0900
444
445 java-package (0.11) unstable; urgency=low
446
447   * change package name java-package and the command build package is 
448     make-jpkg.
449
450  -- Takashi Okamoto <tora@debian.org>  Sat, 31 Jul 2004 15:07:36 +0900
451
452 java-package (0.10) unstable; urgency=low
453
454   * change package name mpkg-j2se.
455   * not use *-j2[re|sdk]debian package. Instead of this, add package 
456     dependency to generated package. This reduce the installation for 
457     such extra package. 
458   * SUN's jdk1.5 beta2 support.
459
460  -- Takashi Okamoto <tora@debian.org>  Sun, 18 Jul 2004 13:53:36 +0900
461
462 java-package (0.9) unstable; urgency=low
463
464   * more generic support for j2re1.3.1/j2sdk1.3.1 from SUN.
465
466   * add alternative for jarsigner (in j2sdk1.4 and j2sdk1.5 from SUN).
467
468  -- Hubert Schmid <ude2@z42.de>  Sun, 23 May 2004 23:35:14 +0200
469
470 java-package (0.8) unstable; urgency=low
471
472   * java plugin: support for mozilla-firefox.
473
474  -- Hubert Schmid <ude2@z42.de>  Tue,  4 May 2004 22:39:39 +0200
475
476 java-package (0.7) unstable; urgency=low
477
478   * Optionally create .changes file.
479
480   * Add command line options: --help, --version, --full-name,
481     --email, --changes.
482
483   * Add environment variables: J2SE_PACKAGE_FULL_NAME,
484     J2SE_PACKAGE_EMAIL.
485
486  -- Hubert Schmid <ude2@z42.de>  Sat, 27 Mar 2004 23:01:08 +0100
487
488 java-package (0.6) unstable; urgency=low
489
490   * More generic support for Java2 1.4.2 from SUN.
491
492  -- Hubert Schmid <ude2@z42.de>  Thu, 11 Mar 2004 20:39:51 +0100
493
494 java-package (0.5) unstable; urgency=low
495
496   * NEW: build Blackdown J2RE 1.4.1 (gcc-2.95) and J2SDK 1.4.1 (gcc-2.95).
497
498   * NEW: support for SUN J2RE 1.5.0 beta, SUN J2SDK 1.5.0 beta.
499
500  -- Hubert Schmid <ude2@z42.de>  Sat,  7 Feb 2004 21:57:09 +0100
501
502 java-package (0.4) unstable; urgency=low
503
504   * Added support for: SUN J2RE 1.4.2_03, SUN J2SDK 1.4.2_03
505
506  -- Hubert Schmid <ude2@z42.de>  Thu, 15 Jan 2004 22:27:52 +0100
507
508 java-package (0.3) unstable; urgency=low
509
510   * Added support for: Blackdown J2RE 1.3, 1.4, J2SDK 1.3, 1.4
511
512   * Removed usage of "du --apparent-size". This should fix a problem
513     with old fileutils.
514
515  -- Hubert Schmid <ude2@z42.de>  Sun,  9 Nov 2003 21:13:38 +0100
516
517 java-package (0.2) unstable; urgency=low
518
519   * Added support for: Sun J2RE 1.3, Sun J2SDK 1.3, Sun J2SDK 1.4
520
521   * Moved peer packages into this source package.
522
523  -- Hubert Schmid <ude2@z42.de>  Thu, 30 Oct 2003 00:10:01 +0100
524
525 java-package (0.1) unstable; urgency=low
526
527   * Initial Release.
528
529  -- Hubert Schmid <j2se-package@z42.de>  Sun, 26 Oct 2003 20:06:57 +0100