]> git.sven.stormbind.net Git - sven/jattach.git/blob - jattach.spec
Update Standards-Version to 4.6.1 - no changes required.
[sven/jattach.git] / jattach.spec
1 Name:           jattach
2 Version:        2.1
3 Release:        1
4 Summary:        JVM Dynamic Attach utility
5
6 Group:          Development/Tools
7 License:        ASL 2.0
8 URL:            https://github.com/apangin/jattach
9 Vendor:         Andrei Pangin
10 Packager:       Vadim Tsesko <incubos@yandex.com>
11
12 BuildRequires:  gcc
13 BuildRequires:  make
14
15 %description
16 The utility to send commands to remote JVM via Dynamic Attach mechanism.
17
18 All-in-one jmap + jstack + jcmd + jinfo functionality in a single tiny program.
19 No installed JDK required, works with just JRE.
20
21 This is the lightweight native version of HotSpot Attach API:
22 https://docs.oracle.com/javase/8/docs/jdk/api/attach/spec/
23
24 %build
25 # Do nothing
26
27 %install
28 BIN=%{buildroot}/usr/bin
29
30 mkdir -p ${BIN}
31
32 install -p -m 555 %{_sourcedir}/bin/jattach ${BIN}
33
34 %files
35 /usr/bin/jattach
36
37 %changelog
38 * Mon Jul 25 2022 Vadim Tsesko <incubos@yandex.com> - 2.1-1
39 - Handle both tabs and spaces when parsing /proc/pid/status
40 - Socket timeout while reading response from OpenJ9 VM
41
42 * Wed Aug 11 2021 Vadim Tsesko <incubos@yandex.com> - 2.0-1
43 - Attach to OpenJ9 VMs
44 - Pass agent error codes
45 - Improved container support
46
47 * Wed Jan 09 2018 Vadim Tsesko <incubos@yandex.com> - 1.5-1
48 - Improved attach to containerized JVMs
49 - chroot support
50
51 * Wed Nov 30 2016 Vadim Tsesko <incubos@yandex.com> - 0.1-1
52 - Initial version